IAR Embedded Workbench®

IDE Project Management and Building Guide

for the

8051 Microcontroller Architecture
COPYRIGHT NOTICE
© 2015 IAR Systems AB.

No part of this document may be reproduced without the prior written consent of IAR Systems AB. The software described in this document is furnished under a license and may only be used or copied in accordance with the terms of such a license.

DISCLAIMER
The information in this document is subject to change without notice and does not represent a commitment on any part of IAR Systems. While the information contained herein is assumed to be accurate, IAR Systems assumes no responsibility for any errors or omissions.

In no event shall IAR Systems, its employees, its contractors, or the authors of this document be liable for special, direct, indirect, or consequential damage, losses, costs, charges, claims, demands, claim for lost profits, fees, or expenses of any nature or kind.

TRADEMARKS
IAR Systems, IAR Embedded Workbench, C-SPY, C-RUN, C-STAT, visualSTATE, Focus on Your Code, IAR KickStart Kit, IAR Experiment!, I-jet, I-jet Trace, I-scope, IAR Academy, IAR, and the logotype of IAR Systems are trademarks or registered trademarks owned by IAR Systems AB.

Microsoft and Windows are registered trademarks of Microsoft Corporation.

Intel® is a registered trademark of Intel Corporation.

Adobe and Acrobat Reader are registered trademarks of Adobe Systems Incorporated.

All other product names are trademarks or registered trademarks of their respective owners.

EDITION NOTICE
First edition: May 2015

Part number: UIDE8051-1

This guide applies to version 9.2x of IAR Embedded Workbench® for 8051.

Internal reference: M18, Hom7.2, tut2009.1, IJOA.
# Brief contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tables</td>
<td>13</td>
</tr>
<tr>
<td>Preface</td>
<td>15</td>
</tr>
<tr>
<td><strong>Part 1. Project management and building</strong></td>
<td>21</td>
</tr>
<tr>
<td>The development environment</td>
<td>23</td>
</tr>
<tr>
<td>Project management</td>
<td>77</td>
</tr>
<tr>
<td>Building projects</td>
<td>103</td>
</tr>
<tr>
<td>Editing</td>
<td>117</td>
</tr>
<tr>
<td><strong>Part 2. Reference information</strong></td>
<td>159</td>
</tr>
<tr>
<td>Installed files</td>
<td>161</td>
</tr>
<tr>
<td>Menu reference</td>
<td>167</td>
</tr>
<tr>
<td>General options</td>
<td>183</td>
</tr>
<tr>
<td>Compiler options</td>
<td>195</td>
</tr>
<tr>
<td>Assembler options</td>
<td>211</td>
</tr>
<tr>
<td>Custom build options</td>
<td>219</td>
</tr>
<tr>
<td>Build actions options</td>
<td>221</td>
</tr>
<tr>
<td>Linker options</td>
<td>223</td>
</tr>
<tr>
<td>Library builder options</td>
<td>239</td>
</tr>
<tr>
<td>Glossary</td>
<td>241</td>
</tr>
<tr>
<td>Index</td>
<td>257</td>
</tr>
</tbody>
</table>
Contents

Tables ...................................................................................................................... 13
Preface .................................................................................................................... 15

Who should read this guide ............................................................................. 15
  Required knowledge .................................................................................. 15

How to use this guide ...................................................................................... 15

What this guide contains .................................................................................. 16
  Part 1. Project management and building .................................................. 16
  Part 2. Reference information ...................................................................... 16

Other documentation ....................................................................................... 17
  User and reference guides ........................................................................ 17
  The online help system ............................................................................. 18
  Web sites .................................................................................................. 18

Document conventions ...................................................................................... 18
  Typographic conventions ........................................................................ 19
  Naming conventions .................................................................................. 19

Part 1. Project management and building .................................................. 21

The development environment ........................................................................ 23

Introduction to the IAR Embedded Workbench IDE .................................. 23
  Briefly about the IDE and the build toolchain ......................................... 23
  Tools for analyzing and checking your application ................................... 24
  An extensible and modular environment .................................................. 24
  Organizing the windows on the screen ....................................................... 25

Using and customizing the IDE ..................................................................... 25
  Running the IDE ....................................................................................... 26
  Organizing windows .................................................................................. 26
  Specifying tool options ............................................................................ 26
  Recognizing filename extensions ............................................................ 27
  Getting started using external analyzers .................................................... 27
  Invoking external tools from the Tools menu ............................................ 30
Adding command line commands to the Tools menu ........................................ 31
Using an external editor .................................................................................. 31

**Reference information on the IDE** ................................................................ 33
IAR Embedded Workbench IDE window .......................................................... 35
Tool Output window ........................................................................................ 38
Common Fonts options .................................................................................... 39
Key Bindings options ....................................................................................... 40
Language options ............................................................................................ 41
Editor options .................................................................................................. 42
Configure Auto Indent dialog box .................................................................... 46
External Editor options ..................................................................................... 47
Editor Setup Files options ................................................................................. 48
Editor Colors and Fonts options ....................................................................... 49
Messages options ............................................................................................. 50
Project options ................................................................................................. 52
External Analyzers options ............................................................................... 54
External Analyzer dialog box ............................................................................. 56
Source Code Control options ............................................................................ 58
Debugger options ............................................................................................... 59
Stack options ..................................................................................................... 61
Register Filter options ....................................................................................... 63
Terminal I/O options ........................................................................................ 65
Configure Tools dialog box ................................................................................ 66
Configure Viewers dialog box .......................................................................... 68
Edit Viewer Extensions dialog box .................................................................... 69
Filename Extensions dialog box ........................................................................ 70
Filename Extension Overrides dialog box ........................................................ 71
Edit Filename Extensions dialog box ................................................................. 72
Argument variables .......................................................................................... 72
Configure Custom Argument Variables dialog box ......................................... 74

**Project management** .................................................................................... 77

**Introduction to managing projects** ................................................................. 77
Briefly about managing projects ......................................................................... 77
How projects are organized ...................................................... 79
Interacting with version control systems ..................................... 82
Managing projects ........................................................................ 83
Creating and managing workspaces ........................................... 83
Viewing the workspace .............................................................. 85
Interacting with SCC-compatible systems ................................. 86
Interacting with Subversion ....................................................... 87
Reference information on managing projects .............................. 88
Workspace window ..................................................................... 89
Create New Project dialog box .................................................. 93
Configurations for project dialog box ......................................... 94
New Configuration dialog box ................................................... 94
Add Project Connection dialog box ............................................ 95
Version Control System menu for SCC ....................................... 96
Select Source Code Control Provider dialog box ................. 98
Check In Files dialog box ........................................................... 98
Check Out Files dialog box ....................................................... 99
Source code control states ......................................................... 100
Version Control System menu for Subversion ....................... 100
Subversion states ...................................................................... 102
Building projects ........................................................................ 103
Introduction to building projects ................................................. 103
Briefly about building a project .................................................. 103
Extending the toolchain ............................................................. 103
Building a project ...................................................................... 104
Setting project options using the Options dialog box .............. 105
Building your project ............................................................... 107
Correcting errors found during build ...................................... 107
Using pre- and post-build actions .............................................. 108
Building multiple configurations in a batch ......................... 109
Building from the command line .............................................. 109
Adding an external tool ............................................................ 110
Reference information on building .............................................. 111
  Options dialog box ................................................................. 112
  Build window ...................................................................... 113
  Batch Build dialog box .......................................................... 114
  Edit Batch Build dialog box .................................................... 115

Editing .............................................................................................. 117
  Introduction to the IAR Embedded Workbench editor ............. 117
    Briefly about the editor .............................................................. 117
    Briefly about source browse information ........................... 118
    Customizing the editor environment ................................ 118

Editing a file ...................................................................................... 118
  Indenting text automatically .................................................... 119
  Matching brackets and parentheses ....................................... 119
  Splitting the editor window into panes ................................ 120
  Dragging text ........................................................................... 120
  Code folding ............................................................................ 120
  Word completion ..................................................................... 121
  Code completion ..................................................................... 121
  Parameter hint ......................................................................... 121
  Using and adding code templates .......................................... 122
  Syntax coloring ....................................................................... 124
  Adding bookmarks .................................................................. 124
  Using and customizing editor commands and shortcut keys .... 124
  Displaying status information .................................................. 125

Programming assistance ............................................................. 125
  Navigating to a function .......................................................... 125
  Finding a definition or declarations of a symbol ..................... 126
  Finding references to a symbol ............................................... 126
  Finding function calls for a selected function ......................... 126
  Switching between source and header files ............................ 126
  Displaying source browse information .................................... 126
  Text searching .......................................................................... 127
  Accessing online help for reference information .................... 127
Reference information on the editor ........................................... 128
  Editor window ........................................................................... 129
  Find dialog box ........................................................................... 137
  Find in Files window ................................................................. 138
  Replace dialog box .................................................................... 139
  Find in Files dialog box .......................................................... 140
  Replace in Files dialog box ...................................................... 142
  Incremental Search dialog box ............................................... 144
  Declarations window ............................................................... 145
  Ambiguous Definitions window ............................................ 146
  References window ................................................................. 147
  Source Browser window ......................................................... 148
  Resolve File Ambiguity dialog box ........................................ 152
  Call Graph window .................................................................. 152
  Template dialog box .............................................................. 153
  Editor shortcut key summary .................................................. 154

Part 2. Reference information .................................................. 159
  Installed files ............................................................................... 161
  Directory structure ................................................................. 161
    Root directory ........................................................................ 161
    The 8051 directory .............................................................. 161
    The common directory ....................................................... 163
    The install-info directory ................................................... 163
  File types ................................................................................ 163
  Menu reference ........................................................................ 167
  Menus ..................................................................................... 167
    File menu .............................................................................. 167
    Edit menu ............................................................................. 169
    View menu ........................................................................... 173
    Project menu ........................................................................ 176
    Tools menu .......................................................................... 179
Window menu ............................................................... 181
Help menu ......................................................................... 182

General options ................................................................... 183

Description of general options ............................................. 183
Target options ...................................................................... 184
Stack/Heap .......................................................................... 186
Data Pointer ........................................................................ 187
Code Bank ........................................................................... 189
Output .................................................................................. 190
Library Configuration ........................................................ 191
Library Options .................................................................... 193
MISRA C .............................................................................. 194

Compiler options ................................................................. 195

Description of compiler options ........................................... 195
Multi-file Compilation ........................................................ 195
Language 1 .......................................................................... 196
Language 2 .......................................................................... 199
Code .................................................................................... 200
Optimizations ...................................................................... 201
Output .................................................................................. 202
List ....................................................................................... 204
Preprocessor ........................................................................ 205
Diagnostics ........................................................................... 206
Extra Options ...................................................................... 208
MISRA C .............................................................................. 208
Edit Include Directories dialog box ....................................... 209

Assembler options ................................................................. 211

Description of assembler options ....................................... 211
Language ............................................................................. 211
Output .................................................................................. 212
List ....................................................................................... 213
Preprocessor ........................................................................ 215
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Diagnostics</td>
<td>216</td>
</tr>
<tr>
<td>Extra Options</td>
<td>217</td>
</tr>
<tr>
<td><strong>Custom build options</strong></td>
<td>219</td>
</tr>
<tr>
<td>Description of custom build options</td>
<td>219</td>
</tr>
<tr>
<td>Custom Tool Configuration</td>
<td>219</td>
</tr>
<tr>
<td><strong>Build actions options</strong></td>
<td>221</td>
</tr>
<tr>
<td>Description of build actions options</td>
<td>221</td>
</tr>
<tr>
<td>Build Actions Configuration</td>
<td>221</td>
</tr>
<tr>
<td><strong>Linker options</strong></td>
<td>223</td>
</tr>
<tr>
<td>Description of linker options</td>
<td>223</td>
</tr>
<tr>
<td>Config</td>
<td>224</td>
</tr>
<tr>
<td>Output</td>
<td>226</td>
</tr>
<tr>
<td>Extra Output</td>
<td>228</td>
</tr>
<tr>
<td>List</td>
<td>229</td>
</tr>
<tr>
<td>Log</td>
<td>231</td>
</tr>
<tr>
<td>#define</td>
<td>232</td>
</tr>
<tr>
<td>Diagnostics</td>
<td>233</td>
</tr>
<tr>
<td>Checksum</td>
<td>235</td>
</tr>
<tr>
<td>Extra Options</td>
<td>237</td>
</tr>
<tr>
<td><strong>Library builder options</strong></td>
<td>239</td>
</tr>
<tr>
<td>Description of library builder options</td>
<td>239</td>
</tr>
<tr>
<td>Output</td>
<td>240</td>
</tr>
<tr>
<td><strong>Glossary</strong></td>
<td>241</td>
</tr>
<tr>
<td><strong>Index</strong></td>
<td>257</td>
</tr>
</tbody>
</table>
## Tables

1. Typographic conventions used in this guide ................................................................. 19
2. Naming conventions used in this guide ................................................................. 19
3. Argument variables .................................................................................................. 72
4. iarbuild.exe command line options ........................................................................ 109
5. Editor shortcut keys for insertion point navigation ........................................ 154
6. Editor shortcut keys for selecting text ...................................................................... 155
7. Editor shortcut keys for scrolling ............................................................................ 155
8. Miscellaneous editor shortcut keys .......................................................................... 155
9. Additional Scintilla shortcut keys .......................................................................... 156
10. The 8051 directory ............................................................................................... 161
11. The common directory ......................................................................................... 163
12. File types ............................................................................................................... 163
Preface

- Who should read this guide
- How to use this guide
- What this guide contains
- Other documentation
- Document conventions

Who should read this guide

Read this guide if you plan to develop an application using IAR Embedded Workbench and want to get the most out of the features and tools available in the IDE.

REQUIRED KNOWLEDGE

To use the tools in IAR Embedded Workbench, you should have working knowledge of:

- The architecture and instruction set of the 8051 microcontroller (refer to the chip manufacturer's documentation)
- The C or C++ programming language
- Application development for embedded systems
- The operating system of your host computer.

For more information about the other development tools incorporated in the IDE, refer to their respective documentation, see Other documentation, page 17.

How to use this guide

Each chapter in this guide covers a specific topic. In many chapters, information is typically divided in different sections based on information types:

- Concepts, which describes the topic and gives overviews of features related to the topic. Any requirements or restrictions are also listed. Read this section to learn about the topic.
- Tasks, which lists useful tasks related to the topic. For many of the tasks, you can also find step-by-step descriptions. Read this section for information about required tasks as well as for information about how to perform certain tasks.
What this guide contains

This is a brief outline and summary of the chapters in this guide.

PART 1. PROJECT MANAGEMENT AND BUILDING

This section describes the process of editing and building your application:

- **The development environment** introduces you to the IAR Embedded Workbench development environment. The chapter also demonstrates the facilities available for customizing the environment to meet your requirements.
- **Project management** describes how you can create workspaces with multiple projects, build configurations, groups, source files, and options that help you handle different versions of your applications.
- **Building projects** discusses the process of building your application.
- **Editing** contains detailed descriptions of the IAR Embedded Workbench editor, how to use it, and the facilities related to its usage. The final section also contains information about how to integrate an external editor of your choice.

PART 2. REFERENCE INFORMATION

- **Installed files** describes the directory structure and the types of files it contains.
- **Menu reference** contains detailed reference information about menus and menu commands.
- **General options** specifies the target, output, library, and MISRA C options.
- **Compiler options** specifies compiler options for language, optimizations, code, output, list file, preprocessor, diagnostics, and MISRA C.
- **Assembler options** describes the assembler options for language, output, list, preprocessor, and diagnostics.
- **Custom build options** describes the options available for custom tool configuration.

● Reference information, which gives reference information related to the topic. Read this section for information about certain GUI components. You can easily access this type of information for a certain component in the IDE by pressing F1.

If you are new to using IAR Embedded Workbench, we suggest that you first read the guide *Getting Started with IAR Embedded Workbench®* for an overview of the tools and the features that the IDE offers. The tutorials, which you can find in the IAR Information Center, will help you get started using IAR Embedded Workbench.

Finally, we recommend the *Glossary* if you should encounter any unfamiliar terms in the IAR Systems user documentation.
Other documentation

User documentation is available as hypertext PDFs and as a context-sensitive online help system in HTML format. You can access the documentation from the Information Center or from the Help menu in the IAR Embedded Workbench IDE. The online help system is also available via the F1 key.

**USER AND REFERENCE GUIDES**

The complete set of IAR Systems development tools is described in a series of guides. Information about:

- System requirements and information about how to install and register the IAR Systems products, is available in the booklet Quick Reference (available in the product box) and the *Installation and Licensing Guide*.
- Getting started using IAR Embedded Workbench and the tools it provides, is available in the guide *Getting Started with IAR Embedded Workbench®*.
- Using the IDE for project management and building, is available in the *IDE Project Management and Building Guide*.
- Using the IAR C-SPY® Debugger, is available in the *C-SPY® Debugging Guide for 8051*.
- Programming for the IAR C/C++ Compiler for 8051, is available in the *IAR C/C++ Compiler Reference Guide for 8051*.
- Using the IAR XLINK Linker, the IAR XAR Library Builder, and the IAR XLIB Librarian, is available in the *IAR Linker and Library Tools Reference Guide*.
- Programming for the IAR Assembler for 8051, is available in the *IAR Assembler Reference Guide for 8051*.
- Using the IAR DLIB Library, is available in the *DLIB Library Reference information*, available in the online help system.
- Using the IAR CLIB Library, is available in the *IAR C Library Functions Reference Guide*, available in the online help system.
- Developing safety-critical applications using the MISRA C guidelines, is available in the *IAR Embedded Workbench® MISRA C:2004 Reference Guide* or the *IAR Embedded Workbench® MISRA C:1998 Reference Guide*. 
Document conventions

- Porting application code and projects created with a previous version of the IAR Embedded Workbench for 8051, is available in the *IAR Embedded Workbench® Migration Guide*.

**Note:** Additional documentation might be available depending on your product installation.

**THE ONLINE HELP SYSTEM**

The context-sensitive online help contains:

- Information about project management, editing, and building in the IDE
- Information about debugging using the IAR C-SPY® Debugger
- Reference information about the menus, windows, and dialog boxes in the IDE
- Compiler reference information
- Keyword reference information for the DLIB library functions. To obtain reference information for a function, select the function name in the editor window and press F1. Note that if you select a function name in the editor window and press F1 while using the CLIB library, you will get reference information for the DLIB library.

**WEB SITES**

Recommended web sites:

- The chip manufacturer’s web site, that contains information and news about the microcontroller.
- The IAR Systems web site, [www.iar.com](http://www.iar.com), that holds application notes and other product information.
- The web site of the C standardization working group, [www.open-std.org/jtc1/sc22/wg14](http://www.open-std.org/jtc1/sc22/wg14).
- The web site of the C++ Standards Committee, [www.open-std.org/jtc1/sc22/wg21](http://www.open-std.org/jtc1/sc22/wg21).
- Finally, the Embedded C++ Technical Committee web site, [www.caravan.net/eczplus](http://www.caravan.net/eczplus), that contains information about the Embedded C++ standard.

**Document conventions**

When, in the IAR Systems documentation, we refer to the programming language C, the text also applies to C++, unless otherwise stated.

When referring to a directory in your product installation, for example `8051\doc`, the full path to the location is assumed, for example `c:\Program Files\IAR Systems\Embedded Workbench 7.4\8051\doc`. 
TYPOGRAPHIC CONVENTIONS

The IAR Systems documentation set uses the following typographic conventions:

<table>
<thead>
<tr>
<th>Style</th>
<th>Used for</th>
</tr>
</thead>
<tbody>
<tr>
<td>computer</td>
<td>• Source code examples and file paths.</td>
</tr>
<tr>
<td></td>
<td>• Text on the command line.</td>
</tr>
<tr>
<td></td>
<td>• Binary, hexadecimal, and octal numbers.</td>
</tr>
<tr>
<td>parameter</td>
<td>A placeholder for an actual value used as a parameter; for example</td>
</tr>
<tr>
<td></td>
<td>filename.h where filename represents the name of the file.</td>
</tr>
<tr>
<td>[option]</td>
<td>An optional part of a directive, where [ and ] are not part of the actual</td>
</tr>
<tr>
<td></td>
<td>directive, but any [, ], (, or ) are part of the directive syntax.</td>
</tr>
<tr>
<td>{option}</td>
<td>A mandatory part of a directive, where { and } are not part of the</td>
</tr>
<tr>
<td></td>
<td>actual directive, but any [, ], (, or ) are part of the directive syntax.</td>
</tr>
<tr>
<td>[option]</td>
<td>An optional part of a command.</td>
</tr>
<tr>
<td>{a</td>
<td>b</td>
</tr>
<tr>
<td>(a</td>
<td>b</td>
</tr>
<tr>
<td>bold</td>
<td>Names of menus, menu commands, buttons, and dialog boxes that appear</td>
</tr>
<tr>
<td></td>
<td>on the screen.</td>
</tr>
<tr>
<td>italic</td>
<td>• A cross-reference within this guide or to another guide.</td>
</tr>
<tr>
<td></td>
<td>• Emphasis.</td>
</tr>
<tr>
<td>...</td>
<td>An ellipsis indicates that the previous item can be repeated an arbitrary</td>
</tr>
<tr>
<td></td>
<td>number of times.</td>
</tr>
</tbody>
</table>

Identifies instructions specific to the IAR Embedded Workbench® IDE interface.

Identifies instructions specific to the command line interface.

Identifies helpful tips and programming hints.

Identifies warnings.

Table 1: Typographic conventions used in this guide

NAMING CONVENTIONS

The following naming conventions are used for the products and tools from IAR Systems®, when referred to in the documentation:

<table>
<thead>
<tr>
<th>Brand name</th>
<th>Generic term</th>
</tr>
</thead>
<tbody>
<tr>
<td>IAR Embedded Workbench® for</td>
<td>IAR Embedded Workbench®</td>
</tr>
<tr>
<td>8051</td>
<td></td>
</tr>
</tbody>
</table>

Table 2: Naming conventions used in this guide
<table>
<thead>
<tr>
<th>Brand name</th>
<th>Generic term</th>
</tr>
</thead>
<tbody>
<tr>
<td>IAR Embedded Workbench® IDE for 8051</td>
<td>the IDE</td>
</tr>
<tr>
<td>IAR C-SPY® Debugger for 8051</td>
<td>C-SPY, the debugger</td>
</tr>
<tr>
<td>IAR C-SPY® Simulator</td>
<td>the simulator</td>
</tr>
<tr>
<td>IAR C/C++ Compiler™ for 8051</td>
<td>the compiler</td>
</tr>
<tr>
<td>IAR Assembler™ for 8051</td>
<td>the assembler</td>
</tr>
<tr>
<td>IAR XLINK Linker™</td>
<td>XLINK, the linker</td>
</tr>
<tr>
<td>IAR XAR Library Builder™</td>
<td>the library builder</td>
</tr>
<tr>
<td>IAR XLIB Librarian™</td>
<td>the librarian</td>
</tr>
<tr>
<td>IAR DLIB Library™</td>
<td>the DLIB library</td>
</tr>
<tr>
<td>IAR CLIB Library™</td>
<td>the CLIB library</td>
</tr>
</tbody>
</table>

Table 2: Naming conventions used in this guide (Continued)
Part 1. Project management and building

This part contains these chapters:

- The development environment
- Project management
- Building projects
- Editing.
The development environment

- Introduction to the IAR Embedded Workbench IDE
- Using and customizing the IDE
- Reference information on the IDE.

Introduction to the IAR Embedded Workbench IDE

These topics are covered:
- Briefly about the IDE and the build toolchain
- Tools for analyzing and checking your application
- An extensible and modular environment.
- Organizing the windows on the screen.

BRIEFLY ABOUT THE IDE AND THE BUILD TOOLCHAIN

The IDE is the environment where all tools needed to build your application—the *build toolchain*—are integrated: a C/C++ compiler, C/C++ libraries, an assembler, a linker, library tools, an editor, a project manager with Make utility, and the IAR C-SPY® Debugger. The tools used specifically for building your source code are referred to as the *build tools*.

The toolchain that comes with your product package supports a specific microcontroller. However, the IDE can simultaneously contain multiple toolchains for various microcontrollers. This means that if you have IAR Embedded Workbench installed for several microcontrollers, you can choose which microcontroller to develop for.

**Note:** The compiler, assembler, and linker and library tools can also be run from a command line environment, if you want to use them as external tools in an already established project environment.
TOOLS FOR ANALYZING AND CHECKING YOUR APPLICATION

IAR Embedded Workbench comes with various types of support for analyzing and finding errors in your application, such as:

- Compiler and linker errors, warnings, and remarks
  All diagnostic messages are issued as complete, self-explanatory messages. Errors reveal syntax or semantic errors, warnings indicate potential problems, and remarks (default off) indicate deviations from the standard. Double-click a message and the corresponding source code construction is highlighted in the editor window. For more information, see the IAR C/C++ Compiler Reference Guide for 8051.

- MISRA C:1998 and 2004
  In addition to the MISRA checks in C-STAT, the IDE provides compiler checks for MISRA C:1998 and 2004. For more information, see the IAR Embedded Workbench® MISRA C:2004 Reference Guide or the IAR Embedded Workbench® MISRA C:1998 Reference Guide.

- C-SPY debugging features such as, Profiling, Code Coverage, Trace, and Power debugging
  For more information, see the C-SPY® Debugging Guide for 8051.

AN EXTENSIBLE AND MODULAR ENVIRONMENT

Although the IDE provides all the features required for your project, you can also integrate other tools. For example, you can:

- Use the Custom Build mechanism to add other tools to the toolchain, see Extending the toolchain, page 103.
- Add IAR visualSTATE to the toolchain, which means that you can add state machine diagrams directly to your project in the IDE.
- Use a version control system to keep track of different versions of your source code.
  The IDE can identify and access any third-party version control system that conforms to the SCC interface published by Microsoft. The IDE can also attach to files in a Subversion working copy.
- Add an external analyzer, for example a lint tool, of your choice to be used on whole projects, groups of files, or an individual file of your project. Typically, you might want to perform a static code analysis on your source code, using the same settings and set of source code files as when you compile. See Getting started using external analyzers, page 27.
- Add external tools to the Tools menu, for convenient access from within the IDE. For this reason, the menu might look different depending on which tools you have preconfigured to appear as menu commands.
● Configure custom argument variables, which typically can be useful if you install a third-party product and want to specify its include directory. Custom argument variables can also be used for simplifying references to files that you want to be part of your project.

**ORGANIZING THE WINDOWS ON THE SCREEN**

In the IDE, each window that you open has a default location, which depends on other currently open windows. You can position the windows and arrange a layout according to your preferences. Each window can be either *docked* or *floating*.

You can dock each window at specific places, and organize them in *tab groups*. If you rearrange the size of one docked window, the sizes of any other docked windows are adjusted accordingly. You can also make a window floating, which means it is always on top of other windows. The location and size of a floating window does not affect other currently open windows. You can move a floating window to any place on your screen, also outside of the IAR Embedded Workbench IDE main window.

Each time you open a previously saved workspace, the same windows are open, and they have the same sizes and positions.

For every project that is executed in the C-SPY environment, a separate layout is saved. In addition to the information saved for the workspace, information about all open debugger-specific windows is also saved.

**Note:** The editor window is always docked. When you open the editor window, its placement is decided automatically depending on other currently open windows. For more information about how to work with the editor window, see *Introduction to the IAR Embedded Workbench editor*, page 117.

---

**Using and customizing the IDE**

These tasks are covered:

● Running the IDE  
● Organizing windows  
● Specifying tool options  
● Recognizing filename extensions  
● Getting started using external analyzers  
● Invoking external tools from the Tools menu  
● Adding command line commands to the Tools menu  
● Using an external editor.

See also *Extending the toolchain*, page 103.
Using and customizing the IDE

For more information about customizations related to C-SPY, see the C-SPY® Debugging Guide for 8051.

RUNNING THE IDE

Click the Start button on the Windows taskbar and choose All Programs>IAR Systems>IAR Embedded Workbench for 8051>IAR Embedded Workbench.

The file iarIdePm.exe is located in the common\bin directory under your IAR Systems installation, in case you want to start the program from the command line or from within Windows Explorer.

Double-clicking the workspace filename

The workspace file has the filename extension eww. If you double-click a workspace filename, the IDE starts.

If you have several versions of IAR Embedded Workbench installed, the workspace file is opened by the most recently used version of your IAR Embedded Workbench that uses that file type, regardless of which version the project file was created in.

ORGANIZING WINDOWS

To place a window as a separate window, drag it next to another open window.

To place a window in the same tab group as another open window, drag the window you want to locate and drop it in the middle of the other window.

To make a window floating, double-click on the window’s title bar.

The status bar, located at the bottom of the IAR Embedded Workbench IDE main window, contains useful help about how to arrange windows.

SPECIFYING TOOL OPTIONS

You can find commands for customizing the IDE on the Tools menu.
To display the IDE Options dialog box, choose Tools>Options to get access to a wide variety of options:

Select a category to the left in the dialog box and you have access to the options to the right.

For more information about the various options for customizing the IDE, see Tools menu, page 179.

**RECOGNIZING FILENAME EXTENSIONS**

In the IDE, you can increase the number of recognized filename extensions. By default, each tool in the build toolchain accepts a set of standard filename extensions. Also, if you have source files with a different filename extension, you can modify the set of accepted filename extensions.

To get access to the necessary commands, choose Tools>Filename Extensions.

See Filename Extensions dialog box, page 70.

To override the default filename extension from the command line, include an explicit extension when you specify a filename.

**GETTING STARTED USING EXTERNAL ANALYZERS**

1. To add an external analyzer to the Project menu, choose Tools>Options to open the IDE Options dialog box and select the Project>External Analyzers page.

2. To configure the invocation, click Add to open the External Analyzer dialog box.
Specify the details required for the analyzer you want to be able to invoke.

Use **Output matching patterns** to specify (or choose from a list) three regular expressions for identifying warning and error messages and to find references to source file locations.

Click **OK** when you have finished.

For more information about this dialog box, see *External Analyzer dialog box*, page 56.

3. In the **IDE Options** dialog box, click **OK**.
Choose **Project>Analyze Project** and select the analyzer that you want to run, alternatively choose **Analyze File(s)** to run the analyzer on individual files.

Each of the regular expressions that you specified will be applied on each line of output from the external analyzer. Output from the analyzer is listed in the Build Log window. You can double-click any line that matches the **Location** regular expression you specified in the **External Analyzer** dialog box to jump to the corresponding location in the editor window.

**Note:** If you want to stop the analysis before it is finished, click the **Stop Build** button.
INVOKING EXTERNAL TOOLS FROM THE TOOLS MENU

1. To add an external tool to the menu, for example Notepad, choose Tools>Configure Tools to open the Configure Tools dialog box.

![Configure Tools dialog box](image)

2. Fill in the text fields according to the screenshot.

For more information about this dialog box, see Configure Tools dialog box, page 66.

3. After you have entered the appropriate information and clicked OK, the menu command you have specified is displayed on the Tools menu.

![Tools menu options](image)

**Note:** You cannot use the Configure Tools dialog box to extend the toolchain in the IDE. If you intend to add an external tool to the standard build toolchain, see Extending the toolchain, page 103.
ADDITION COMMAND LINE COMMANDS TO THE TOOLS MENU

Command line commands and calls to batch files must be run from a command shell. You can add command line commands to the Tools menu and execute them from there.

To add a command, for example Backup, to the Tools menu to make a copy of the entire project directory to a network drive:

1 Choose Tools>Configure Tools to open the Configure Tools dialog box.
2 Type or browse to the cmd.exe command shell in the Command text box.
3 Type the command line command or batch file name in the Argument text box, for example:
   /C copy c:\project\*.* F:
   Alternatively, use an argument variable to allow relocatable paths:
   /C copy $PROJ_DIR$\*.* F:
   The argument text should be specified as:
   /C name
   where name is the name of the command or batch file you want to run.
   The /C option terminates the shell after execution, to allow the IDE to detect when the tool has finished.

USING AN EXTERNAL EDITOR

The External Editor options—available by choosing Tools>Options>Editor—let you specify an external editor of your choice.

Note: While you are debugging using C-SPY, C-SPY will not use the external editor for displaying the current debug state. Instead, the built-in editor will be used.

To specify an external editor of your choice:

1 Select the option Use External Editor.
2 An external editor can be called in one of two ways, using the Type drop-down menu:
   ● Command Line calls the external editor by passing command line parameters.
   ● DDE calls the external editor by using DDE (Windows Dynamic Data Exchange).
3 If you use the command line, specify the command to pass to the editor, that is, the name of the editor and its path, for instance:
   C:\Windows\NOTEPAD.EXE
To send an argument to the external editor, type the argument in the Arguments field. For example, type $FILE_{PATH}$ to start the editor with the active file (in editor, project, or messages windows).

**Note:** Options for Register Filter and Terminal I/O are only available when the C-SPY debugger is running.

4 If you use DDE, specify the editor’s DDE service name in the Service field. In the Command field, specify a sequence of command strings to send to the editor.

The service name and command strings depend on the external editor that you are using. Refer to the user documentation of your external editor to find the appropriate settings.

The command strings should be entered as:

DDE-Topic CommandString1
DDE-Topic CommandString2
as in this example, which applies to Codewright®:

The command strings used in this example will open the external editor with a dedicated file activated. The cursor will be located on the current line as defined in the context from where the file is open, for instance when searching for a string in a file, or when double-clicking an error message in the Message window.

5 Click OK.

When you double-click a filename in the Workspace window, the file is opened by the external editor.

Variables can be used in the arguments. For more information about the argument variables that are available, see Argument variables, page 72.

Reference information on the IDE

Reference information about:
- IAR Embedded Workbench IDE window, page 35
- Tool Output window, page 38
- Common Fonts options, page 39
- Key Bindings options, page 40
- Language options, page 41
- Editor options, page 42
- Configure Auto Indent dialog box, page 46
- External Editor options, page 47
- Editor Setup Files options, page 48
Reference information on the IDE

- Editor Colors and Fonts options, page 49
- Messages options, page 50
- Project options, page 52
- External Analyzers options, page 54
- External Analyzer dialog box, page 56
- Source Code Control options, page 58
- Debugger options, page 59
- Stack options, page 61
- Register Filter options, page 63
- Terminal I/O options, page 65
- Configure Tools dialog box, page 66
- Configure Viewers dialog box, page 68
- Edit Viewer Extensions dialog box, page 69
- Filename Extensions dialog box, page 70
- Filename Extension Overrides dialog box, page 71
- Edit Filename Extensions dialog box, page 72
- Argument variables, page 72
- Configure Custom Argument Variables dialog box, page 74
IAR Embedded Workbench IDE window

The main window of the IDE is displayed when you launch the IDE.

The figure shows the window and its default layout.

Menu bar

The menu bar contains:

File
Commands for opening source and project files, saving and printing, and exiting from the IDE.

Edit
Commands for editing and searching in editor windows and for enabling and disabling breakpoints in C-SPY.

View
Commands for opening windows and controlling which toolbars to display.
Project
Commands for adding files to a project, creating groups, and running the IAR Systems tools on the current project.

Simulator
Commands specific for the C-SPY simulator. This menu is only available when you have selected the simulator driver in the Options dialog box.

C-SPY hardware driver
Commands specific for the C-SPY hardware debugger driver you are using, in other words, the C-SPY driver that you have selected in the Options dialog box. For some IAR Embedded Workbench products, the name of the menu reflects the name of the C-SPY driver you are using and for others, the name of the menu is Emulator.

Tools
User-configurable menu to which you can add tools for use with the IDE.

Window
Commands for manipulating the IDE windows and changing their arrangement on the screen.

Help
Commands that provide help about the IDE.

For more information about each menu, see Menus, page 167.

Toolbar
The IDE toolbar—available from the View menu—provides buttons for the most useful commands on the IDE menus, and a text box for typing a string to do a quick search.

For a description of any button, point to it with the mouse pointer. When a command is not available, the corresponding toolbar button is dimmed, and you will not be able to click it.
This figure shows the menu commands corresponding to each of the toolbar buttons:

**Note:** When you start C-SPY, the Download and Debug button will change to a Make and Debug button and the Debug without Downloading will change to a Restart Debugger button.

**Status bar**

The status bar at the bottom of the window can be enabled from the View menu.

The status bar displays:

- Source browser progress information
- The number of errors and warnings generated during a build
- The position of the insertion point in the editor window. When you edit, the status bar shows the current line and column number containing the insertion point.
- The character encoding
- The state of the modifier keys Caps Lock, Num Lock, and Overwrite.
- If your product package is available in more languages than English, a flag in the corner shows the language version you are using. Click the flag to change the language. The change will take force the next time you launch the IDE.
Tool Output window

The Tool Output window is available by choosing View>Messages>Tool Output.

This window displays any messages output by user-defined tools in the Tools menu, provided that you have selected the option Redirect to Output Window in the Configure Tools dialog box; see Configure Tools dialog box, page 66. When opened, this window is, by default, grouped together with the other message windows.

Context menu

This context menu is available:

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy</td>
<td>Copies the contents of the window.</td>
</tr>
<tr>
<td>Select All</td>
<td>Selects the contents of the window.</td>
</tr>
<tr>
<td>Clear All</td>
<td>Deletes the contents of the window.</td>
</tr>
</tbody>
</table>
Common Fonts options

The Common Fonts options are available by choosing Tools>Options.

Use this page to configure the fonts used for all project windows except the editor windows.

For information about how to change the font in the editor windows, see Editor Colors and Fonts options, page 49.

Fixed Width Font

Selects which font to use in the Disassembly, Register, and Memory windows.

Proportional Width Font

Selects which font to use in all windows except the Disassembly, Register, Memory, and editor windows.
Key Bindings options

The Key Bindings options are available by choosing Tools→Options.

Use this page to customize the shortcut keys used for the IDE menu commands.

Menu

Selects the menu to be edited. Any currently defined shortcut keys for the selected menu are listed below the Menu drop-down list.

List of commands

Selects the menu command you want to configure your own shortcut keys for, from this list of all commands available on the selected menu.

Press shortcut key

Type the key combination you want to use as shortcut key for the selected command. You cannot set or add a shortcut if it is already used by another command.

Primary

Choose to:

Set

Saves the key combination in the Press shortcut key field as a shortcut for the selected command in the list.

Clear

Removes the listed primary key combination as a shortcut for the selected command in the list.
The new shortcut will be displayed next to the command on the menu.

**Alias**

Choose to:

**Add**

Saves the key combination in the **Press shortcut key** field as an alias—a hidden shortcut—for the selected command in the list.

**Clear**

Removes the listed alias key combination as a shortcut for the selected command in the list.

The new shortcut will be not displayed next to the command on the menu.

**Reset All**

Reverts the shortcuts for all commands to the factory settings.

**Language options**

The **Language** options are available by choosing **Tools>Options**.

Use this page to specify the language to be used in windows, menus, dialog boxes, etc.
Language

Selects the language to be used. The available languages depend on your product package, English (United States) and Japanese.

Note: If you have installed IAR Embedded Workbench for several different toolchains in the same directory, the IDE might be in mixed languages if the toolchains are available in different languages.

Editor options

The Editor options are available by choosing Tools>Options.

Use this page to configure the editor.

For more information about the editor, see Editing, page 117.

Tab size

Specify the width of a tab character, in terms of character spaces.

Indent size

Specify the number of spaces to be used when tabulating with an indentation.
Tab Key Function

Controls what happens when you press the Tab key. Choose between:

**Insert tab**
Inserts a tab character when the Tab key is pressed.

**Indent with spaces**
Inserts an indentation (space characters) when the Tab key is pressed.

Show right margin
Displays the area of the editor window outside the right margin as a light gray field. If this option is selected, you can set the width of the text area between the left margin and the right margin. Choose to set the width based on:

**Printing edge**
Bases the width on the printable area, which is taken from the general printer settings.

**Columns**
Bases the width on the number of columns.

File Encoding
Controls file encoding. Choose between:

**Default character encoding**
Selects the character encoding to be used by default for new files. Choose between:

**System** (uses the Windows settings)
**Western European**
**UTF-8**
**Japanese (Shift-JIS)**
**Chinese Simplified (GB2312)**
**Korean (Unified Hangul Code)**
**Arabic**
**Baltic**
**Central European**
**Greek**
**Hebrew**
Reference information on the IDE

Russian
Thai
Vietnamese

Note that if you have specified a character encoding from the editor window context menu, that encoding will override this setting for the specific document.

Auto-detect character encoding
Detected automatically which character encoding that should be used when you open an existing document.

EOL characters
Selects which line break character to use when editor documents are saved. Choose between:

- **PC** (default), Windows and DOS end of line characters.
- **Unix**, UNIX end of line characters.
- **Preserve**, the same end of line character as the file had when it was opened, either PC or UNIX. If both types or neither type are present in the opened file, PC end of line characters are used.

Syntax highlighting
Makes the editor display the syntax of C or C++ applications in different text styles.

For more information about syntax highlighting, see Editor Colors and Fonts options, page 49 and Syntax coloring, page 124.

Auto indent
Makes the editor indent the new line automatically when you press Return. For C/C++ source files, click the Configure button to configure the automatic indentation; see Configure Auto Indent dialog box, page 46. For all other text files, the new line will have the same indentation as the previous line.

Show line numbers
Makes the editor display line numbers in the editor window.

Scan for changed files
Makes the editor reload files that have been modified by another tool.

If a file is open in the IDE, and the same file has concurrently been modified by another tool, the file will be automatically reloaded in the IDE. However, if you already started to edit the file, you will be prompted before the file is reloaded.
Show bookmarks

Makes the editor display a column on the left side in the editor window, with icons for compiler errors and warnings, Find in Files results, user bookmarks, and breakpoints.

Show fold margin

Makes the editor display the fold margin in the left side of the editor window. For more information, see Code folding, page 120.

Enable virtual space

Allows the insertion point to move outside the text area.

Remove trailing blanks

Removes trailing blanks from files when they are saved to disk. Trailing blanks are blank spaces between the last non-blank character and the end of line character.

Auto code completion and parameter hints

Enables code completion and parameter hints. For more information, see Editing a file, page 118.

Show source browser tooltips

Toggles the display of detailed information about the identifier that the cursor currently hovers over.

Show line break characters

Toggles the display of carriage return and line feed characters in the editor window.
Configure Auto Indent dialog box

The Configure Auto Indent dialog box is available from the IDE Options dialog box.

Use this dialog box to configure the editor’s automatic indentation of C/C++ source code.

For more information about indentation, see Indenting text automatically, page 119.

To open the Configure Auto Indent dialog box:

1. Choose Tools>Options.
2. Open the Editor page.
3. Select the Auto indent option and click the Configure button.

Opening Brace (a)

Specify the number of spaces used for indenting an opening brace.

Body (b)

Specify the number of additional spaces used for indenting code after an opening brace, or a statement that continues onto a second line.

Label (c)

Specify the number of additional spaces used for indenting a label, including case labels.

Sample code

This area reflects the settings made in the text boxes for indentation. All indentations are relative to the preceding line, statement, or other syntactic structures.
External Editor options

The External Editor options are available by choosing Tools>Options.

Use this page to specify an external editor of your choice.

Note: The contents of this dialog box depends on the setting of the Type option.

See also Using an external editor, page 31.

Use External Editor

Enables the use of an external editor.

Type

Selects the type of interface. Choose between:

● Command Line
● DDE (Windows Dynamic Data Exchange).

Editor

Specify the filename and path of your external editor. A browse button is available for your convenience.

Arguments

Specify any arguments to be passed to the editor. This is only applicable if you have selected Command Line as the interface type.
Service

Specify the DDE service name used by the editor. This is only applicable if you have selected DDE as the interface type.

The service name depends on the external editor that you are using. Refer to the user documentation of your external editor to find the appropriate settings.

Command

Specify a sequence of command strings to be passed to the editor. The command strings should be typed as:

DDE-Topic CommandString1
DDE-Topic CommandString2

This is only applicable if you have selected DDE as the interface type.

The command strings depend on the external editor that you are using. Refer to the user documentation of your external editor to find the appropriate settings.

Note: You can use variables in arguments, see Argument variables, page 72.

Editor Setup Files options

The Editor Setup Files options are available by choosing Tools>Options.

Use Custom Keyword File

Specify a text file containing keywords that you want the editor to highlight. For information about syntax coloring, see Syntax coloring, page 124.
Use Code Templates

Specify a text file with code templates that you can use for inserting frequently used code in your source file. For information about using code templates, see Using and adding code templates, page 122.

Editor Colors and Fonts options

The Editor Colors and Fonts options are available by choosing Tools>Options.

Use this page to specify the colors and fonts used for text in the editor windows. The keywords controlling syntax highlighting for assembler and C or C++ source code are specified in the files syntax_icc.cfg and syntax_asm.cfg, respectively. These files are located in the 8051\config directory.

Editor Font

Click the Font button to open the standard Font dialog box where you can choose the font and its size to be used in editor windows.
Syntax Coloring

Selects a syntax element in the list and sets the color and style for it:

**Color**
Lists colors to choose from. Choose **Custom** from the list to define your own color.

**Type Style**
Select **Normal**, **Bold**, or **Italic** style for the selected element.

**Sample**
Displays the current appearance of the selected element.

**Background Color**
Click to set the background color of the editor window.

**Note:** The **User keyword** syntax element refers to the keywords that you have listed in the custom keyword file; see *Editor Setup Files options*, page 48.

Messages options

The **Messages** options are available by choosing **Tools>Options**.

Use this page to configure the amount of output in the **Build** messages window.
Show build messages

Selects the amount of output to display in the Build messages window. Choose between:

**All**
- Shows all messages, including compiler and linker information.

**Warnings**
- Shows warnings and errors.

**Errors**
- Shows errors only.

Log in file

Select the Log build messages in file option to write build messages to a log file. Choose between:

**Append to end of file**
- Appends the messages at the end of the specified file.

**Overwrite old file**
- Replaces the contents in the file you specify.

Type the filename you want to use in the text box. A browse button is available for your convenience.

Enable All Dialogs

Enables all dialog boxes you have suppressed by selecting a Don’t show again check box, for example:
Project options

The Project options are available by choosing Tools->Options.

Use this page to set options for the Make and Build commands.

Stop build operation on
Selects when the build operation should stop. Choose between:

Never
Never stops.

Warnings
Stops on warnings and errors.

Errors
Stops on errors.

Save editor windows before building
Selects when the editor windows should be saved before a build operation. Choose between:

Never
Never saves.
The development environment

Ask
Prompts before saving.

Always
Always saves before Make or Build.

Save workspace and projects before building
Selects when a workspace and included projects should be saved before a build operation. Choose between:

Never
Never saves.

Ask
Prompts before saving.

Always
Always saves before Make or Build.

Make before debugging
Selects when a Make operation should be performed as you start a debug session. Choose between:

Never
Never performs a Make operation before a debug session.

Ask
Prompts before performing a Make operation.

Always
Always performs a Make operation before a debug session.

Reload last workspace at startup
Loads the last active workspace automatically the next time you start the IAR Embedded Workbench IDE.

Play a sound after build operations
Plays a sound when the build operations are finished.

Generate browse information
Enables the use of the Source Browser window, see Source Browser window, page 148.
Reference information on the IDE

**No source browser and build status updates when the IDE is not the foreground process**

Halts the source browser when the IDE is not the foreground process. This also means that the build status is no longer updated in the **Workspace** window. This option is useful for example, if you are using a laptop and want to reduce power consumption.

**Enable project connections**

Enables the support for setting up live project connections, see *Add Project Connection dialog box*, page 95.

**Enable parallel build**

Enables the support for parallel build. The compiler runs in several parallel processes to better use the available cores in the CPU. In the **Processes** text box, specify the number of processes you want to use. Using all available cores might result in a less responsive IDE.

**External Analyzers options**

The **External Analyzers** options are available by choosing **Tools>Options**.

Use this page to add an external analyzer to the standard build toolchain.

For more information, see *Getting started using external analyzers*, page 27.
Analyzers

Lists the external analyzers that you have added to the standard build toolchain.

Move Up

Moves the analyzer you have selected in the list one step up. This order is reflected on the Project menu.

Move Down

Moves the analyzer you have selected in the list one step down. This order is reflected on the Project menu.

Add

Displays the External Analyzer dialog box where you can add a new analyzer to the toolchain and configure the invocation of the analyzer.

Delete

Deletes the selected analyzer from the list of analyzers.

Edit

Displays the External Analyzer dialog box where you can edit the invocation details of the selected analyzer.
External Analyzer dialog box

The External Analyzer dialog box is available by choosing Tools>Options>Project>External Analyzers.

Use this dialog box to configure the invocation of the external analyzer that you want to add to the standard build toolchain.

For more information, see Getting started using external analyzers, page 27.

Name

Specify the name of the external analyzer. Note that the name must be unique.
Path

Specify the path to the analyzer’s executable file. A browse button is available for your convenience.

Arguments

Specify the arguments that you want to pass to the analyzer. Note that you can use argument variables for specifying the arguments, see Argument variables, page 72.

Location

Specify a regular expression used for finding source file locations. The regular expression is applied to each output line which will appear as text in the Build Log window. You can double-click a line that matches the regular expression you specify.

You can use the argument variables \$FILE_NAME\$, \$LINE_NUMBER\$, and \$COLUMN_NUMBER\$ to identify a filename, line number, and column number, respectively. Choose one of the predefined expressions:

\"?$FILE_NAME\"?:$LINE_NUMBER\$

Will, for example, match a location of the form file.c:17.

\"?$FILE_NAME\"?:+$LINE_NUMBER\$

Will, for example, match a location of the form file.c17.

\"?$FILE_NAME\"?

Will, for example, match a location of the form file.c.

Alternatively, you can specify your own expression. For example, the regular expression

Msg: \$FILE_NAME\$ @ \$LINE_NUMBER\$

when applied to the output string

Msg:MySourceFile.c @ 32, will identify the file as MySourceFile.c, and the line number as 32.

Warning

Any output line that matches this expression is tagged with the warning symbol.

For example, the expression (?!warning\(?-i\)): will identify any line that contains the string warning: (regardless of case) as a warning.

Error

Any output line that matches this expression is tagged with the error symbol. Errors have precedence over warnings.
For example, the expression (?!error(?-i): will identify any line that contains the string error: (regardless of case) as an error.

**Source Code Control options**

The Source Code Control options are available by choosing Tools>Options.

Use this page to configure the interaction between an IAR Embedded Workbench project and an SCC project.

**Keep items checked out when checking in**

Determines the default setting for the option Keep Checked Out in the Check In Files dialog box; see Check In Files dialog box, page 98.

**Save editor windows before performing source code control commands**

Determines whether editor windows should be saved before you perform any source code control commands. Choose between:

**Never**

Never saves editor windows before performing any source code control commands.

**Ask**

Prompts before performing any source code control commands.

**Always**

Always saves editor windows before performing any source code control commands.
Debugger options

The Debugger options are available by choosing **Tools>Options**.

Use this page to configure the debugger environment.

**When source resolves to multiple function instances**

Some source code corresponds to multiple code instances, for example template code. When specifying a source location in such code, for example when setting a source breakpoint, you can make C-SPY act on all instances or a subset of instances. Use the **Automatically choose all instances** option to let C-SPY act on all instances without asking first.

**Source code color in disassembly window**

Click the **Color** button to select the color for source code in the **Disassembly** window. To define your own color, choose **Custom** from the list.

**Step into functions**

Controls the behavior of the **Step Into** command. Choose between:

- **All functions**
  
  Makes the debugger step into all functions.
Functions with source only
Makes the debugger step only into functions for which the source code is known. This helps you avoid stepping into library functions or entering disassembly mode debugging.

STL container expansion
Specify how many elements that are shown initially when a container value is expanded in, for example, the Watch window.

Update intervals
Specify how often the contents of the Live Watch window and the Memory window are updated.
These text boxes are only available if the C-SPY driver you are using has access to the target system memory while executing your application.

Default integer format
Selects the default integer format in the Watch, Locals, and related windows.

Window classification by background color
Toggles background colors in some C-SPY windows on or off. Colors are used for differentiating types of windows; for example, all interrupt-related windows have one background color, and all watch-related windows have another color, etc.
Stack options

The Stack options are available by choosing Tools>Options or from the context menu in the Memory window.

Use this page to set options specific to the Stack window.

Enable graphical stack display and stack usage tracking
Enables the graphical stack bar available at the top of the Stack window. It also enables detection of stack overflows. For more information about the stack bar and the information it provides, see the C-SPY® Debugging Guide for 8051.

% stack usage threshold
Specify the percentage of stack usage above which C-SPY should issue a warning for stack overflow.

Warn when exceeding stack threshold
Makes C-SPY issue a warning when the stack usage exceeds the threshold specified in the % stack usage threshold option.

Warn when stack pointer is out of bounds
Makes C-SPY issue a warning when the stack pointer is outside the stack memory range.

Stack pointer(s) not valid until program reaches
Specify a location in your application code from where you want the stack display and verification to occur. The Stack window will not display any information about stack usage until execution has reached this location.
By default, C-SPY will not track the stack usage before the main function. If your application does not have a main function, for example, if it is an assembler-only project, you should specify your own start label. If this option is selected, after each reset C-SPY keeps a breakpoint on the given location until it is reached.

Typically, the stack pointer is set up in the system initialization code cstartup, but not necessarily from the very first instruction. Select this option to avoid incorrect warnings or misleading stack display for this part of the application.

**Warnings**

Selects where warnings should be issued. Choose between:

- **Log**
  - Warnings are issued in the Debug Log window.

- **Log and alert**
  - Warnings are issued in the Debug Log window and as alert dialog boxes.

**Limit stack display to**

Limits the amount of memory displayed in the Stack window by specifying a number of bytes, counting from the stack pointer. This can be useful if you have a big stack or if you are only interested in the topmost part of the stack. Using this option can improve the Stack window performance, especially if reading memory from the target system is slow. By default, the Stack window shows the whole stack, or in other words, from the stack pointer to the bottom of the stack. If the debugger cannot determine the memory range for the stack, the byte limit is used even if the option is not selected.

**Note:** The Stack window does not affect the execution performance of your application, but it might read a large amount of data to update the displayed information when the execution stops.
Register Filter options

The Register Filter options are available by choosing Tools>Options when C-SPY is running.

Use this page to define your own filters for application-specific register groups or to edit predefined filters. The register groups can then be viewed in the Register window.

Defining application-specific register groups minimizes the amount of registers displayed in the Register window and speeds up the debugging.

For more information about register groups, see the C-SPY® Debugging Guide for 8051.

To define application-specific register groups:

1. Choose Tools>Options>Register Filter.

2. Select Use register filter and specify the filename and destination of the filter file for your new group in the dialog box that appears.
3 Click **New Group** and specify the name of your group, for example **My Timer Group**.

4 In the register tree view on the **Register Filter** page, select a register and click the arrow button to add it to your group. Repeat this process for all registers that you want to add to your group.

5 Optionally, select any registers for which you want to change the integer base, and choose a suitable base.

6 When you are done, click **OK**. Your new group is now available in the **Register** window.

   If you want to add more groups to your filter file, repeat this procedure for each group you want to add.

**Use register filter**

Enables the use of register filters.

**Filter Files**

Displays a dialog box where you can select or create a new filter file. The file will be created in the same directory as your active project.

**Groups**

Lists all available register groups in the filter file, alternatively displays the new register group.

**New Group**

Click to create a new register group.

**Group members**

Shows the registers in the group currently selected in the **Groups** drop-down list.

To add registers to the group, select the registers you want to add in the list of all available registers to the left and move them using the arrow button.

To remove registers from the group, select the registers you want to remove and move them using the arrow button.
Base

Overrides the default base. Note that it is only possible to override to `float` if the size of the register is 32 bits, and to `double` if the size of the register is 64 bits.

Terminal I/O options

The Terminal I/O options are available by choosing Tools>Options when C-SPY is running.

Use this page to configure the C-SPY terminal I/O functionality.

**Input mode**

Controls how the terminal I/O input is read.

- **Keyboard**
  - Makes the input characters be read from the keyboard. Choose between:
    - **Buffered**: Buffers input characters.
    - **Direct**: Does not buffer input characters.
  
- **File**
  - Makes the input characters be read from a file. Choose between:
    - **Text**: Reads input characters from a text file.
    - **Binary**: Reads input characters from a binary file.

A browse button is available for locating the input file.
Reference information on the IDE

Input echoing
Determines whether to echo the input characters and where to echo them. The choices are:

- **Log file.** Requires that you have enabled the option **Debug>Logging>Enable log file.**
- **Terminal I/O window.**

Show target reset in **Terminal I/O window**
Displays a message in the C-SPY **Terminal I/O** window when the target resets.

**Configure Tools dialog box**
The **Configure Tools** dialog box is available from the Tools menu.
Use this dialog box to specify a tool of your choice to add to the Tools menu, for example Notepad:

- Options...
- Filename Extensions...
- Configure Viewers...
- Configure Custom Argument Variables...
- Configure Tools...
- Notepad

**Note:** If you intend to add an external tool to the standard build toolchain, see *Extending the toolchain*, page 103.

You can use variables in the arguments, which allows you to set up useful tools such as interfacing to a command line revision control system, or running an external tool on the selected file.

**Adding a command line command or batch file to the Tools menu:**

1. Type or browse to the `cmd.exe` command shell in the **Command** text box.
2. Type the command line command or batch file name in the **Argument** text box as:
   
   ```
   /C name
   ```
   
   where `name` is the name of the command or batch file you want to run.
   
   The `/C` option terminates the shell after execution, to allow the IDE to detect when the tool has finished.
   
   For an example, see *Adding command line commands to the Tools menu*, page 31.

**New**

Creates a stub for a new menu command for you to configure using this dialog box.

**Delete**

Removes the command selected in the **Menu Content** list.

**Menu Content**

Lists all menu commands that you have defined.

**Menu Text**

Specify the name of the menu command. If you add the & sign anywhere in the name, the following letter, `n` in this example, will appear as the mnemonic key for this command. The text you specify will be reflected in the **Menu Content** list.
Command
Specify the tool and its path, to be run when you choose the command from the menu. A browse button is available for your convenience.

Argument
Optional: Specify an argument for the command.

Initial Directory
Specify an initial working directory for the tool.

Redirect to Output window
Makes the IDE send any console output from the tool to the Tool Output page in the message window. Tools that are launched with this option cannot receive any user input, for instance input from the keyboard.
Tools that require user input or make special assumptions regarding the console that they execute in, will not work at all if launched with this option.

Prompt for Command Line
Makes the IDE prompt for the command line argument when the command is chosen from the Tools menu.

Tool Available
Specifies in which context the tool should be available. Choose between:
● Always
● When debugging
● When not debugging.

Configure Viewers dialog box
The Configure Viewers dialog box is available from the Tools menu.

IDE Project Management and Building Guide
for 8051

68
This dialog box lists overrides to the default associations between the document formats that IAR Embedded Workbench can handle and viewer applications.

Display area

This area contains these columns:

**Extensions**
Explicitly defined filename extensions of document formats that IAR Embedded Workbench can handle.

**Action**
The viewer application that is used for opening the document type. **Explorer Default** means that the default application associated with the specified type in Windows Explorer is used.

**New**
Displays the **Edit Viewer Extensions** dialog box; see *Edit Viewer Extensions dialog box*, page 69.

**Edit**
Displays the **Edit Viewer Extensions** dialog box; see *Edit Viewer Extensions dialog box*, page 69.

**Delete**
Removes the association between the selected filename extensions and the viewer application.

**Edit Viewer Extensions dialog box**
The **Edit Viewer Extensions** dialog box is available from the **Configure Viewers** dialog box.

![Edit Viewer Extensions dialog box](image)

Use this dialog box to specify how to open a new document type or edit the setting for an existing document type.
File name extensions

Specify the filename extension for the document type—including the separating period (.)..

Action

Selects how to open documents with the filename extension specified in the Filename extensions text box. Choose between:

Built-in text editor

Opens all documents of the specified type with the IAR Embedded Workbench text editor.

Use file explorer associations

Opens all documents of the specified type with the default application associated with the specified type in Windows Explorer.

Command line

Opens all documents of the specified type with the viewer application you type or browse your way to. You can give any command line options you would like to the tool.

Filename Extensions dialog box

The Filename Extensions dialog box is available from the Tools menu.

Use this dialog box to customize the filename extensions recognized by the build tools. This is useful if you have many source files with different filename extensions.

Toolchain

Lists the toolchains for which you have an IAR Embedded Workbench installed on your host computer. Select the toolchain you want to customize filename extensions for.

Note the * character which indicates user-defined overrides. If there is no * character, factory settings are used.
Edit

Displays the Filename Extension Overrides dialog box; see Filename Extension Overrides dialog box, page 71.

Filename Extension Overrides dialog box

The Filename Extension Overrides dialog box is available from the Filename Extensions dialog box.

This dialog box lists filename extensions recognized by the build tools.

Display area

This area contains these columns:

Tool
The available tools in the build chain.

Factory Setting
The filename extensions recognized by default by the build tool.

Override
The filename extensions recognized by the build tool if there are overrides to the default setting.

Edit

Displays the Edit Filename Extensions dialog box for the selected tool.
Edit Filename Extensions dialog box

The Edit File Extensions dialog box is available from the Filename Extension Overrides dialog box.

This dialog box lists the filename extensions recognized by the IDE and lets you add new filename extensions.

Factory setting

Lists the filename extensions recognized by default.

Override

Specify the filename extensions you want to be recognized. Extensions can be separated by commas or semicolons, and should include the leading period.

Argument variables

You can use argument variables for paths and arguments, for example when you specify include paths in the Options dialog box or whenever there is a need for a macro-like expansion that depends on the current context, for example in arguments to tools. You can use a wide range of predefined argument variables as well as create your own, see Configure Custom Argument Variables dialog box, page 74. These are the predefined argument variables:

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>$COMPILER_ARGS$</td>
<td>All compiler options except for the filename that is used when compiling using the compiler. Note that this argument variable is restricted to the Arguments text box in the External Analyzer dialog box.</td>
</tr>
<tr>
<td>$CONFIG_NAME$</td>
<td>The name of the current build configuration, for example Debug or Release.</td>
</tr>
<tr>
<td>$CUR_DIR$</td>
<td>Current directory</td>
</tr>
<tr>
<td>$CUR_LINE$</td>
<td>Current line</td>
</tr>
<tr>
<td>$DATE$</td>
<td>Today's date</td>
</tr>
</tbody>
</table>

Table 3: Argument variables
Variable | Description
--- | ---
$\$ENV\_DIR\$ | Top directory of IAR Embedded Workbench, for example `c:\program files\iar systems\embedded workbench 6.1`.
$\$EXE\_DIR\$ | Directory for executable output.
$\$FILE\_BNAME\$ | Filename without extension.
$\$FILE\_BPATH\$ | Full path without extension.
$\$FILE\_DIR\$ | Directory of active file, no filename.
$\$FILE\_FNAME\$ | Filename of active file without path.
$\$FILE\_PATH\$ | Full path of active file (in Editor, Project, or Message window).
$\$LIST\_DIR\$ | Directory for list output.
$\$OBJ\_DIR\$ | Directory for object output.
$\$PROJ\_DIR\$ | Project directory.
$\$PROJ\_FNAME\$ | Project filename without path.
$\$PROJ\_PATH\$ | Full path of project file.
$\$TARGET\_DIR\$ | Directory of primary output file.
$\$TARGET\_BNAME\$ | Filename without path of primary output file and without extension.
$\$TARGET\_BPATH\$ | Full path of primary output file without extension.
$\$TARGET\_FNAME\$ | Filename without path of primary output file.
$\$TARGET\_PATH\$ | Full path of primary output file.
$\$TOOLKIT\_DIR\$ | Directory of the active product, for example `c:\program files\iar systems\embedded workbench 7.1\8051`.
$\$USER\_NAME\$ | Your host login name.
$\$_ENVVAR_\$ | The Windows environment variable `ENVVAR`. Any name within `$_` and `_$` will be expanded to that system environment variable.
$\$MY\_CUSTOM\_VAR\$ | Your own argument variable, see `Configure Custom Argument Variables` dialog box, page 74. Any name within `$_` and `_$` will be expanded to the value you have defined.

Table 3: Argument variables (Continued)

Argument variables can also be used on some pages in the IDE Options dialog box, see Tools menu, page 179.
Configure Custom Argument Variables dialog box

The Configure Custom Argument Variables dialog box is available from the Tools menu.

Use this dialog box to define and edit your own custom argument variables. Typically, this can be useful if you install a third-party product and want to specify its include directory by using argument variables. Custom argument variables can also be used for simplifying references to files that you want to be part of your project.

Custom argument variables have one of two different scopes:

- Workspace-local variables, which are associated with a specific workspace and can only be seen by the workspace that was loaded when the variables were created.
- Global variables, which are available for use in all workspaces

You can organize your variables in named groups.

Note that when you rely on custom argument variables in the build tool settings, some of the information needed for a project to build properly might now be in a .custom_argvars file. You should therefore consider version-controlling your custom argument file, and whether to document the need for using these variables.

Workspace and Global tabs

Click the tab with the scope you want for your variable:

Workspace
- Both global and workspace-local variables are visible in the display area.
- Only workspace-local variables can be edited or removed.

Reference information on the IDE
The development environment

- Groups of variables as well as individual variables can be added or imported to the local level.
- Workspace-local variables are stored in the file `workspace_name.custom_argvars` in the same directory as the workspace file `workspace_name.eww`.

**Global**
- Only variables that are defined as global are visible in the display area.
- All variables can be edited or removed.
- Groups of variables as well as individual variables can be added or imported to the global level.
- Global variables are stored in the file `global.custom_argvars` in the same directory as the global IAR Embedded Workbench configuration file `IarIdePm.ini`.

Expand/Collapse All
Expands or collapses the view of the variables.

Hide disabled groups
Hides all groups of variables that you previously have disabled.

Enable Group / Disable Group
Enables or disables a group of variables that you have selected. The result differs depending on which tab you have open:
- The **Workspace** tab: Enabling or disabling groups will only affect the current workspace.
- The **Global** tab: Enabling will only affect newly created workspaces. These will inherit the current global state as the default for the workspace.

**Note:** You cannot use a variable that is part of a disabled group.

New Group
Opens the **New Group** dialog box where you can specify a name for a new group. When you click OK, the group is created and appears in the list of custom argument variables.

Add Variable
Opens the **Add Variables** dialog box where you can specify a name and value of a new variable to the group you have selected. When you click OK, the variable is created and appears in the list of custom argument variables.
Note that you can also add variables by importing previously defined variables. See \textbf{Import}.

\textbf{Edit Variable}

Opens the \textbf{Edit Variables} dialog box where you can edit the name and value of a selected variable. When you click OK, the variable is created and appears in the list of custom argument variables.

\textbf{Delete}

Deletes the selected group or variable.

\textbf{Import}

Opens a file browser where you can locate a \texttt{workspace\_name\.custom\_argvars} file. The file can contain variables already defined and associated with another workspace or be a file created when installing a third-party product.
Project management

- Introduction to managing projects
- Managing projects
- Reference information on managing projects.

Introduction to managing projects

These topics are covered:
- Briefly about managing projects
- How projects are organized
- Interacting with version control systems.

BRIEFLY ABOUT MANAGING PROJECTS

In a large-scale development project, with hundreds of files, you must be able to organize the files in a structure that is easily navigated and maintained by perhaps several engineers.

The IDE comes with functions that will help you stay in control of all project modules, for example, C or C++ source code files, assembler files, include files, and other related
modules. You create *workspaces* and let them contain one or several *projects*. Files can be organized in *file groups*, and options can be set on all levels—project, group, or file.

Changes are tracked so that a request for rebuild will retranslate all required modules, making sure that no executable files contain out-of-date modules.

These are some additional features of the IDE:

- Project templates to create a project that can be built and executed for a smooth development startup
- Hierarchical project representation
- Source browser with an hierarchical symbol presentation
- Options can be set globally, on groups of source files, or on individual source files
- The Make command automatically detects changes and performs only the required operations
- Project connection to set up a connection between IAR Embedded Workbench and an external tool
- Text-based project files
- Custom Build utility to expand the standard toolchain in an easy way
- Command line build with the project file as input.
Navigating between project files

There are two main different ways to navigate your project files: using the workspace window or the Source Browser window. The Workspace window displays an hierarchical view of the source files, dependency files, and output files and how they are logically grouped. The Source Browser window, on the other hand, displays information about the build configuration that is currently active in the workspace window. For that configuration, the Source Browser window displays a hierarchical view of all globally defined symbols, such as variables, functions, and type definitions. For classes, information about any base classes is also displayed.

For more information about source browsing, see Briefly about source browse information, page 118.

HOW PROJECTS ARE ORGANIZED

The IDE allows you to organize projects in an hierarchical tree structure showing the logical structure at a glance.

The IDE has been designed to suit the way that software development projects are typically organized. For example, perhaps you need to develop related versions of an application for different versions of the target hardware, and you might also want to include debugging routines into the early versions, but not in the final application.

Versions of your applications for different target hardware will often have source files in common, and you might want to be able to maintain only one unique copy of these files, so that improvements are automatically carried through to each version of the application. Perhaps you also have source files that differ between different versions of the application, such as those dealing with hardware-dependent aspects of the application.

In the following sections, the various levels of the hierarchy are described.

Projects and workspaces

Typically you create one or several projects, where each project can contain either:

- Source code files, which you can use for producing your embedded application or a library. For an example where a library project has been combined with an application project, see the example about creating and using libraries in the tutorials.

- An externally built executable file that you want to load in C-SPY. For information about how to load executable files built outside of the IDE, see the C-SPY® Debugging Guide for 8051.

If you have several related projects, you can access and work with them simultaneously. To achieve this, you can organize related projects in workspaces.
Each workspace you define can contain one or more projects, and each project must be part of at least one workspace.

Consider this example: two related applications—for instance A and B—are developed, requiring one development team each (team A and B). Because the two applications are related, they can share parts of the source code between them. The following project model can be applied:

- Three projects—one for each application, and one for the common source code
- Two workspaces—one for team A and one for team B.

Collecting the common sources in a library project (compiled but not linked object code) is both convenient and efficient, to avoid having to compile it unnecessarily. This figure illustrates this example:

![Diagram showing project and workspace structure]

**Projects and build configurations**

Often, you need to build several versions of your project, for example, for different debug solutions that require different settings for the linker and debugger. Another example is when you need a separately built executable file with special debug output for execution trace, etc. IAR Embedded Workbench lets you define multiple build configurations for each project. In a simple case, you might need just two, called Debug and Release, where the only differences are the options used for optimization, debug information, and output format. In the Release configuration, the preprocessor symbol \texttt{NDEBUG} is defined, which means the application will not contain any asserts.
Additional build configurations might be useful, for instance, if you intend to use the application on different target devices. The application is the same, but hardware-related parts of the code differ. Thus, depending on which target device you intend to build for, you can exclude some source files from the build configuration. These build configurations might fulfill these requirements for Project A:

- Project A - Device 1: Release
- Project A - Device 1: Debug
- Project A - Device 2: Release
- Project A - Device 2: Debug

**Groups**

Normally, projects contain hundreds of files that are logically related. You can define each project to contain one or more groups, in which you can collect related source files. You can also define multiple levels of subgroups to achieve a logical hierarchy. By default, each group is present in all build configurations of the project, but you can also specify a group to be excluded from a particular build configuration.

**Source files and their paths**

Source files can be located directly under the project node or in a hierarchy of groups. The latter is convenient if the amount of files makes the project difficult to survey. By default, each file is present in all build configurations of the project, but you can also specify a file to be excluded from a particular build configuration.

Only the files that are part of a build configuration will actually be built and linked into the output code.

Once a project has been successfully built, all include files and output files are displayed in the structure below the source file that included or generated them.

**Note:** The settings for a build configuration can affect which include files that are used during the compilation of a source file. This means that the set of include files associated with the source file after compilation can differ between the build configurations.

The IDE supports relative source file paths to a certain degree, for:

- Project files
  
  Paths to files part of the project file are relative if they are located on the same drive. The path is relative either to $PROJ_DIR$ or $EW_DIR$. The argument variable $EW_DIR$ is only used if the path refers to a file located in a subdirectory of $EW_DIR$ and the distance from $EW_DIR$ is shorter than the distance from $PROJ_DIR$.
Paths to files that are part of the project file are absolute if the files are located on different drives.

- **Workspace files**
  For files located on the same drive as the workspace file, the path is relative to `$PROJ_DIR$`.
  For files located on another drive than the workspace file, the path is absolute.

- **Debug files**
  If your debug image file contains debug information, any paths in the file that refer to source files are absolute.

**Drag and drop**
You can easily drag individual source files and project files from Windows Explorer to the **Workspace** window. Source files dropped on a group are added to that group. Source files dropped outside the project tree—on the **Workspace** window background—are added to the active project.

**INTERACTING WITH VERSION CONTROL SYSTEMS**
The IAR Embedded Workbench IDE can identify and access any:

- Installed third-party version control system that conforms to the Source Code Control (SCC) interface published by Microsoft corporation, see Interacting with SCC-compatible systems, page 86.
- Files that are in a Subversion (SVN) working copy, see Interacting with Subversion, page 87.

From within the IDE you can connect an IAR Embedded Workbench project to an external SCC or SVN project, and perform some of the most commonly used operations.

To connect your IAR Embedded Workbench project to a version control system, you should be familiar with the version control client application you are using. Note that some of the windows and dialog boxes that appear when you work with version control in the IDE originate from the version control system and are not described in the documentation from IAR Systems. For information about details in the client application, refer to the documentation supplied with that application.

**Note:** Different version control systems use very different terminology even for some of the most basic concepts involved. You must keep this in mind when you read the descriptions of the interaction between the IDE and the version control system.
Managing projects

These tasks are covered:

- Creating and managing workspaces
- Viewing the workspace
- Interacting with SCC-compatible systems
- Interacting with Subversion.

CREATING AND MANAGING WORKSPACES

This is a description of the overall procedure for creating the workspace, projects, groups, files, and build configurations. For a detailed step-by-step example, see *Creating an application project* in the tutorials.
The steps involved for creating and managing a workspace and its contents are:

1. **Create a workspace**
   - An empty Workspace window appears, where you collect your projects, groups, and files.

2. **Add projects to the workspace**
   - You can base a new project on a template project with preconfigured settings. Template projects are available for C/C++ applications, assembler applications, and library projects.

3. **Create groups**
   - A group of files can be added either to the project's top node or to another group within the project.

4. **Add files to the project**
   - A file can be added either to the project's top node or to a group within the project.

5. **Create new build configurations**
   - By default, each project you add has two build configurations called Debug and Release. You can base a new configuration on one of these.

6. **Exclude groups and files from a build configuration**
   - The icon that indicates the excluded group or file will change to white in the Workspace window.

7. **Remove items from a project**

**Note:** You do not have to use the same toolchain for the new build configuration as for other build configurations in the same project and it might not be necessary for you to perform all of these steps and not in this order.

The **File** menu provides commands for creating workspaces. The **Project** menu provides commands for creating projects, adding files to a project, creating groups, specifying project options, and running the IAR Systems development tools on the current projects.
VIEWING THE WORKSPACE

The Workspace window is where you access your projects and files during the application development.

1. To choose which project you want to view, click its tab at the bottom of the Workspace window.

![Workspace Window]

For each file that has been built, an Output folder icon appears, containing generated files, such as object files and list files. The latter is generated only if the list file option is enabled. The Output folder related to the project node contains generated files related to the whole project, such as the executable file and the linker map file (if the list file option is enabled).

Also, any included header files will appear, showing dependencies at a glance.

2. To display the project with a different build configuration, choose that build configuration from the drop-down list at the top of the Workspace window.

The project and build configuration you have selected are displayed highlighted in the Workspace window. It is the project and build configuration that you select from the drop-down list that are built when you build your application.

3. To display an overview of all projects in the workspace, click the Overview tab at the bottom of the Workspace window.
An overview of all project members is displayed.

The current selection in the Build Configuration drop-down list is also highlighted when an overview of the workspace is displayed.

**INTERACTING WITH SCC-COMPATIBLE SYSTEMS**

In any SCC-compatible system, you use a client application to maintain a central archive. In this archive you keep the working copies of the files of your project. The version control integration in IAR Embedded Workbench allows you to conveniently perform some of the most common version control operations directly from within the IDE. However, several tasks must still be performed in the client application.

**To connect an IAR Embedded Workbench project to an SCC system:**

1. In the Microsoft SCC-compatible client application, set up an SCC project.
2. In the IDE, connect your application project to the SCC project.

**Setting up an SCC project in the SCC client application**

Use your SCC client tools to set up a working directory for the files in your IAR Embedded Workbench project that you want to control using your SCC system. The files can be placed in one or more nested subdirectories, all located under a common root. Specifically, all source files must reside in the same directory as the .ewp project file, or in subdirectories of this directory.

For information about the steps involved, refer to the documentation supplied with the SCC client application.

**To connect application projects to the SCC project**

1. In the Workspace window, select the project for which you have created an SCC project.
2 From the Project menu, choose Version Control System>Connect Project To SCC Project. This command is also available from the context menu that appears when you right-click in the Workspace window.

Note: The commands on the Source Code Control submenu are available when you have successfully connected your application project to your SCC project.

3 If you have SCC-compatible systems from different vendors installed, you will be prompted to choose which system you want to connect to.

4 An SCC-specific dialog box will appear where you can navigate to the SCC project that you have set up.

For more information about the commands available for accessing the SCC system, see Version Control System menu for SCC, page 96.

Viewing the SCC states

When your IAR Embedded Workbench project has been connected to the SCC project, a column that contains status information for version control will appear in the Workspace window. Different icons are displayed depending on the state.

There are also icons for some combinations of these states. Note that the interpretation of these states depends on the SCC client application you are using. For more information about the icons and the different states they represent, see Source code control states, page 100.

Configuring the interaction between the IDE and SCC

To configure the interaction between the IDE and SCC, choose Tools>Options and click the Source Code Control tab. For more information about the available commands, see Source Code Control options, page 58.

INTERACTING WITH SUBVERSION

The version control integration in IAR Embedded Workbench allows you to conveniently perform some of the most common Subversion operations directly from within the IDE, using the client applications `svn.exe` and `TortoiseProc.exe`.

To connect an IAR Embedded Workbench project to a Subversion system:

1 In the Subversion client application, set up a Subversion working copy.

2 In the IDE, connect your application project to the Subversion working copy.

To set up a Subversion working copy:

1 To use the Subversion integration in the IDE, make sure that `svn.exe` and `TortoiseProc.exe` are in your path.
2 Check out a working copy from a Subversion repository.

The files that constitute your project do not have to come from the same working copy; all files in the project are treated individually. However, note that TortoiseProc.exe does not allow you to simultaneously, for example, check in files coming from different repositories.

To connect application projects to the Subversion working copy:

1 In the Workspace window, select the project for which you have created a Subversion working copy.

2 From the Project menu, choose Version Control System>Connect Project to Subversion. This command is also available from the context menu that appears when you right-click in the Workspace window.

For more information about the commands available for accessing the Subversion working copy, see Version Control System menu for Subversion, page 100.

Viewing the Subversion states

When your IAR Embedded Workbench project has been connected to the Subversion working copy, a column that contains status information for version control will appear in the Workspace window. Various icons are displayed, where each icon reflects the Subversion state, see Subversion states, page 102.
See also:
*Source Code Control options*, page 58.

**Workspace window**

The *Workspace* window is available from the *View* menu.

![Workspace Window Diagram]

Use this window to access your projects and files during the application development.

**Drop-down list**

At the top of the window there is a drop-down list where you can choose a build configuration to display in the window for a specific project.

**The display area**

This area contains four columns.

The *Files* column displays the name of the current workspace and a tree representation of the projects, groups and files included in the workspace. One or more of these icons are displayed:

- ![Workspace Icon]
- ![Project Icon]
The column that contains status information about option overrides can have one of three icons for each level in the project:

- Blank: There are no settings/overrides for this file/group.
- Black check mark: There are local settings/overrides for this file/group.
- Red check mark: There are local settings/overrides for this file/group, but they are either identical to the inherited settings or they are ignored because you use multi-file compilation, which means that the overrides are not needed.

The column that contains build status information can have one of three icons for each file in the project:

- Blank: The file will not be rebuilt next time the project is built.
- Red star: The file will be rebuilt next time the project is built.
The column contains status information about version control. For information about the various icons, see:
- *Source code control states*, page 100
- *Subversion states*, page 102.

Use the tabs at the bottom of the window to choose which project to display. Alternatively, you can choose to display an overview of the entire workspace.

For more information about project management and using the *Workspace* window, see the *Introduction to managing projects*, page 77.

### Context menu

This context menu is available:

<table>
<thead>
<tr>
<th>Options...</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
</tr>
<tr>
<td>Context</td>
</tr>
<tr>
<td>Gearwheel</td>
</tr>
<tr>
<td>Options...</td>
</tr>
<tr>
<td>Make</td>
</tr>
<tr>
<td>Remove</td>
</tr>
<tr>
<td>Version...</td>
</tr>
<tr>
<td>Control</td>
</tr>
<tr>
<td>Containing Folder...</td>
</tr>
<tr>
<td>File Properties...</td>
</tr>
</tbody>
</table>

These commands are available:

#### Options

Displays a dialog box where you can set options for each build tool, for the selected item in the *Workspace* window. You can set options for the entire project, for a group of files, or for an individual file. See *Setting project options using the Options dialog box*, page 105.

#### Make

Brings the current target up to date by compiling, assembling, and linking only the files that have changed since the last build.
Compile
Compiles or assembles the currently active file as appropriate. You can choose the file either by selecting it in the Workspace window, or by selecting the editor window containing the file you want to compile.

Rebuild All
Recompiles and relinks all files in the selected build configuration.

Clean
Deletes intermediate files.

Stop Build
Stops the current build operation.

Add>Add Files
Displays a dialog box where you can add files to the project.

Add>Add filename
Adds the indicated file to the project. This command is only available if there is an open file in the editor.

Add>Add Group
Displays the Add Group dialog box where you can add new groups to the project. For more information about groups, see Groups, page 81.

Remove
Removes selected items from the Workspace window.

Rename
Displays the Rename Group dialog box where you can rename a group. For more information about groups, see Groups, page 81.

Version Control System
Opens a submenu with commands for source code control, see Version Control System menu for SCC, page 96.

Open Containing Folder
Opens the File Explorer that displays the directory where the selected file resides.

File Properties
Displays a standard File Properties dialog box for the selected file.

Set as Active
Sets the selected project in the overview display to be the active project. It is the active project that will be built when the Make command is executed.
Create New Project dialog box

The Create New Project dialog box is available from the Project menu.

Use this dialog box to create a new project based on a template project. Template projects are available for C/C++ applications, assembler applications, and library projects. You can also create your own template projects.

**Tool chain**

Selects the target to build for. If you have several versions of IAR Embedded Workbench for different targets installed on your host computer, the drop-down list might contain some or all of these targets.

**Project templates**

Select a template to base the new project on, from this list of available template projects.

**Description**

A description of the currently selected template.
Configurations for project dialog box

The Configurations for project dialog box is available by choosing Project>Edit Configurations.

![Configurations for project](image)

Use this dialog box to define new build configurations for the selected project; either entirely new, or based on a previous project.

**Configurations**

Lists existing configurations, which can be used as templates for new configurations.

**New**

Displays a dialog box where you can define new build configurations, see New Configuration dialog box, page 94.

**Remove**

Removes the configuration that is selected in the Configurations list.

New Configuration dialog box

The New Configuration dialog box is available by clicking New in the Configurations for project dialog box.

![New Configuration](image)
Use this dialog box to define new build configurations; either entirely new, or based on any currently defined configuration.

**Name**

Type the name of the build configuration.

**Tool chain**

Specify the target to build for. If you have several versions of IAR Embedded Workbench for different targets installed on your host computer, the drop-down list might contain some or all of these targets.

**Based on configuration**

Selects a currently defined build configuration to base the new configuration on. The new configuration will inherit the project settings and information about the factory settings from the old configuration. If you select None, the new configuration will be based strictly on the factory settings.

**Factory settings**

Select the default factory settings that you want to apply to your new build configuration. These factory settings will be used by your project if you click the Factory Settings button in the Options dialog box.

Choose between:

- **Debug**
  - Factory settings suitable for a debug build configuration.
- **Release**
  - Factory settings suitable for a release build configuration.

**Add Project Connection dialog box**

The Add Project Connection dialog box is available from the Project menu.

Use this dialog box to set up a project connection between IAR Embedded Workbench and an external tool. This can, for example, be useful if you want IAR Embedded Workbench to build source code files provided by the external tool. The source files will automatically be added to your project. If the set of files changes, the new set of files will automatically be used when the project is built in IAR Embedded Workbench.
To disable support for this, see Project options, page 52.

**Connect using**

Chooses the external tool that you want to set up a connection with.

**OK**

Displays a dialog box where you specify the connection.

### Version Control System menu for SCC

The Version Control System submenu is available from the Project menu and from the context menu in the Workspace window.

This is the menu for SCC-compatible systems:

- Check In...
- Check Out...
- Undo Checkout
- Get Latest Version
- Compare...
- Summary...
- Properties...

**Note:** The contents of the Version Control System submenu reflect the version control system in use, either an SCC-compatible system or Subversion.

For more information about interacting with an external version control system, see Interacting with version control systems, page 82.

**Menu commands**

These commands are available for SCC:

**Check In**

Displays the Check In Files dialog box where you can check in the selected files; see Check In Files dialog box, page 98. Any changes you have made in the files will be stored in the archive. This command is enabled when currently checked-out files are selected in the Workspace window.
Check Out

Checks out the selected file or files. Depending on the SCC (Source Code Control) system you are using, a dialog box might appear; see Check Out Files dialog box, page 99. This means you get a local copy of the file(s), which you can edit. This command is enabled when currently checked-in files are selected in the Workspace window.

Undo Checkout

Reverts the selected files to the latest archived version; the files are no longer checked out. Any changes you have made to the files will be lost. This command is enabled when currently checked-out files are selected in the Workspace window.

Get Latest Version

Replaces the selected files with the latest archived version.

Compare

Displays—in an SCC-specific window—the differences between the local version and the most recent archived version.

History

Displays SCC-specific information about the revision history of the selected file.

Properties

Displays information available in the version control system for the selected file.

Refresh

Updates the version control system display status for all the files that are part of the project. This command is always enabled for all projects under version control.

Connect Project to SCC Project

Displays a dialog box, which originates from the SCC client application, to let you create a connection between the selected IAR Embedded Workbench project and an SCC project; the IAR Embedded Workbench project will then be an SCC-controlled project. After creating this connection, a special column that contains status information will appear in the Workspace window.

Disconnect Project from SCC Project

Removes the connection between the selected IAR Embedded Workbench project and an SCC project; your project will no longer be an SCC-controlled project. The column in the Workspace window that contains SCC status information will no longer be visible for that project.
Select Source Code Control Provider dialog box

The Select Source Code Control Provider dialog box is displayed if several SCC systems from different vendors are available.

Use this dialog box to choose the SCC system you want to use.

Check In Files dialog box

The Check In Files dialog box is available by choosing the Project>Source Code Control>Check In command, alternatively available from the Workspace window context menu.

Comment

Specify a comment—typically a description of your changes—that will be stored in the archive together with the file revision. This text box is only enabled if the SCC system supports adding comments at check in.
Keep checked out

Specifies that the files will continue to be checked out after they have been checked in. Typically, this is useful if you want to make your modifications available to other members in your project team, without stopping your own work with the file.

Advanced

Displays a dialog box, originating from the SCC client application, that contains advanced options. This button is only available if the SCC system supports setting advanced options at check in.

Files

Lists the files that will be checked in. The list will contain all files that were selected in the Workspace window when the Check In Files dialog box was opened.

Check Out Files dialog box

The Check Out Files dialog box is available by choosing the Project>Source Code Control>Check Out command, alternatively available from the Workspace window context menu. However, this dialog box is only available if the SCC system supports adding comments at check out or advanced options.

Comment

Specify a comment—typically the reason why the file is checked out—that will be placed in the archive together with the file revision. This text box is only enabled if the SCC system supports the adding of comments at check out.
Advanced
Displays a dialog box, originating from the SCC client application, that contains advanced options. This button is only available if the SCC system supports setting advanced options at check out.

Files
Lists files that will be checked out. The list will contain all files that were selected in the Workspace window when the Check Out Files dialog box was opened.

Source code control states
Each source code-controlled file can be in one of several states.

- (blank) Checked out to you. The file is editable.
- (checkmark) Checked out to you. The file is editable and you have modified the file.
- (gray padlock) Checked in. In many SCC systems this means that the file is write-protected.
- (gray padlock) Checked in. A new version is available in the archive.
- (red padlock) Checked out exclusively to another user. In many SCC systems, this means that you cannot check out the file.
- (red padlock) Checked out exclusively to another user. A new version is available in the archive. In many SCC systems, this means that you cannot check out the file.

Note: The source code control in the IAR Embedded Workbench IDE depends on the information provided by the SCC system. If the SCC system provides incorrect or incomplete information about the states, the IDE might display incorrect symbols.

Version Control System menu for Subversion
The Version Control System submenu is available from the Project menu and from the context menu in the Workspace window.
This is the menu for Subversion:

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Commit</td>
<td>Displays Tortoise’s Commit dialog box for the selected file(s).</td>
</tr>
<tr>
<td>Add</td>
<td>Displays Tortoise’s Add dialog box for the selected file(s).</td>
</tr>
<tr>
<td>Revert</td>
<td>Displays Tortoise’s Revert dialog box for the selected file(s).</td>
</tr>
<tr>
<td>Update</td>
<td>Opens Tortoise’s Update window for the selected file(s).</td>
</tr>
<tr>
<td>Diff</td>
<td>Opens Tortoise’s Diff window for the selected file(s).</td>
</tr>
<tr>
<td>Log</td>
<td>Opens Tortoise’s Log window for the selected file(s).</td>
</tr>
<tr>
<td>Properties</td>
<td>Displays information available in the version control system for the selected file.</td>
</tr>
<tr>
<td>Refresh</td>
<td>Updates the version control system display status for all files that are part of the project. This command is always enabled for all projects under the version control system.</td>
</tr>
</tbody>
</table>

**Note:** The contents of the Version Control System submenu reflect the version control system in use, either an SCC-compatible system or Subversion.

For more information about interacting with an external version control system, see *Interacting with version control systems*, page 82.
Connect Project to SVN Project

Checks whether \texttt{svn.exe} and \texttt{TortoiseProc.exe} are in the path and then enables the connection between the IAR Embedded Workbench project and an existing checked-out working copy. After this connection has been created, a special column that contains status information appears in the \texttt{Workspace} window. Note that you must check out the source files from outside the IDE.

Disconnect Project from SVN Project

Removes the connection between the selected IAR Embedded Workbench project and Subversion. The column in the \texttt{Workspace} window that contains SVN status information will no longer be visible for that project.

Subversion states

Each Subversion-controlled file can be in one of several states.

\begin{itemize}
\item[(blue A)] Added.
\item[(red C)] Conflicted.
\item[(red D)] Deleted.
\item[(red I)] Ignored.
\item[(blank)] Not modified.
\item[(red M)] Modified.
\item[(red R)] Replaced.
\item[(gray X)] An unversioned directory created by an external definition.
\item[(gray question mark)] Item is not under version control.
\item[(black exclamation mark)] Item is missing—removed by a non-SVN command—or incomplete.
\item[(red tilde)] Item obstructed by an item of a different type.
\end{itemize}

\textbf{Note:} The version control system in the IAR Embedded Workbench IDE depends on the information provided by Subversion. If Subversion provides incorrect or incomplete information about the states, the IDE might display incorrect symbols.
Building projects

- Introduction to building projects
- Building a project
- Reference information on building.

Introduction to building projects

These topics are covered:
- Briefly about building a project
- Extending the toolchain.

BRIEFLY ABOUT BUILDING A PROJECT

The build process consists of these steps:
- Setting project options
- Building the project, either an application project or a library project
- Correcting any errors detected during the build procedure.

To make the build process more efficient, you can use the Batch Build command. This gives you the possibility to perform several builds in one operation. If necessary, you can also specify pre-build and post-build actions.

In addition to using the IAR Embedded Workbench IDE to build projects, you can also use the command line utility iarbuild.exe.

For examples of building application and library projects, see the tutorials in the Information Center. For more information about building library projects, see the IAR C/C++ Compiler Reference Guide for 8051.

EXTENDING THE TOOLCHAIN

IAR Embedded Workbench provides a feature—Custom Build—which lets you extend the standard toolchain. This feature is used for executing external tools (not provided by IAR Systems). You can make these tools execute each time specific files in your project have changed.

If you specify custom build options on the Custom tool configuration page, the build commands treat the external tool and its associated files in the same way as the standard tools within the IAR Embedded Workbench IDE and their associated files. The relation
Building a project

between the external tool and its input files and generated output files is similar to the relation between the C/C++ Compiler, .c files, .h files, and .r51 files. For more information about available custom build options, see Custom build options, page 219.

You specify filename extensions of the files used as input to the external tool. If the input file has changed since you last built your project, the external tool is executed; just as the compiler executes if a .c file has changed. In the same way, any changes in additional input files (for instance include files) are detected.

You must specify the name of the external tool. You can also specify any necessary command line options needed by the external tool, and the name of the output files generated by the external tool. Note that you can use argument variables for some of the file information.

You can specify custom build options to any level in the project tree. The options you specify are inherited by any sublevel in the project tree.

Tools that can be added to the toolchain

Some examples of external tools, or types of tools, that you can add to the IAR Embedded Workbench toolchain are:

- Tools that generate files from a specification, such as Lex and YACC
- Tools that convert binary files—for example files that contain bitmap images or audio data—to a table of data in an assembler or C source file. This data can then be compiled and linked together with the rest of your application.

For more information, see Adding an external tool, page 110.

Building a project

These tasks are covered:

- Setting project options using the Options dialog box
- Building your project
- Correcting errors found during build
- Using pre- and post-build actions
- Building multiple configurations in a batch
- Building from the command line
- Adding an external tool.
SETTING PROJECT OPTIONS USING THE OPTIONS DIALOG BOX

Before you can set project options, choose a build configuration.

By default, the IDE creates two build configurations when a project is created—**Debug** and **Release**. Every build configuration has its own project settings, which are independent of the other configurations.

For example, a configuration that is used for debugging would not be highly optimized, and would produce output that suits the debugging. Conversely, a configuration for building the final application would be highly optimized, and produce output that suits a flash or PROM programmer.
2 Decide which level you want to set the options on: the entire project, groups of files, or for an individual file. Select that level in the Workspace window (in this example, the project level) and choose Options from the context menu to display the Options dialog box.

![Options dialog box](image)

*Note:* There is one important restriction on setting options. If you set an option on group or file level (group or file level override), no options on higher levels that operate on files will affect that group or file.

3 The Options dialog box provides options for the build tools—a category for each build tool.

![Options dialog box](image)

Options in the General Options, Linker, and Debugger categories can only be set on project level because they affect the entire build configuration, and cannot be set for individual groups and files. However, the options in the other categories can be set for the project, a group of files, or an individual file.
Select a category from the **Category** list to select which building tool to set options for. Which tools that are available in the **Category** list depends on which tools are included in your product. When you select a category, one or more pages containing options for that component are displayed.

Click the tab that corresponds to the type of options you want to view or change. Make your settings appropriately.

To override project level settings, select the required item—for instance a specific group of files—and then select the option **Override inherited settings**. The new settings will affect all members of that group, that is, files and any groups of files. Your local overrides are indicated with a checkmark in a separate column in the **Workspace** window.

To restore all settings to the default factory settings, click the **Factory Settings** button, which is available for all categories except **General Options** and **Custom Build**. Note that two sets of factory settings are available: Debug and Release. Which one that is used depends on your build configuration; see **New Configuration dialog box**, page 94.

**Note:** If you add a source file with a non-recognized filename extension to your project, you cannot set options on that source file. However, you can add support for additional filename extensions. For more information, see **Filename Extensions dialog box**, page 70.

**BUILDING YOUR PROJECT**

You can build your project either as an application project or a library project.

You have access to the build commands both from the **Project** menu and from the context menu that appears if you right-click an item in the **Workspace** window.

To build your project as an application project, choose one of the three build commands **Make**, **Compile**, and **Rebuild All**. They will run in the background, so you can continue editing or working with the IDE while your project is being built.

To build your project as a library project, choose **Project>Options>General Options>Output>Output file>Library** before you build your project. Then, **Linker** is replaced by **Library Builder** in the **Category** list in the options dialog box, and the result of the build will be a library. For an example, see the tutorials.

For more information, see **Project menu**, page 176.

**CORRECTING ERRORS FOUND DURING BUILD**

Error messages are displayed in the **Build messages** window.

**To specify the level of output to the Build message window:**

Choose **Tools>Options** to open the **IDE Options** dialog box.
2 Click the Messages tab and select the level of output in the Show build messages drop-down list.

Alternatively, you can right-click in the Build Messages window and select Options from the context menu.

If your source code contains errors, you can jump directly to the correct position in the appropriate source file by double-clicking the error message in the error listing in the Build window, or selecting the error and pressing Enter.

After you have resolved any problems reported during the build process and rebuilt the project, you can directly start debugging the resulting code at the source level.

For more information about the Build messages window, see Build window, page 113.

USING PRE- AND POST-BUILD ACTIONS

If necessary, you can specify pre-build and post-build actions that you want to occur before or after the build. The Build Actions options in the Options dialog box—available from the Project menu—let you specify the actions required.

For more information about the Build Actions options, see Build actions options, page 221.

Using pre-build actions for time stamping

You can use pre-build actions to embed a time stamp for the build in the resulting binary file. Follow these steps:

1 Create a dedicated time stamp file, for example, timestamp.c and add it to your project.

2 In this source file, use the preprocessor macros __TIME__ and __DATE__ to initialize a string variable.

3 Choose Project>Options>Build Actions to open the Build Actions dialog box.

4 In the Pre-build command line text field, specify for example this pre-build action:
   cmd /c "del "$OBJ_DIR$\timestamp.o""

   This command removes the timestamp.o object file.

   Alternatively, you can use the open source command line utility touch for this purpose or any other suitable utility that updates the modification time of the source file. For example:
   "touch $PROJ_DIR$\timestamp.c"
If the project is not entirely up-to-date, the next time you use the Make command, the pre-build action will be invoked before the regular build process. Then the regular build process must always recompile timestamp.c and the correct timestamp will end up in the binary file.

If the project already is up-to-date, the pre-build action will not be invoked. This means that nothing is built, and the binary file still contains the timestamp for when it was last built.

**BUILDING MULTIPLE CONFIGURATIONS IN A BATCH**

Use the batch build feature when you want to build more than one configuration at once. A batch is an ordered list of build configurations. The Batch Build dialog box—available from the Project menu—lets you create, modify, and build batches of configurations.

For workspaces that contain several configurations, it is convenient to define one or more different batches. Instead of building the entire workspace, you can build only the appropriate build configurations, for instance Release or Debug configurations.

For more information about the Batch Build dialog box, see Batch Build dialog box, page 114.

**BUILDING FROM THE COMMAND LINE**

To build the project from the command line, use the IAR Command Line Build Utility (iarbuild.exe) located in the common\bin directory. As input you use the project file, and the invocation syntax is:

```bash
iarbuild project.ewp [-clean|-build|-make] configuration|*
[-log errors|warnings|info|all][-parallel number][-varfile argvarfile]
```

These are the possible parameters:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>project.ewp</td>
<td>Your IAR Embedded Workbench project file.</td>
</tr>
<tr>
<td>-clean</td>
<td>Removes any intermediate and output files.</td>
</tr>
<tr>
<td>-build</td>
<td>Rebuilds and relinks all files in the current build configuration.</td>
</tr>
<tr>
<td>-make</td>
<td>Brings the current build configuration up to date by compiling, assembling, and linking only the files that have changed since the last build.</td>
</tr>
</tbody>
</table>

*Note: This is Table 4: iarbuild.exe command line options.*
If you run the application from a command shell without specifying a project file, you will get a sign-on message describing available parameters and their syntax.

### ADDING AN EXTERNAL TOOL

The following example demonstrates how to add the tool Flex to the toolchain. The same procedure can be used also for other tools.

In the example, Flex takes the file `myFile.lex` as input. The two files `myFile.c` and `myFile.h` are generated as output.

1. Add the file you want to work with to your project, for example `myFile.lex`.
2. Select this file in the Workspace window and choose Project>Options. Select Custom Build from the list of categories.
3. In the Filename extensions field, type the filename extension `.lex`. Remember to specify the leading period (`.`).
4. In the Command line field, type the command line for executing the external tool, for example:

   ```
   flex $FILE_PATH$ -o$FILE_BNAME$.c
   ```

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>configuration</code>*</td>
<td><code>configuration</code>, the name of the configuration you want to build, which can either be one of the predefined configurations Debug or Release, or a name that you define yourself. For more information about build configurations, see Projects and build configurations, page 80.</td>
</tr>
<tr>
<td><code>-log errors</code></td>
<td>Displays build error messages.</td>
</tr>
<tr>
<td><code>-log warnings</code></td>
<td>Displays build warning and error messages.</td>
</tr>
<tr>
<td><code>-log info</code></td>
<td>Displays build warning and error messages, and messages issued by the <code>#pragma message</code> preprocessor directive.</td>
</tr>
<tr>
<td><code>-log all</code></td>
<td>Displays all messages generated from the build, for example compiler sign-on information and the full command line.</td>
</tr>
<tr>
<td><code>-parallel number</code></td>
<td>Specifies the number of parallel processes to run the compiler in to make better use of the cores in the CPU.</td>
</tr>
<tr>
<td><code>-varfile</code></td>
<td>Makes custom argument variables defined in a workspace scope available to the build engine by specifying the file to use.</td>
</tr>
</tbody>
</table>

* (wild card character), the -clean, -build, and -make commands will a process all configurations defined in the project.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>-log errors</code></td>
<td>Displays build error messages.</td>
</tr>
<tr>
<td><code>-log warnings</code></td>
<td>Displays build warning and error messages.</td>
</tr>
<tr>
<td><code>-log info</code></td>
<td>Displays build warning and error messages, and messages issued by the <code>#pragma message</code> preprocessor directive.</td>
</tr>
<tr>
<td><code>-log all</code></td>
<td>Displays all messages generated from the build, for example compiler sign-on information and the full command line.</td>
</tr>
<tr>
<td><code>-parallel number</code></td>
<td>Specifies the number of parallel processes to run the compiler in to make better use of the cores in the CPU.</td>
</tr>
<tr>
<td><code>-varfile</code></td>
<td>Makes custom argument variables defined in a workspace scope available to the build engine by specifying the file to use.</td>
</tr>
</tbody>
</table>

Table 4: iarbuild.exe command line options (Continued)

If you run the application from a command shell without specifying a project file, you will get a sign-on message describing available parameters and their syntax.
During the build process, this command line is expanded to:

```
flex myFile.lex -omyFile.c
```

Note the usage of *argument variables*. Note specifically the use of `$FILE_BNAME$` which gives the base name of the input file, in this example appended with the `c` extension to provide a C source file in the same directory as the input file `foo.lex`. For more information about these variables, see *Argument variables*, page 72.

In the **Output files** field, describe the output files that are relevant for the build. In this example, the tool Flex would generate two files—one source file and one header file. The text in the **Output files** text box for these two files would look like this:

```
$FILE_BPATH$.c
$FILE_BPATH$.h
```

If the external tool uses any additional files during the build, these should be added in the **Additional input files** field, for instance:

```
$TOOLKIT_DIR\inc\stdio.h
```

This is important, because if the dependency files change, the conditions will no longer be the same and the need for a rebuild is detected.

Click **OK**.

To build your application, choose **Project>Make**.

---

**Reference information on building**

Reference information about:

- *Options dialog box*, page 112
- *Build window*, page 113
- *Batch Build dialog box*, page 114
- *Edit Batch Build dialog box*, page 115.
Options dialog box

The Options dialog box is available from the Project menu.

Use this dialog box to specify your project settings.

See also Setting project options using the Options dialog box, page 105.

Category

Selects the build tool you want to set options for. The available categories will depend on the tools installed in your IAR Embedded Workbench IDE, and will typically include:

- General options
- C/C++ Compiler
- Assembler
- Custom build, options for extending the toolchain
- Build Actions, options for pre-build and post-build actions
- Linker, available for application projects but not for library projects
- Library builder, available for library projects but not for application projects
- Debugger
● Simulator
● C-SPY hardware drivers, options specific to additional hardware debuggers.

Selecting a category displays one or more pages of options for that component of the IDE.

**Factory Settings**

Restores all settings to the default factory settings. Note that this option is not available for all categories.

**Build window**

The Build window is available by choosing **View > Messages**.

This window displays the messages generated when building a build configuration. When opened, the window is, by default, grouped together with the other message windows. Double-click a message in the Build window to open the appropriate file for editing, with the insertion point at the correct position.

**Context menu**

This context menu is available:

- **Copy**
  - Copies the contents of the window.
- **Select All**
  - Selects the contents of the window.

These commands are available:
Clear All

Deletes the contents of the window.

Options

Opens the Messages page of the IDE options dialog box. On this page you can set options related to messages; see Messages options, page 50.

Batch Build dialog box

The Batch Build dialog box is available by choosing Project>Batch build.

This dialog box lists all defined batches of build configurations. For more information, see Building multiple configurations in a batch, page 109.

Batches

Select the batch you want to build from this list of currently defined batches of build configurations.

Build

Give the build command you want to execute:

- Make
- Clean
- Rebuild All.

New

Displays the Edit Batch Build dialog box, where you can define new batches of build configurations; see Edit Batch Build dialog box, page 115.
Remove

Removes the selected batch.

Edit

Displays the Edit Batch Build dialog box, where you can edit existing batches of build configurations.

**Edit Batch Build dialog box**

The Edit Batch Build dialog box is available from the Batch Build dialog box.

Use this dialog box to create new batches of build configurations, and edit already existing batches.

**Name**

Type a name for a batch that you are creating, or change the existing name (if you wish) for a batch that you are editing.

**Available configurations**

Select the configurations you want to move to be included in the batch you are creating or editing, from this list of all build configurations that belong to the workspace.

To move a build configuration from the Available configurations list to the Configurations to build list, use the arrow buttons.
Configurations to build

Lists the build configurations that will be included in the batch you are creating or editing. Drag the build configurations up and down to set the order between the configurations.
Editing

- Introduction to the IAR Embedded Workbench editor
- Editing a file
- Programming assistance
- Reference information on the editor.

Introduction to the IAR Embedded Workbench editor

These topics are covered:
- Briefly about the editor
- Briefly about source browse information
- Customizing the editor environment.

For information about how to use an external editor in the IAR Embedded Workbench IDE, see *Using an external editor*, page 31.

BRIEFLY ABOUT THE EDITOR

The integrated text editor allows you to edit multiple files in parallel, and provides both basic editing features and functions specific to software development, like:
- Automatic word and code completion
- Automatic line indentation and block indentation
- Parenthesis and bracket matching
- Function navigation within source files
- Context-sensitive help system that can display reference information for DLIB library functions and language extensions
- Text styles and color that identify the syntax of C or C++ programs and assembler directives
- Powerful search and replace commands, including multi-file search
- Direct jump to context from error listing
- Multibyte character support
- Parameter hints
- Bookmarks
● Unlimited undo and redo for each window.

**BRIEFLY ABOUT SOURCE BROWSE INFORMATION**

Optionally, source browse information is continuously generated in the background. This information is used by many different features useful as programming assistance, for example:

● **Source Browser** window
● Go to definition or declaration
● Find all references
● Find all calls to or from a function, where the result is presented as a call graph.

The source browse information is updated when a file in the project is saved. When you save an edited source file, or when you open a new project, there will be a short delay before the information is up-to-date. During the update, progress information is displayed in the **Source Browser** window title and in the status bar.

**Note:** If you want the generation of source browse information to halt when you change focus from the IAR Embedded Workbench IDE to another program, make sure to enable the **No source browser and build status updates when the IDE is not the foreground process** option.

**CUSTOMIZING THE EDITOR ENVIRONMENT**

The IDE editor can be configured on the **IDE Options** pages **Editor** and **Editor>Colors and Fonts**. Choose **Tools>Options** to access the pages.

For information about these pages, see **Tools menu**, page 179.

---

**Editing a file**

The editor window is where you write, view, and modify your source code. These tasks are covered:

● Indenting text automatically
● Matching brackets and parentheses
● Splitting the editor window into panes
● Dragging text
● Code folding
● Word completion
● Code completion
● Parameter hint
● Using and adding code templates
● Syntax coloring
● Adding bookmarks
● Using and customizing editor commands and shortcut keys
● Displaying status information.

See also:
● Programming assistance, page 125
● Using an external editor, page 31.

**INDENTING TEXT AUTOMATICALLY**

The text editor can perform various kinds of indentation. For assembler source files and plain text files, the editor automatically indents a line to match the previous line.

To indent several lines, select the lines and press the Tab key.

To move a whole block of lines back to the left again, press Shift+Tab.

For C/C++ source files, the editor indents lines according to the syntax of the C/C++ source code. This is performed whenever you:

● Press the Return key
● Type any of the special characters {, }, :, and #
● Have selected one or several lines, and choose the Edit>Auto Indent command.

**To enable or disable the indentation:**

1. Choose Tools>Options and select Editor.
2. Select or deselect the Auto indent option.

To customize the C/C++ automatic indentation, click the Configure button.

For more information, see Configure Auto Indent dialog box, page 46.

**MATCHING BRACKETS AND PARENTHESES**

To highlight matching parentheses with a light gray color, place the insertion point next to a parenthesis:

```c
void neatCounter(void)
{
    callCount ++ 1;
}```
The highlight remains in place as long as the insertion point is located next to the parenthesis.

To select all text between the brackets surrounding the insertion point, choose Edit>Match Brackets. Every time you choose Match Brackets (grow) or Match Brackets (shrink) after that, the selection will increase or shrink, respectively, to the next hierarchic pair of brackets.

Note: Both of these functions—automatic matching of corresponding parentheses and selection of text between brackets—apply to (), [], {}, and <> (requires Match All Brackets).

SPLITTING THE EDITOR WINDOW INTO PANES

You can split the editor window horizontally or vertically into multiple panes, to look at different parts of the same source file at once, or to move text between two different panes.

To split a window into panes (horizontally or vertically), use the Window>Split command.

Alternatively, to split the window vertically, double-click the splitter bar, or drag it to the middle of the window.

To revert to a single pane, double-click the splitter control or drag it back to the end of the scroll bar.

DRAGGING TEXT

To move text within an editor window or to copy between editor windows, select the text and drag it to the new location.

CODE FOLDING

Sections of code can be hidden and displayed using code folding.

To collapse or expand groups of lines, click on the fold points in the fold margin:

The fold point positions are based on the hierarchical structure of the document contents, for example, brace characters in C/C++ or the element hierarchy of an XML.
file. The Toggle All Folds command (Ctrl+Alt+F) can be used for expanding (or collapsing) all folds in the current document. The command is available from the Edit menu and from the context menu in the editor window. You can enable or disable the fold margin from Tools>Options>Editor.

WORD COMPLETION

Word completion attempts to complete the word that you have started to type, basing the assumption on the contents of the rest of your document.

To make the editor complete the word that you have started to type, press Ctrl+Alt+Space or choose Complete Word from the context menu. If the suggestion is incorrect, repeat the command to get new suggestions.

CODE COMPLETION

To make the editor show a list of symbols that are available in a class, type ., ->, or :: after a class or object name:

```c
struct myStruct
{
  int a;
  int b;
};

int function (void)
{
  struct myStruct myStruct;

  myStruct; // Insertion point
```

When you place the cursor anywhere else but after ., ->, or ::, the context menu lists all symbols available in the active translation unit.

Click on a symbol name in the list or choose it with the arrow keys and press return to insert it at the current insertion point.

PARAMETER HINT

To make the editor suggest function parameters as tooltip information, start typing the first parenthesis after a function name.
When there are several overloaded versions of a function, you can choose which one to use by clicking the arrows in the tooltip (Ctrl+Up/Down). To insert the parameters as text, press Ctrl+Enter:

```c
int overload(char c);
int overload(short s);
int overload(int i);

int function (void)
```

**USING AND ADDING CODE TEMPLATES**

Code templates are a method of conveniently inserting frequently used source code sequences, for example for loops and if statements. The code templates are defined in a plain text file. By default, a few example templates are provided. In addition, you can easily add your own code templates.

**To set up the use of code templates:**

1. Choose **Tools>Options>Editor>Setup Files**.
2. Select or deselect the **Use Code Templates** option.
   
   By default, code templates are enabled.
3. In the text field, specify which template file you want to use:
   
   - The default template file
     
     The original template file `CodeTemplates.txt` is located in the `common\config` directory of your product installation. The first time you use IAR Embedded Workbench, the original template file is copied to a directory for local settings, and this is the file that is used by default if code templates are enabled.
   
   - Your own template file
     
     Note that before you can choose your own template file, you must first have created one. To create your own template file, choose **Edit>Code Templates>Edit Templates**. Add your code templates and save the file with a new name. The syntax for defining templates is described in the default template file.
   
   - A template file that uses correct language
     
     When you start the IAR Embedded Workbench IDE for the very first time, you are asked to select a language version. This only applies if you are using an IDE that is available in other languages than English.
     
     Selecting a language creates a corresponding language version of the default code template file in the `Application Data\IAR Embedded Workbench` subdirectory of the current Windows user (for example `CodeTemplates.ENU.txt` for English...
and CodeTemplates.JPN.txt for Japanese). The default code template file does not change automatically if you change the language version of the IDE afterwards.

A browse button is available for your convenience.

Note that if the code template file you want to select is not in the browsed directory (which is the case when you have selected a different language version), you must:

- Delete the filename in the Use Code Templates text box.
- Deselect the Use Code Templates option and click OK.
- Restart the IAR Embedded Workbench IDE.
- Choose Tools>Options>Editor>Setup Files again.

The default code template file for the selected language version of the IDE should now be displayed in the Use Code Templates text box. Select the checkbox to enable the template.

To insert a code template into your source code:

1. In the editor window, right-click where you want the template to be inserted and choose Insert Template (Ctrl+Alt+V).

2. Choose a code template from the menu that appears.

If the code template requires any type of field input, as in the for loop example which needs an end value and a count variable, an input dialog box appears.
SYNTAX COLORING

If the Tools>Options>Editor>Syntax highlighting option is enabled, the IAR Embedded Workbench editor automatically recognizes the syntax of different parts of source code, for example:

- C and C++ keywords
- C and C++ comments
- Assembler directives and comments
- Preprocessor directives
- Strings.

The different parts of source code are displayed in different text styles.

To change these styles, choose Tools>Options, and use the Editor>Colors and Fonts options. For more information, see Editor Colors and Fonts options, page 49.

To define your own set of keywords that should be syntax-colored automatically:

1. In a text file, list all the keywords that you want to be automatically syntax-colored. Separate each keyword with either a space or a new line.
2. Choose Tools>Options and select Editor>Setup Files.
3. Select the Use Custom Keyword File option and specify your newly created text file. A browse button is available for your convenience.
4. Select Editor>Colors and Fonts and choose User Keyword from the Syntax Coloring list. Specify the font, color, and type style of your choice. For more information, see Editor Colors and Fonts options, page 49.

In the editor window, type any of the keywords you listed in your keyword file; see how the keyword is colored according to your specification.

ADDING BOOKMARKS

Use the Edit>Navigate>Toggle Bookmark command to add and remove bookmarks. To switch between the marked locations, choose Edit>Navigate>Navigate Next Bookmark or Navigate Previous Bookmark.

USING AND CUSTOMIZING EDITOR COMMANDS AND SHORTCUT KEYS

The Edit menu provides commands for editing and searching in editor windows, for instance, unlimited undo/redo. You can also find some of these commands on the context menu that appears when you right-click in the editor window. For more information about each command, see Edit menu, page 169.
There are also editor shortcut keys for:

- moving the insertion point
- scrolling text
- selecting text.

For more information about these shortcut keys, see *Editor shortcut key summary*, page 154.

To change the default shortcut key bindings, choose **Tools>Options**, and click the **Key Bindings** tab. For more information, see *Key Bindings options*, page 40.

**DISPLAYING STATUS INFORMATION**

The status bar is available by choosing **View>Status Bar**. For more information, see *IAR Embedded Workbench IDE window*, page 35.

---

**Programming assistance**

There are several features in the editor that assist you during your software development. This section describes various tasks related to using the editor.

These tasks are covered:

- Navigating to a function
- Finding a definition or declarations of a symbol
- Finding references to a symbol
- Finding function calls for a selected function
- Switching between source and header files
- Displaying source browse information
- Text searching
- Accessing online help for reference information.

The current position of the insertion point is added to the insertion point history by actions like **Go to definition** and clicking on the result for the **Find in Files** command. You can jump in the history either forward or backward by using the **Navigate Forward** and **Navigate Backward** buttons (or by pressing Alt + Right Arrow or Alt + Left Arrow).

**NAVIGATING TO A FUNCTION**

Click the **Go to function** button in the top-right corner of the editor window to list all functions defined in the source file displayed in the window. You can then choose to
navigate directly to one of the functions by clicking it in the list. Note that the list is refreshed when you save the file.

**FINDING A DEFINITION OR DECLARATIONS OF A SYMBOL**

To see the definition or declaration of a global symbol or a function, you can use these alternative methods:

- In the editor window, right-click on a symbol and choose the **Go to definition** or **Go to declaration** command from the context menu that appears. If more than one declaration is found, the declarations are listed in the Declarations window from where you can navigate to a specific declaration.

- In the **Source Browser** window, double-click on a symbol to view the definition.

- In the **Source Browser** window, right-click on a symbol, or function, and choose the **Go to definition** command from the context menu that appears.

The definition of the symbol or function is displayed in the editor window.

**FINDING REFERENCES TO A SYMBOL**

To find all references for a specific symbol, select the symbol in the editor window, right-click and choose **Find All References** from the context menu. All found references are displayed in the **References** window.

You can now navigate between the references.

**FINDING FUNCTION CALLS FOR A SELECTED FUNCTION**

To find all calls to or from a function, select the function in the editor window or in the **Source Browser** window, right-click and choose either **Find All Calls to** or **Find All Calls from** from the context menu. The result is displayed in the **Call Graph** window.

You can navigate between the function calls.

**SWITCHING BETWEEN SOURCE AND HEADER FILES**

If the insertion point is located on an **#include** line, you can choose the **Open "header.h"** command from the context menu, which opens the header file in an editor window. You can also choose the command **Open Header/Source File**, which opens the header or source file with a corresponding filename to the current file, or activates it if it is already open. This command is available if the insertion point is located on any line except an **#include** line.

**DISPLAYING SOURCE BROWSE INFORMATION**

To open the **Source Browser** window, choose **View>Source Browser>Source Browser**.
The Source Browser window is, by default, docked with the Workspace window. Source browse information is displayed for the active build configuration.

Note that you can choose a file filter and a type filter from the context menu that appears when you right-click in the top pane of the window.

2 To display browse information in the Source Browser window, choose Tools>Options>Project and select the option Generate browse information.

TEXT SEARCHING

There are several standard search functions available in the editor:

- Quick search text box
- Find dialog box
- Replace dialog box
- Find in Files dialog box
- Replace in Files dialog box
- Incremental Search dialog box.

To use the Quick search text box on the toolbar:

1 Type the text you want to search for and press Enter.

2 Press Esc to stop the search. This is a quick method of searching for text in the active editor window.

To use the Find, Replace, Find in Files, Replace in Files, and Incremental Search functions:

1 Before you use the search commands, choose Tools>Options>Editor and make sure the Show bookmarks option is selected.

2 Choose the appropriate search command from the Edit menu. For more information about each search function, see Edit menu, page 169.

3 To remove the blue flag icons that have appeared in the left-hand margin, right-click in the Find in Files window and choose Clear All from the context menu.

ACCESSING ONLINE HELP FOR REFERENCE INFORMATION

When you need to know the syntax of a library function, extended keyword, intrinsic function, etc, type the name and select it in the editor window and press F1. The documentation for the item appears in a help window.
Reference information on the editor

Reference information about:

- Editor window, page 129
- Find dialog box, page 137
- Find in Files window, page 138
- Replace dialog box, page 139
- Find in Files dialog box, page 140
- Replace in Files dialog box, page 142
- Incremental Search dialog box, page 144
- Declarations window, page 145
- Ambiguous Definitions window, page 146
- References window, page 147
- Source Browser window, page 148
- Resolve File Ambiguity dialog box, page 152
- Call Graph window, page 152
- Template dialog box, page 153
- Editor shortcut key summary, page 154.
Editor window

The editor window is opened when you open or create a text file in the IDE.

You can open one or several text files, either from the File menu, or by double-clicking them in the Workspace window. All open files are available from the drop-down menu at the upper right corner of the editor window. Several editor windows can be open at the same time.

Source code files and HTML files are displayed in editor windows. From an open HTML document, hyperlinks to HTML files work like in an ordinary web browser. A link to an *new* workspace file opens the workspace in the IDE, and closes any currently open workspace and the open HTML document.

When you want to print a source file, it can be useful to enable the option **Show line numbers**—available by choosing **Tools>Options>Editor**.

The editor window is always docked, and its size and position depend on other currently open windows.
Relative source file paths
The IDE has partial support for relative source file paths.
If a source file is located in the project file directory or in any subdirectory of the project file directory, the IDE uses a path relative to the project file when accessing the source file.

Window tabs, tab groups, and tab context menu
The name of the open file is displayed on the tab. If you open several files, they are organized in a tab group. Click the tab for the file that you want to display. If a file has been modified after it was last saved, an asterisk appears on the tab after the filename, for example Utilities.c*. If a file is read-only, a padlock icon is visible on the tab.
The tab’s tooltip shows the full path and a remark if the file is not a member of the active project.
A context menu appears if you right-click on a tab in the editor window.

These commands are available:

Save file
Saves the file.
Close
Closes the file.
Close All But This
Closes all tabs except the current tab.
Close All to the Right
Closes all tabs to the right of the current tab.
Open Containing Folder
Opens the File Explorer that displays the directory where the selected file resides.
**File Properties**

Displays a standard file properties dialog box.

**Multiple editor windows and splitter controls**

You can have one or several editor windows open at the same time. The commands on the **Window** menu allow you to split the editor window into panes and to open multiple editor windows. There are also commands for moving files between editor windows.

To split the editor window vertically into multiple panes, you can also use the splitter controls.

For more information about each command on the **Window** menu, see the *IDE Project Management and Building Guide*.

**Go to function**

Click the **Go to function** button in the top right-hand corner of the editor window to list all functions of the C or C++ editor window.

Click the function that you want to show in the editor window.
Context menu

This context menu is available:

- Cut
- Copy
- Paste
- Complete Word
- Complete Code
- Parameter Hint
- Match Brackets
- Toggle All Folds
- Insert Template
- Open Header/Source File
- Go to Definition of 'main'
- Go to Declaration of 'main'
- Find All References to 'main'
- Find All Calls to 'main'
- Find All Calls from 'main'

Find in Trace
- Toggle Breakpoint (Code)
- Toggle Breakpoint (Log)
- Toggle Breakpoint (Trace Start)
- Toggle Breakpoint (Trace Stop)
- Enable/disable Breakpoint
- Set Data Breakpoint for 'main'
- Set Data Log Breakpoint for 'main'

Set Next Statement
- Quick Watch
- Add to Watch

Move to PC
- Run to Cursor
- Character Encoding

Options...

The contents of this menu depend on whether the debugger is started or not, and on the C-SPY driver you are using. Typically, additional breakpoint types might be available on this menu. For information about available breakpoints, see the C-SPY® Debugging Guide for 8051.
These commands are available:

**Cut, Copy, Paste**
Standard window commands.

**Complete Word**
Attempts to complete the word you have begun to type, basing the guess on the contents of the rest of the editor document.

**Complete Code**
Shows a list of symbols that are available in a class, when you place the insertion point after ., ->, or :: and when these characters are preceded by a class or object name. For more information, see *Code completion*, page 121.

**Parameter Hint**
Suggests parameters as tooltip information for the function parameter list you have begun to type. When there are several overloaded versions of a function, you can choose which one to use by clicking the arrows in the tooltip. For more information, see *Parameter hint*, page 121.

**Match Brackets**
Selects all text between the brackets immediately surrounding the insertion point, increases the selection to the next hierarchic pair of brackets, or beeps if there is no higher bracket hierarchy.

**Toggle All Folds**
Expands/collapses all code folds in the active project.

**Insert Template**
Displays a list in the editor window from which you can choose a code template to be inserted at the location of the insertion point. If the code template you choose requires any field input, the Template dialog box appears; for information about this dialog box, see *Template dialog box*, page 153. For information about using code templates, see *Using and adding code templates*, page 122.

**Open ",header.h"**
Opens the header file header.h in an editor window. If more than one header file with the same name is found and the IDE does not have access to dependency information, the Resolve File Ambiguity dialog box is displayed, see *Resolve File Ambiguity dialog box*, page 152. This menu command is only available if the insertion point is located on an #include line when you open the context menu.
Open Header/Source File

Opens the header or source code file that has same base name as the current file. If the destination file is not open when you choose the command, the file will first be opened. This menu command is only available if the insertion point is located on any line except an `#include` line when you open the context menu. This command is also available from the File>Open menu.

Go to Definition of symbol

Places the insertion point at the definition of the symbol. If no definition is found in the source code, the first declaration will be used instead. If more than one possible definition is found, they are listed in the Ambiguous Definitions window. See Ambiguous Definitions window, page 146.

Go to Declaration of symbol

If only one declaration is found, the command puts the insertion point at the declaration of the symbol. If more than one declaration is found, these declarations are listed in the Declarations window.

Find All References to symbol

The references are listed in the References window.

Find All Calls to

Opens the Call Graph window which displays all functions in the project that calls the selected function, see Call Graph window, page 152. If this command is disabled, make sure to select a function in the editor window.

Find All Calls from

Opens the Call Graph window which displays all functions in the project that are called from the selected function, see Call Graph window, page 152. If this command is disabled, make sure to select a function in the editor window.

Check In, Check Out, Undo Checkout

Commands for source code control; for more information, see Version Control System menu for SCC, page 96. These menu commands are only available if the current source file in the editor window is SCC-controlled. The file must also be a member of the current project.

Toggle Breakpoint (Code)

Toggles a code breakpoint at the statement or instruction containing or close to the cursor in the source window. For information about code breakpoints, see the C-SPY® Debugging Guide for 8051.
Toggle Breakpoint (Log)
Toggles a log breakpoint at the statement or instruction containing or close to
the cursor in the source window. For information about log breakpoints, see the
C-SPY® Debugging Guide for 8051.

Toggle Breakpoint (Trace Start)
Toggles a Trace Start breakpoint. When the breakpoint is triggered, trace data
collection starts. For information about Trace Start breakpoints, see the C-SPY®
Debugging Guide for 8051. Note that this menu command is only available if
the C-SPY driver you are using supports trace.

Toggle Breakpoint (Trace Stop)
Toggles a Trace Stop breakpoint. When the breakpoint is triggered, trace data
collection stops. For information about Trace Stop breakpoints, see the C-SPY®
Debugging Guide for 8051. Note that this menu command is only available if
the C-SPY driver you are using supports trace.

Enable/disable Breakpoint
Toggles a breakpoint between being disabled, but not actually
removed—making it available for future use—and being enabled again.

Set Data Breakpoint for ‘variable’
Toggles a data log breakpoint on variables with static storage duration. Requires
support in the C-SPY driver you are using. For more information about data
breakpoints, see the C-SPY® Debugging Guide for 8051.

Set Data Log Breakpoint for ‘variable’
Toggles a data log breakpoint on variables with static storage duration. Requires
support in the C-SPY driver you are using. The breakpoints you set in this
window will be triggered by both read and write accesses; to change this, use the
Breakpoints window. For more information about data logging and data log
breakpoints, see the C-SPY® Debugging Guide for 8051.

Find in Trace
Searches the contents of the Trace window for occurrences of the given
location—the position of the insertion point in the source code—and reports the
result in the Find in Trace window. This menu command requires support for
Trace in the C-SPY driver you are using, see the C-SPY® Debugging Guide for
8051.

Edit Breakpoint
Displays the Edit Breakpoint dialog box to let you edit the breakpoint available
on the source code line where the insertion point is located. If there is more than
one breakpoint on the line, a submenu is displayed that lists all available
breakpoints on that line.
Set Next Statement
Sets the Program Counter directly to the selected statement or instruction without executing any code. This menu command is only available when you are using the debugger. For more information, see the C-SPY® Debugging Guide for 8051.

Quick Watch
Opens the Quick Watch window, see the C-SPY® Debugging Guide for 8051. This menu command is only available when you are using the debugger.

Add to Watch
Adds the selected symbol to the Watch window. This menu command is only available when you are using the debugger.

Move to PC
Moves the insertion point to the current PC position in the editor window. This menu command is only available when you are using the debugger.

Run to Cursor
Executes from the current statement or instruction up to the statement or instruction where the insertion point is located. This menu command is only available when you are using the debugger.

Character Encoding
Interprets the source file according to the specified character encoding. Choose between:

System (uses the Windows settings)
UTF-8
Western European
Japanese (Shift-JIS)
Chinese Simplified (GB2312)
Korean (Unified Hangul Code)
Arabic
Baltic
Central European
Greek
Hebrew
Russian
Thai

Vietnamese

**Convert to UTF-8** (converts the document to UTF-8)

Use one of these settings if the **Auto-detect character encoding** option could not determine the correct encoding or if the option is deselected. For more information about file encoding, see *Editor options*, page 42.

**Options**

Displays the **IDE Options** dialog box, see *Tools menu*, page 179.

**Find dialog box**

The **Find** dialog box is available from the **Edit** menu.

![Find dialog box](image)

Note that the contents of the dialog box might be different if you search in an editor window compared to if you search in the **Memory** window.

**Find what**

Specify the text to search for. Use the drop-down list to use old search strings.

**Match case**

Searches only for occurrences that exactly match the case of the specified text. Otherwise, specifying `int` will also find `INT` and `Int`. This option is only available when you perform the search in an editor window.

**Match whole word**

Searches for the specified text only if it occurs as a separate word. Otherwise, specifying `int` will also find `print`, `sprintf` etc. This option is only available when you perform the search in an editor window.

**Search as hex**

Searches for the specified hexadecimal value. This option is only available when you perform the search in the **Memory** window.
Only in selection

Limits the search operation to the selected lines (when searching in an editor window) or to the selected memory area (when searching in the Memory window). The option is only enabled when a selection has been made before you open the dialog box.

Find Next

Searches for the next occurrence of the specified text.

Find Previous

Searches for the previous occurrence of the specified text.

Stop

Stops an ongoing search. This button is only available during a search in the Memory window.

Find in Files window

The Find in Files window is available by choosing View>Messages. This window displays the output from the Edit>Find and Replace>Find in Files command. When opened, this window is, by default, grouped together with the other message windows. Double-click an entry in the window to open the corresponding file with the insertion point positioned at the correct location. That source location is highlighted with a blue flag icon. Choose Edit>Next Error/Tag or press F4 to jump to the next in sequence.

Context menu

This context menu is available:

- Copy
- Select All
- Clear All
These commands are available:

**Copy**
Copies the selected content of the window.

**Select All**
Selects the contents of the window.

**Clear All**
Deletes the contents of the window and any blue flag icons in the left-side margin of the editor window.

### Replace dialog box

The **Replace** dialog box is available from the **Edit** menu.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Find what</strong></td>
<td>Specify the text to search for. Use the drop-down list to use old search strings.</td>
</tr>
<tr>
<td><strong>Replace with</strong></td>
<td>Specify the text to replace each found occurrence with. Use the drop-down list to use old search strings.</td>
</tr>
<tr>
<td><strong>Match case</strong></td>
<td>Searches only for occurrences that exactly match the case of the specified text. Otherwise, specifying <code>int</code> will also find <code>INT</code> and <code>Int</code>. This option is only available when you perform the search in an editor window.</td>
</tr>
<tr>
<td><strong>Match whole word</strong></td>
<td>Searches for the specified text only if it occurs as a separate word. Otherwise, <code>int</code> will also find <code>print</code>, <code>sprintf</code> etc. This option is only available when you search in an editor window.</td>
</tr>
</tbody>
</table>

Note that the contents of the dialog box is different if you search in an editor window compared to if you search in the **Memory** window.
Search as hex

Searches for the specified hexadecimal value. This option is only available when you perform the search in the Memory window.

Only in selection

Limits the search operation to the selected lines (when searching in an editor window) or to the selected memory area (when searching in the Memory window). The option is only enabled when a selection has been made before you open the dialog box.

Find next

Searches for the next occurrence of the specified text.

Replace

Replaces the searched text with the specified text.

Replace all

Replaces all occurrences of the searched text in the current editor window.

Find in Files dialog box

The Find in Files dialog box is available from the Edit menu.

Use this dialog box to search for a string in files.
The result of the search appears in the Find in Files message window—available from the View menu. You can then go to each occurrence by choosing the Edit>Next Error/Tag command, alternatively by double-clicking the messages in the Find in Files message window. This opens the corresponding file in an editor window with the insertion point positioned at the start of the specified text. A blue flag in the left-hand margin indicates the line with the string you searched for.

**Find what**

Specify the string you want to search for, or a regular expression. Use the drop-down list to use old search strings/expressions. You can narrow the search down with one or more of these conditions:

**Match case**

Searches only for occurrences that exactly match the case of the specified text. Otherwise, specifying `int` will also find `INT` and `Int`.

**Match whole word**

Searches only for the string when it occurs as a separate word (mnemonic `&w`). Otherwise, `int` will also find `print`, `sprintf` and so on.

**Match regular expression**

Interprets the search string as a the regular expression, which must follow the standard for the Perl programming language.

**Look in**

Specify which files you want to search in. Choose between:

**For all projects in workspace**

Searches all projects in the workspace, not just the active project.

**Project files**

Searches all files that you have explicitly added to your project.

**Project files and user include files**

Searches all files that you have explicitly added to your project and all files that they include, except the include files in the IAR Embedded Workbench installation directory.

**Project files and all include files**

Searches all project files that you have explicitly added to your project and all files that they include.

**Directory**

Searches the directory that you specify. Recent search locations are saved in the drop-down list. A browse button is available for your convenience.
Reference information on the editor

Look in subdirectories

Searches the directory that you have specified and all its subdirectories.

File types

A filter for choosing which type of files to search; the filter applies to all Look in settings. Choose the appropriate filter from the drop-down list. The text field is editable, to let you add your own filters. Use the * character to indicate zero or more unknown characters of the filters, and the ? character to indicate one unknown character.

Stop

Stops an ongoing search. This button is only available during an ongoing search.

Replace in Files dialog box

The Replace in Files dialog box is available from the Edit menu.

Use this dialog box to search for a specified string in multiple text files and replace it with another string.

The result of the replacement appears in the Find in Files message window—available from the View menu. You can then go to each occurrence by choosing the Edit>Next Error/Tag command, alternatively by double-clicking the messages in the Find in Files message window. This opens the corresponding file in an editor window with the
insertion point positioned at the start of the specified text. A blue flag in the left-hand margin indicates the line containing the string you searched for.

Find what

Specify the string you want to search for and replace, or a regular expression. Use the drop-down list to use old search strings/expressions. You can narrow the search down with one or more of these conditions:

**Match case**
Searches only for occurrences that exactly match the case of the specified text. Otherwise, specifying int will also find INT and Int.

**Match whole word**
Searches only for the string when it occurs as a separate word (mnemonic &w). Otherwise, int will also find print, sprintf and so on.

**Match regular expression**
Interprets the search string as a regular expression, which must follow the standard for the Perl programming language.

Replace with

Specify the string you want to replace the original string with. Use the drop-down list to use old replace strings.

Look in

Specify which files you want to search in. Choose between:

**For all projects in workspace**
Searches all projects in the workspace, not just the active project.

**Project files**
Searches all files that you have explicitly added to your project.

**Project files and user include files**
Searches all files that you have explicitly added to your project and all files that they include, except the include files in the IAR Embedded Workbench installation directory.

**Project files and all include files**
Searches all project files that you have explicitly added to your project and all files that they include.
Directory
Searches the directory that you specify. Recent search locations are saved in the drop-down list. A browse button is available for your convenience.

Look in subdirectories
Searches the directory that you have specified and all its subdirectories.

File types
A filter for choosing which type of files to search; the filter applies to all Look in settings. Choose the appropriate filter from the drop-down list. The text field is editable, to let you add your own filters. Use the * character to indicate zero or more unknown characters of the filters, and the ? character to indicate one unknown character.

Stop
Stops an ongoing search. This button is only available during an ongoing search.

Close
Closes the dialog box. An ongoing search must be stopped first.

Find Next
Finds the next occurrence of the specified search string.

Replace
Replaces the found string and finds the next occurrence of the specified search string.

Replace All
Saves all files and replaces all found strings that match the search string.

Skip file
Skips the occurrences in the current file.

Incremental Search dialog box
The Incremental Search dialog box is available from the Edit menu.
Use this dialog box to gradually fine-tune or expand the search string.

**Find what**

Type the string to search for. The search is performed from the location of the insertion point—the start point. Every character you add to or remove from the search string instantly changes the search accordingly. If you remove a character, the search starts over again from the start point.

If a word in the editor window is selected when you open the Incremental Search dialog box, this word will be displayed in the **Find What** text box.

Use the drop-down list to use old search strings.

**Match case**

Searches for occurrences that exactly match the case of the specified text. Otherwise, searching for `int` will also find `INT` and `Int`.

**Find Next**

Searches for the next occurrence of the current search string. If the **Find What** text box is empty when you click the **Find Next** button, a string to search for will automatically be selected from the drop-down list. To search for this string, click **Find Next**.

**Close**

Closes the dialog box.

**Only in selection**

Limits the search operation to the selected lines. The option is only available when more than one line has been selected before you open the dialog box.

**Declarations window**

The **Declarations** window is available by choosing **View>Source Browser**.
This window displays the result from the Go to Declaration command on the editor window context menu.

When opened, this window is by default grouped together with the other message windows.

To find and list declarations for a specific symbol, select a symbol in the editor window, right-click and choose Go to Declaration from the context menu. All declarations are listed in the Declarations window.

Double-click an entry in the window to open the corresponding file with the insertion point positioned at the correct location. Choose Edit>Next Error/Tag or press F4 to jump to the next in sequence.

Context menu

This context menu is available:

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy</td>
<td>Copies the contents of the window.</td>
</tr>
<tr>
<td>Select All</td>
<td>Selects the contents of the window.</td>
</tr>
<tr>
<td>Clear All</td>
<td>Deletes the contents of the window.</td>
</tr>
</tbody>
</table>

These commands are available:

Copy
Copies the contents of the window.

Select All
Selects the contents of the window.

Clear All
Deletes the contents of the window.

Ambiguous Definitions window

The Ambiguous Definitions window is available by choosing View>Source Browser.

This window displays the result from the Go to Definition command on the editor window context menu, if the source browser finds more than one possible definition.

When opened, this window is by default grouped together with the other message windows.
Double-click an entry in the window to open the corresponding file with the insertion point positioned at the correct location. Choose Edit>Next Error/Tag or press F4 to jump to the next entry in sequence.

**Context menu**

This context menu is available:

<table>
<thead>
<tr>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy</td>
</tr>
<tr>
<td>Select All</td>
</tr>
<tr>
<td>Clear All</td>
</tr>
</tbody>
</table>

These commands are available:

**Copy**

Copies the contents of the window.

**Select All**

Selects the contents of the window.

**Clear All**

Deletes the contents of the window.

**References window**

The References window is available by choosing View>Source Browser.

This window displays the result from the Find All References commands on the editor window context menu.

When opened, this window is by default grouped together with the other message windows.

To find and list references for a specific symbol, select a symbol in the editor window, right-click and choose Find All References from the context menu. All references are listed in the References window.
Double-click an entry in the window to open the corresponding file with the insertion point positioned at the correct location. Choose Edit->Next Error/Tag or press F4 to jump to the next in sequence.

**Context menu**

This context menu is available:

- Copy
- Select All
- Clear All

These commands are available:

- **Copy**
  Copies the contents of the window.

- **Select All**
  Selects the contents of the window.

- **Clear All**
  Deletes the contents of the window.

**Source Browser window**

The **Source Browser** window is available from the View menu.

This window displays an hierarchical view in alphabetical order of all symbols defined in the active build configuration. This means that source browse information is available for symbols in source files and include files part of that configuration. Source browse
information is not available for symbols in linked libraries. The window consists of two separate display areas.

For more information about how to use this window, see Displaying source browse information, page 126.

The upper display area

The upper display area contains two columns:

- An icon that corresponds to the Symbol type classification.
- The names of global symbols and functions defined in the project. Note that an unnamed type, for example a struct or a union without a name, will get a name based on the filename and line number where it is defined. These pseudonames are enclosed in angle brackets.
- The scope (namespaces and classes/structs) that the entry belongs to.
- The file name (without path) that contains the definition of the entry.

To sort each column, click its header.

The lower display area

For a symbol selected in the upper display area, the lower area displays its properties:

- Displays the unique name of each element, for instance `classname::membername`.
- Displays the symbol type for each element represented as an icon.
- Specifies the path to the file in which the element is defined.

Icons used for the symbol types

These are the icons used:

- Base class
- Class
- Configuration
- Enumeration
- Enumeration constant
- Field of a struct
(Purple rhomb) Function
# Macro
 Namespace
 Template class
 Template function
 Type definition
 Union
(Yellow rhomb) Variable

Context menu

This context menu is available in the upper display area:

- Go to Definition
  The editor window will display the definition of the selected item.

- Find All Calls to
  Opens the Call Graph window which displays all functions in the project that calls the selected function, see Call Graph window, page 152. If this command is disabled, make sure to select a function in the Source Browser window.

- Find All Calls from
  Opens the Call Graph window which displays all functions in the project that are called from the selected function, see Call Graph window, page 152. If this command is disabled, make sure to select a function in the Source Browser window.
Move to Parent
If the selected element is a member of a class, struct, union, enumeration, or namespace, this menu command can be used for moving the insertion point to the enclosing element.

All Symbols
Type filter; displays all global symbols and functions defined in the project.

All Functions & Variables
Type filter; displays all functions and variables defined in the project.

Non-Member Functions & Variables
Type filter; displays all functions and variables that are not members of a class.

Types
Type filter; displays all types such as structures and classes defined in the project.

Constants & Macros
Type filter; displays all constants and macros defined in the project.

Project Files
File filter; displays symbols from all files that you have explicitly added to your project, but no include files.

Project Files and User Include Files
File filter; displays symbols from all files that you have explicitly added to your project and all files included by them, except the include files in the IAR Embedded Workbench installation directory.

Project Files and All Include Files
File filter; displays symbols from all files that you have explicitly added to your project and all files included by them.
Resolve File Ambiguity dialog box

The Resolve File Ambiguity dialog box is displayed when the editor finds more than one header file with the same name.

This dialog box lists the header files if more than one header file is found when you choose the Open "header.h" command on the editor window context menu and the IDE does not have access to dependency information.

Call Graph window

The Call Graph window is available by choosing View>Source Browser>Call Graph.

This window displays calls to or calls from a function. The window is useful for navigating between the function calls.

To display a call graph, select a function name in the editor window or in the Source Browser window, right-click and select either Find All Calls to or Find All Calls from from the context menu.

Double-click an entry in the window to place the insertion point at the location of the function call (or definition, if a call is not applicable for the entry). The editor will open the file that contains the call if necessary.
Display area

The display area shows the call graph for the selected function, where each line lists a function. These columns are available:

- **Function**: Displays the call graph for the selected function; first the selected function, followed by a list of all called or calling functions. The functions calling the selected function are indicated with left arrow and the functions called by the selected function are indicated with a right arrow.
- **File**: The name of the source file.
- **Line**: The line number for the call.

Context menu

This context menu is available:

- **Go to Definition**: Places the insertion point at the location of the function definition.
- **Go to Call**: Places the insertion point at the location of the function call.

Template dialog box

The Template dialog box appears when you insert a code template that requires any field input.

Use this dialog box to specify any field input that is required by the source code template you insert.

**Note**: The figure reflects the default code template that can be used for automatically inserting code for a `for` loop.
Text fields

Specify the required input in the text fields. Which fields that appear depends on how the code template is defined.

Display area

The display area shows the code that would result from the code template, using the values you submit.

For more information about using code templates, see Using and adding code templates, page 122.

Editor shortcut key summary

There are three types of shortcut keys that you can use in the editor:

- Predefined shortcut keys, which you can configure using the IDE Options dialog box.
- Shortcut keys provided by the Scintilla editor.
- Custom shortcut keys that you configure yourself using the IDE Options dialog box.

The following tables summarize the editor’s predefined shortcut keys.

Moving the insertion point

<table>
<thead>
<tr>
<th>To move the insertion point</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>One character to the left</td>
<td>Left arrow</td>
</tr>
<tr>
<td>One character to the right</td>
<td>Right arrow</td>
</tr>
<tr>
<td>One word to the left</td>
<td>Ctrl + Left arrow</td>
</tr>
<tr>
<td>One word to the right</td>
<td>Ctrl + Right arrow</td>
</tr>
<tr>
<td>One word part to the left; when using mixed cases, for example mixedCaseName</td>
<td>Ctrl + Alt + Left arrow</td>
</tr>
<tr>
<td>One word part to the right; when using mixed cases, for example mixedCaseName</td>
<td>Ctrl + Alt + Right arrow</td>
</tr>
<tr>
<td>One line up</td>
<td>Up arrow</td>
</tr>
<tr>
<td>One line down</td>
<td>Down arrow</td>
</tr>
<tr>
<td>To the previous paragraph</td>
<td>Ctrl + Alt + Up arrow</td>
</tr>
<tr>
<td>To the next paragraph</td>
<td>Ctrl + Alt + Down arrow</td>
</tr>
<tr>
<td>To the start of the line</td>
<td>Home</td>
</tr>
</tbody>
</table>

Table 5: Editor shortcut keys for insertion point navigation
Selecting text

To select text, press Shift and the corresponding command for moving the insertion point. In addition, this command is available:

<table>
<thead>
<tr>
<th>To select</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>A column-based block</td>
<td>Shift + Alt + Arrow key</td>
</tr>
</tbody>
</table>

Scrolling text

To scroll

<table>
<thead>
<tr>
<th>To scroll</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Up one line.</td>
<td>Ctrl + Up arrow</td>
</tr>
<tr>
<td>Down one line.</td>
<td>Ctrl + Down arrow</td>
</tr>
<tr>
<td>Up one page</td>
<td>Page Up</td>
</tr>
<tr>
<td>Down one page</td>
<td>Page Down</td>
</tr>
</tbody>
</table>

Miscellaneous shortcut keys

<table>
<thead>
<tr>
<th>Description</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>When used in the parameter hints text box, this shortcut inserts parameters as text in the source code.</td>
<td>Ctrl + Enter</td>
</tr>
<tr>
<td>Bracket matching: Expand selection to next level of matching of {}, [], or ().</td>
<td>Ctrl + B</td>
</tr>
<tr>
<td>Bracket matching: Expand selection to next level of matching of {}, [], (), or &lt;&gt;</td>
<td>Ctrl + Alt + B</td>
</tr>
</tbody>
</table>

Table 5: Editor shortcut keys for insertion point navigation (Continued)
Table 6: Editor shortcut keys for selecting text
Table 7: Editor shortcut keys for scrolling
Table 8: Miscellaneous editor shortcut keys
## Additional Scintilla shortcut keys

<table>
<thead>
<tr>
<th>Description</th>
<th>Press</th>
</tr>
</thead>
</table>
| Scroll window line up or down | Ctrl + Up  
Ctrl + Down |
| Select a rectangular block and change its size a line up or down, or a column left or right | Shift + Alt + arrow key |
| Move insertion point one paragraph up or down | Ctrl + Alt + Up  
Ctrl + Alt + Down |
| Grow selection one paragraph up or down | Ctrl + Shift + Alt + Up  
Ctrl + Shift + Alt + Down |
| Move insertion point one word left or right | Ctrl + Left  
Ctrl + Right |
| Grow selection one word left or right | Ctrl + Shift + Left  
Ctrl + Shift + Right |
| Grow selection to next start or end of a word | Ctrl + Shift + Alt + Left  
Ctrl + Shift + Alt + Right |
| Move to first non-blank character of the line | Home |
| Move to start of line | Alt + Home |

*Table 9: Additional Scintilla shortcut keys*
<table>
<thead>
<tr>
<th>Description</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select to start of the line</td>
<td>Shift + Alt + Home</td>
</tr>
<tr>
<td>Select a rectangular block to the start or end</td>
<td>Shift + Alt + Page Up</td>
</tr>
<tr>
<td>end of page</td>
<td>Shift + Alt + Page Down</td>
</tr>
<tr>
<td>Delete to start of next word</td>
<td>Ctrl + Delete</td>
</tr>
<tr>
<td>Delete to start of previous word</td>
<td>Ctrl + Backspace</td>
</tr>
<tr>
<td>Delete forward to end of line</td>
<td>Ctrl + Shift + Delete</td>
</tr>
<tr>
<td>Delete backward to start of line</td>
<td>Ctrl + Shift + Backspace</td>
</tr>
<tr>
<td>Zoom in</td>
<td>Ctrl + Add (numeric +)</td>
</tr>
<tr>
<td>Zoom out</td>
<td>Ctrl + Subtract (numeric –)</td>
</tr>
<tr>
<td>Restore zoom to 100%</td>
<td>Ctrl + Divide (numeric /)</td>
</tr>
<tr>
<td>Cut current line</td>
<td>Ctrl + L</td>
</tr>
<tr>
<td>Copy current line</td>
<td>Ctrl + Shift + T</td>
</tr>
<tr>
<td>Delete current line</td>
<td>Ctrl + Shift + L</td>
</tr>
<tr>
<td>Change selection to lower case</td>
<td>Ctrl + U</td>
</tr>
<tr>
<td>Change selection to upper case</td>
<td>Ctrl + Shift + U</td>
</tr>
</tbody>
</table>

Table 9: Additional Scintilla shortcut keys (Continued)
Part 2. Reference information

This part contains these chapters:

- Installed files
- Menu reference
- General options
- Compiler options
- Assembler options
- Custom build options
- Build actions options
- Linker options
- Library builder options.
Installed files

- Directory structure
- File types

Directory structure

These topics are covered:
- Root directory
- The 8051 directory
- The common directory
- The install-info directory

The installation procedure creates several directories to contain the various types of files used with the IAR Systems development tools. The following sections give a description of the files contained by default in each directory.

ROOT DIRECTORY

The root directory created by the default installation procedure is the x:\Program Files\IAR Systems\Embedded Workbench 6.n\ directory where x is the drive where Microsoft Windows is installed and 6.n is the version number of the IDE.

THE 8051 DIRECTORY

The 8051 directory contains all product-specific subdirectories.

<table>
<thead>
<tr>
<th>Directory</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>8051\bin</td>
<td>Contains executable files for 8051-specific components, such as the compiler, the assembler, the linker and the library tools, and the C-SPY® drivers.</td>
</tr>
</tbody>
</table>

Table 10: The 8051 directory
<table>
<thead>
<tr>
<th>Directory</th>
<th>Description</th>
</tr>
</thead>
</table>
| 8051\config | Contains files used for configuring the development environment and projects, for example:  
  • Linker configuration files (*.xcl)  
  • C-SPY device description files (*.ddf)  
  • Device selection files (*.i51, *.menu)  
  • Syntax coloring configuration files (*.cfg)  
  • Project templates for both application and library projects (*.exp), and for the library projects, the corresponding library configuration files. |
| 8051\doc    | Contains release notes with recent additional information about the 8051 tools. We recommend that you read all of these files. The directory also contains online versions in hypertext PDF format of this user guide, and of the 8051 reference guides, as well as online help files (*.chm). |
| 8051\drivers| Contains low-level device drivers, typically USB drivers required by the C-SPY drivers.                                                      |
| 8051\examples| Contains files related to example projects, which can be opened from the Information Center.                                               |
| 8051\inc    | Contains include files, such as the header files for the standard C or C++ library. There are also specific header files that define special function registers (SFRs); these files are used by both the compiler and the assembler. |
| 8051\lib    | Contains prebuilt libraries and the corresponding library configuration files, used by the compiler.                                       |
| 8051\src    | Contains source files for some configurable library functions and the library source code.  
  For the XLINK linker, the directory also contains the source files for components common to all IAR Embedded Workbench products, such as a sample reader of the IAR XLINK Linker output format SIMPLE. |
| 8051\tutor  | Contains the files used for the tutorials in the Information Center.                                                                       |

Table 10: The 8051 directory (Continued)
THE COMMON DIRECTORY

The common directory contains subdirectories for components shared by all IAR Embedded Workbench products.

<table>
<thead>
<tr>
<th>Directory</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>common\bin</td>
<td>Contains executable files for components common to all IAR Embedded Workbench products, such as the editor and the graphical user interface components. The executable file for the IDE is also located here.</td>
</tr>
<tr>
<td>common\config</td>
<td>Contains files used by the IDE for settings in the development environment.</td>
</tr>
<tr>
<td>common\doc</td>
<td>Contains release notes with recent additional information about the components common to all IAR Embedded Workbench products. We recommend that you read these files. The directory also contains documentation related to installation and licensing, and getting started using IAR Embedded Workbench.</td>
</tr>
<tr>
<td>common\plugins</td>
<td>Contains executable files and description files for components that can be loaded as plugin modules, for example modules for code coverage.</td>
</tr>
</tbody>
</table>

Table 11: The common directory

THE INSTALL-INFO DIRECTORY

The install-info directory contains metadata (version number, name, etc.) about the installed product components. Do not modify these files.

File types

The IAR Systems development tools use the following default filename extensions to identify the produced files and other recognized file types:

<table>
<thead>
<tr>
<th>Ext.</th>
<th>Type of file</th>
<th>Output from</th>
<th>Input to</th>
</tr>
</thead>
<tbody>
<tr>
<td>a51</td>
<td>Target application</td>
<td>XLINK</td>
<td>EPROM, C-SPY, etc.</td>
</tr>
<tr>
<td>asm</td>
<td>Assembler source code</td>
<td>Text editor</td>
<td>Assembler</td>
</tr>
<tr>
<td>bat</td>
<td>Windows command batch file</td>
<td>Compiler</td>
<td>Windows</td>
</tr>
<tr>
<td>c</td>
<td>C source code</td>
<td>Text editor</td>
<td>Compiler</td>
</tr>
<tr>
<td>cfg</td>
<td>Syntax coloring configuration</td>
<td>Text editor</td>
<td>IDE</td>
</tr>
<tr>
<td>chm</td>
<td>Online help system file</td>
<td>--</td>
<td>IDE</td>
</tr>
<tr>
<td>cpp</td>
<td>C++ source code</td>
<td>Text editor</td>
<td>Compiler</td>
</tr>
</tbody>
</table>

Table 12: File types
<table>
<thead>
<tr>
<th>Ext.</th>
<th>Type of file</th>
<th>Output from</th>
<th>Input to</th>
</tr>
</thead>
<tbody>
<tr>
<td>csmpy.bat</td>
<td>Invocation file for csmpybat</td>
<td>C-SPY</td>
<td>-</td>
</tr>
<tr>
<td>d51</td>
<td>Target application with debug information</td>
<td>XLINK</td>
<td>C-SPY and other symbolic debuggers</td>
</tr>
<tr>
<td>dat</td>
<td>Macros for formatting of STL containers</td>
<td>IDE</td>
<td>IDE</td>
</tr>
<tr>
<td>dbg</td>
<td>Target application with debug information</td>
<td>XLINK</td>
<td>C-SPY and other symbolic debuggers</td>
</tr>
<tr>
<td>dbgdt</td>
<td>Debugger desktop settings</td>
<td>C-SPY</td>
<td>C-SPY</td>
</tr>
<tr>
<td>ddf</td>
<td>Device description file</td>
<td>Text editor</td>
<td>C-SPY</td>
</tr>
<tr>
<td>dep</td>
<td>Dependency information</td>
<td>IDE</td>
<td>IDE</td>
</tr>
<tr>
<td>dni</td>
<td>Debugger initialization file</td>
<td>C-SPY</td>
<td>C-SPY</td>
</tr>
<tr>
<td>ewd</td>
<td>Project settings for C-SPY</td>
<td>IDE</td>
<td>IDE</td>
</tr>
<tr>
<td>ewp</td>
<td>IAR Embedded Workbench project (current version)</td>
<td>IDE</td>
<td>IDE</td>
</tr>
<tr>
<td>ewplugin</td>
<td>IDE description file for plugin modules</td>
<td>--</td>
<td>IDE</td>
</tr>
<tr>
<td>eww</td>
<td>Workspace file</td>
<td>IDE</td>
<td>IDE</td>
</tr>
<tr>
<td>fmt</td>
<td>Formatting information for the Locals and Watch windows</td>
<td>IDE</td>
<td>IDE</td>
</tr>
<tr>
<td>h</td>
<td>C/C++ or assembler header source</td>
<td>Text editor</td>
<td>Compiler or\n#include assembler</td>
</tr>
<tr>
<td>helpfiles</td>
<td>Help menu configuration file</td>
<td>Text editor</td>
<td>IDE</td>
</tr>
<tr>
<td>html.htm</td>
<td>HTML document</td>
<td>Text editor</td>
<td>IDE</td>
</tr>
<tr>
<td>i</td>
<td>Preprocessed source</td>
<td>Compiler</td>
<td>Compiler</td>
</tr>
<tr>
<td>i51</td>
<td>Device selection file</td>
<td>Text editor</td>
<td>IDE</td>
</tr>
<tr>
<td>inc</td>
<td>Assembler header source</td>
<td>Text editor</td>
<td>Assembler\n#include</td>
</tr>
<tr>
<td>ini</td>
<td>Project configuration</td>
<td>IDE</td>
<td>-</td>
</tr>
<tr>
<td>log</td>
<td>Log information</td>
<td>IDE</td>
<td>-</td>
</tr>
<tr>
<td>lst</td>
<td>List output</td>
<td>Compiler and assembler</td>
<td>-</td>
</tr>
<tr>
<td>mac</td>
<td>C-SPY macro definition</td>
<td>Text editor</td>
<td>C-SPY</td>
</tr>
<tr>
<td>map</td>
<td>List output</td>
<td>XLINK</td>
<td>-</td>
</tr>
</tbody>
</table>

*Table 12: File types (Continued)*

**IDE Project Management and Building Guide**

164 for 8051
Installed files

When you run the IDE, some files are created and located in dedicated directories under your project directory, by default $PROJ_DIR$/Debug, $PROJ_DIR$/Release, $PROJ_DIR$/settings, and the file *.dep under the installation directory. None of these directories or files affect the execution of the IDE, which means you can safely remove them if required.

<table>
<thead>
<tr>
<th>Ext.</th>
<th>Type of file</th>
<th>Output from</th>
<th>Input to</th>
</tr>
</thead>
<tbody>
<tr>
<td>menu</td>
<td>Device selection file</td>
<td>Text editor</td>
<td>IDE</td>
</tr>
<tr>
<td>pbd</td>
<td>Source browse information</td>
<td>IDE</td>
<td>IDE</td>
</tr>
<tr>
<td>pbi</td>
<td>Source browse information</td>
<td>IDE</td>
<td>IDE</td>
</tr>
<tr>
<td>pew</td>
<td>IAR Embedded Workbench project (old project format)</td>
<td>IDE</td>
<td>IDE</td>
</tr>
<tr>
<td>prj</td>
<td>IAR Embedded Workbench project (old project format)</td>
<td>IDE</td>
<td>IDE</td>
</tr>
<tr>
<td>r5l</td>
<td>Object module</td>
<td>Compiler and assembler</td>
<td>XLINK, XAR, and XLIB</td>
</tr>
<tr>
<td>r5l</td>
<td>Library</td>
<td>XAR, XLIB</td>
<td>XLINK, XAR, and XLIB</td>
</tr>
<tr>
<td>s5l</td>
<td>Assembler source code</td>
<td>Text editor</td>
<td>Assembler</td>
</tr>
<tr>
<td>vsp</td>
<td>visualSTATE project files</td>
<td>IAR visualSTATE Designer</td>
<td>IAR visualSTATE Designer and IAR Embedded Workbench IDE</td>
</tr>
<tr>
<td>wsd</td>
<td>Workspace desktop settings</td>
<td>IDE</td>
<td>IDE</td>
</tr>
<tr>
<td>wsp</td>
<td>Main IDE window placement information</td>
<td>IDE</td>
<td>IDE</td>
</tr>
<tr>
<td>xcl</td>
<td>Extended command line</td>
<td>Text editor</td>
<td>Assembler, compiler, linker</td>
</tr>
</tbody>
</table>

Table 12: File types (Continued)

When you run the IDE, some files are created and located in dedicated directories under your project directory, by default $PROJ_DIR$/Debug, $PROJ_DIR$/Release, $PROJ_DIR$/settings, and the file *.dep under the installation directory. None of these directories or files affect the execution of the IDE, which means you can safely remove them if required.
Menu reference

Menus

Reference information about:

- File menu
- Edit menu
- View menu
- Project menu
- Tools menu
- Window menu
- Help menu.

In addition, a set of C-SPY-specific menus become available when you start the debugger. For more information about these menus, see the C-SPY® Debugging Guide for 8051.

File menu

The File menu provides commands for opening workspaces and source files, saving and printing, and exiting from the IDE.

The menu also includes a numbered list of the most recently opened files and workspaces. To open one of them, choose it from the menu.
**Menu commands**

These commands are available:

- **New (Ctrl+N)**  
  Displays a submenu with commands for creating a new workspace, or a new text file.

- **Open>File (Ctrl+O)**  
  Displays a submenu from which you can select a text file or an HTML document to open. See *Editor window*, page 129.

- **Open>Workspace**  
  Displays a submenu from which you can select a workspace file to open. Before a new workspace is opened you will be prompted to save and close any currently open workspaces.

- **Open>Header/Source File (Ctrl+Shift+H)**  
  Opens the header file or source file that corresponds to the current file, and shifts focus from the current file to the newly opened file. This command is also available from the context menu available from the editor window.

- **Close**  
  Closes the active window. You will be given the opportunity to save any files that have been modified before closing.

- **Save Workspace**  
  Saves the current workspace file.

- **Close Workspace**  
  Closes the current workspace file.

- **Save (Ctrl+S)**  
  Saves the current text file or workspace file.

- **Save As**  
  Displays a dialog box where you can save the current file with a new name.

- **Save All**  
  Saves all open text documents and workspace files.

- **Page Setup**  
  Displays a dialog box where you can set printer options.

- **Print (Ctrl+P)**  
  Displays a dialog box where you can print a text document.
Recent Files
Displays a submenu from where you can quickly open the most recently opened text documents.

Recent Workspaces
Displays a submenu from where you can quickly open the most recently opened workspace files.

Exit
Exits from the IDE. You will be asked whether to save any changes to text files before closing them. Changes to the project are saved automatically.

Edit menu
The Edit menu provides commands for editing and searching.

Menu commands
These commands are available:

**Undo (Ctrl+Z)**
Undoes the last edit made to the current editor window.
Menus

Redo (Ctrl+Y)
Redoes the last Undo in the current editor window.
You can undo and redo an unlimited number of edits independently in each editor window.

Cut (Ctrl+X)
The standard Windows command for cutting text in editor windows and text boxes.

Copy (Ctrl+C)
The standard Windows command for copying text in editor windows and text boxes.

Paste (Ctrl+V)
The standard Windows command for pasting text in editor windows and text boxes.

Select All (Ctrl+A)
Selects all text in the active editor window.

Find and Replace>Find (Ctrl+F)
Displays the Find dialog box where you can search for text within the current editor window; see Find dialog box, page 137. Note that if the insertion point is located in the Memory window when you choose the Find command, the dialog box will contain a different set of options than otherwise. If the insertion point is located in the Trace window when you choose the Find command, the Find in Trace dialog box is opened; the contents of this dialog box depend on the C-SPY driver you are using, see the C-SPY® Debugging Guide for 8051 for more information.

Find and Replace>Find Next (F3)
Finds the next occurrence of the specified string.

Find and Replace>Find Previous (Shift+F3)
Finds the previous occurrence of the specified string.

Find and Replace>Find Next (Selected) (Ctrl+F3)
Searches for the next occurrence of the currently selected text or the word currently surrounding the insertion point.

Find and Replace>Find Previous (Selected) (Ctrl+Shift+F3)
Searches for the previous occurrence of the currently selected text or the word currently surrounding the insertion point.
Find and Replace>Replace (Ctrl+H)
Displays a dialog box where you can search for a specified string and replace each occurrence with another string; see Replace dialog box, page 139. Note that if the insertion point is located in the Memory window when you choose the Replace command, the dialog box will contain a different set of options than otherwise.

Find and Replace>Find in Files
Displays a dialog box where you can search for a specified string in multiple text files; see Find in Files window, page 138.

Find and Replace>Replace in Files
Displays a dialog box where you can search for a specified string in multiple text files and replace it with another string; see Replace in Files dialog box, page 142.

Find and Replace>Incremental Search (Ctrl+I)
Displays a dialog box where you can gradually fine-tune or expand the search by continuously changing the search string; see Incremental Search dialog box, page 144.

Navigate>Go To (Ctrl+G)
Displays the Go to Line dialog box where you can move the insertion point to a specified line and column in the current editor window.

Navigate>Toggle Bookmark (Ctrl+F2)
Toggles a bookmark at the line where the insertion point is located in the active editor window.

Navigate>Previous Bookmark (Shift+F2)
Moves the insertion point to the previous bookmark that has been defined with the Toggle Bookmark command.

Navigate>Next Bookmark (F2)
Moves the insertion point to the next bookmark that has been defined with the Toggle Bookmark command.

Navigate>Navigate Backward (Alt+Left Arrow)
Navigates backward in the insertion point history. The current position of the insertion point is added to the history by actions like Go to definition and clicking on a result from the Find in Files command.

Navigate>Navigate Forward (Alt+Right Arrow)
Navigates forward in the insertion point history. The current position of the insertion point is added to the history by actions like Go to definition and clicking on a result from the Find in Files command.
Navigate>Go to Definition (F12)
- Shows the declaration of the selected symbol or the symbol where the insertion point is placed. This menu command is available when browse information has been enabled, see Project options, page 52.

Code Templates>Insert Template (Ctrl+Alt+V)
- Displays a list in the editor window from which you can choose a code template to be inserted at the location of the insertion point. If the code template you choose requires any field input, the Template dialog box appears; see Template dialog box, page 153. For information about using code templates, see Using and adding code templates, page 122.

Code Templates>Edit Templates
- Opens the current code template file, where you can modify existing code templates and add your own code templates. For information about using code templates, see Using and adding code templates, page 122.

Next Error/Tag (F4)
- If the message window contains a list of error messages or the results from a Find in Files search, this command displays the next item from that list in the editor window.

Previous Error/Tag (Shift+F4)
- If the message window contains a list of error messages or the results from a Find in Files search, this command displays the previous item from that list in the editor window.

Complete Word (Ctrl+Alt+Space)
- Attempts to complete the word you have begun to type, basing the guess on the contents of the rest of the editor document.

Complete Code (Ctrl+Space)
- Shows a list of symbols that are available in a class, when you place the insertion point after . , ->, or :: and when these characters are preceded by a class or object name. For more information, see Code completion, page 121.

Parameter Hint (Ctrl+Shift+Space)
- Suggests parameters as tooltip information for the function parameter list you have begun to type. When there are several overloaded versions of a function, you can choose which one to use by clicking the arrows in the tooltip. For more information, see Parameter hint, page 121.
Match Brackets
Selects all text between the brackets immediately surrounding the insertion point, increases the selection to the next hierarchic pair of brackets, or beeps if there is no higher bracket hierarchy.

Toggle All Folds (Ctrl+Alt+F)
Expands/collapses all code folds in the active project.

Auto Indent (Ctrl+T)
Indents one or several lines you have selected in a C/C++ source file. To configure the indentation, see Configure Auto Indent dialog box, page 46.

Block Comment (Ctrl+K)
Places the C++ comment character sequence `//` at the beginning of the selected lines.

Block Uncomment (Ctrl+K)
Removes the C++ comment character sequence `//` from the beginning of the selected lines.

Toggle Breakpoint (F9)
Toggles a breakpoint at the statement or instruction that contains or is located near the cursor in the source window.

This command is also available as an icon button on the debug toolbar.

Enable/Disable Breakpoint (Ctrl+F9)
Toggles a breakpoint between being disabled, but not actually removed—making it available for future use—and being enabled again.

View menu

The View menu provides several commands for opening windows and displaying toolbars in the IDE. When C-SPY is running you can also open debugger-specific windows from this menu. See the C-SPY® Debugging Guide for 8051 for information about these.
**Menu commands**

These commands are available:

**Messages**
Displays a submenu which gives access to the message windows—**Build**, **Find in Files**, **Tool Output**, **Debug Log**—that display messages and text output from the IAR Embedded Workbench commands. If the window you choose from the menu is already open, it becomes the active window.

**Workspace**
Opens the current **Workspace** window, see *Workspace window*, page 89.

**Source Browser**
- **Source Browser**
  Opening the **Source Browser** window, see *Source Browser window*, page 148.

**Source Browser**
- **References**
  Opening the **References** window, see *References window*, page 147.

**Source Browser**
- **Declarations**
  Opening the **Declarations** window, see *Declarations window*, page 145.

**Source Browser**
- **Call Graph**
  Opening the **Call Graph** window, see *Call Graph window*, page 152.

**Breakpoints**
Opening the **Breakpoints** window, see the *C-SPY® Debugging Guide for 8051*.

**Disassembly**
Opening the **Disassembly** window. Only available when C-SPY is running.

**Memory**
Opening the **Memory** window. Only available when C-SPY is running.

**Symbolic Memory**
Opening the **Symbolic Memory** window. Only available when C-SPY is running.

**Register**
Opening the **Register** window. Only available when C-SPY is running.

**Watch**
Opening the **Watch** window. Only available when C-SPY is running.

**Locals**
Opening the **Locals** window. Only available when C-SPY is running.

**Statics**
Opening the **Statics** window. Only available when C-SPY is running.
Auto
Opens the Auto window. Only available when C-SPY is running.

Live Watch
Opens the Live Watch window. Only available when C-SPY is running.

Quick Watch
Opens the Quick Watch window. Only available when C-SPY is running.

Call Stack
Opens the Call Stack window. Only available when C-SPY is running.

Stack
Opens the Stack window. Only available when C-SPY is running.

Terminal I/O
Opens the Terminal I/O window. Only available when C-SPY is running.

Images
Opens the Images window. Only available when C-SPY is running.

Code Coverage
Opens the Code Coverage window. Only available when C-SPY is running.

Symbols
Opens the Symbols window. Only available when C-SPY is running.

Toolbars
The options Main and Debug toggle the two toolbars on or off.

Status bar
Toggles the status bar on or off.
Project menu

The Project menu provides commands for working with workspaces, projects, groups, and files, and for specifying options for the build tools, and running the tools on the current project.

Menu commands

These commands are available:

Add Files
Displays a dialog box where you can select which files to include in the current project.

Add Group
Displays a dialog box where you can create a new group. In the Group Name text box, specify the name of the new group. For more information about groups, see Groups, page 81.
Import File List
Displays a standard Open dialog box where you can import information about files and groups from projects created using another IAR Systems toolchain.

To import information from project files which have one of the older filename extensions .pew or .prj you must first have exported the information using the context menu command Export File List available in your current IAR Embedded Workbench.

Add Project Connection
Displays the Add Project Connection dialog box, see Add Project Connection dialog box, page 95.

Edit Configurations
Displays the Configurations for project dialog box, where you can define new or remove existing build configurations. See Configurations for project dialog box, page 94.

Remove
In the Workspace window, removes the selected item from the workspace.

Create New Project
Displays the Create New Project dialog box where you can create a new project and add it to the workspace; see Create New Project dialog box, page 93.

Add Existing Project
Displays a standard Open dialog box where you can add an existing project to the workspace.

Options (Alt+F7)
Displays the Options dialog box, where you can set options for the build tools, for the selected item in the Workspace window; see Options dialog box, page 112. You can set options for the entire project, for a group of files, or for an individual file.

Version Control System
Displays a submenu with commands for version control, see Version Control System menu for SCC, page 96.

Make (F7)
Brings the current build configuration up to date by compiling, assembling, and linking only the files that have changed since the last build.

Compile (Ctrl+F7)
Compiles or assembles the currently selected file, files, or group.
One or more files can be selected in the Workspace window—all files in the same project, but not necessarily in the same group. You can also select the editor window containing the file you want to compile. The Compile command is only enabled if all files in the selection can be compiled or assembled.

You can also select a group, in which case the command is applied to each file in the group (also inside nested groups) that can be compiled, even if the group contains files that cannot be compiled, such as header files.

If the selected file is part of a multi-file compilation group, the command will still only affect the selected file.

**Rebuild All**
Rebuilds and relinks all files in the current target.

**Clean**
Removes any intermediate files.

**Batch Build (F8)**
Displays the Batch Build dialog box where you can configure named batch build configurations, and build a named batch. See Batch Build dialog box, page 114.

**Analyze Project**
Runs the external analyzer that you select and performs an analysis on all source files of your project. The list of analyzers is populated with analyzers that you specify on the External Analyzers page in the IDE Options dialog box.

Note that this menu command is not available if you have not added an analyzer. For more information, see Getting started using external analyzers, page 27.

**Analyze File(s)**
Runs the external analyzer that you select and performs an analysis on a group of files or on an individual file. The list of analyzers is populated with analyzers that you specify on the External Analyzers page in the IDE Options dialog box.

Note that this menu command is not available if you have not added an analyzer. For more information, see Getting started using external analyzers, page 27.

**Stop Build (Ctrl+Break)**
Stops the current build operation.
**Menu reference**

**Download and Debug (Ctrl+D)**
Downloads the application and starts C-SPY so that you can debug the project object file. If necessary, a make will be performed before running C-SPY to ensure the project is up to date. This command is not available during a debug session.

**Debug without Downloading**
Starts C-SPY so that you can debug the project object file. This menu command is a shortcut for the Suppress Download option available on the Download page. The Debug without Downloading command is not available during a debug session.

**Make & Restart Debugger**
Stops C-SPY, makes the active build configuration, and starts the debugger again; all in a single command. This command is only available during a debug session.

**Restart Debugger**
Stops C-SPY and starts the debugger again; all in a single command. This command is only available during a debug session.

**Download**
Commands for flash download and erase. Note that these menu commands are not available in IAR Embedded Workbench for 8051.

**SFR Setup**
Opens the SFR Setup window which displays the currently defined SFRs that C-SPY has information about. For more information about this window, see the C-SPY® Debugging Guide for 8051.

**Open Device Description File**
Opens a submenu where you can choose to open a file from a list of all device files and SFR definitions files that are in use.

**List All Registers to File**
Reads the contents of all registers, including SFRs, and stores the list in a log file. If you are not in a debug session, only the list of registers is stored.

**Tools menu**
The Tools menu provides commands for customizing the environment, such as changing common fonts and shortcut keys.
It is a user-configurable menu to which you can add tools for use with IAR Embedded Workbench. Thus, it might look different depending on which tools you have preconfigured to appear as menu items.

**Menu Commands**

These commands are available:

**Options**

Displays the IDE Options dialog box where you can customize the IDE. See:

- Common Fonts options, page 39
- Key Bindings options, page 40
- Language options, page 41
- Editor options, page 42
- Configure Auto Indent dialog box, page 46
- External Editor options, page 47
- Editor Setup Files options, page 48
- Editor Colors and Fonts options, page 49
- Messages options, page 50
- Project options, page 52
- Source Code Control options, page 58
- Debugger options, page 59
- Stack options, page 61
- Register Filter options, page 63
- Terminal I/O options, page 65.

**Configure Tools**

Displays the Configure Tools dialog box where you can set up the interface to use external tools; see Configure Tools dialog box, page 66.
Filename Extensions
Displays the Filename Extensions dialog box where you can define the filename extensions to be accepted by the build tools; see Filename Extensions dialog box, page 70.

Configure Viewers
Displays the Configure Viewers dialog box where you can configure viewer applications to open documents with; see Configure Viewers dialog box, page 68.

Notepad
User-configured. This is an example of a user-configured addition to the Tools menu.

Window menu
The Window menu provides commands for manipulating the IDE windows and changing their arrangement on the screen.

<table>
<thead>
<tr>
<th>Close Tab</th>
<th>Ctrl+F4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Close Window</td>
<td></td>
</tr>
<tr>
<td>Split</td>
<td></td>
</tr>
<tr>
<td>New Vertical Editor Window</td>
<td></td>
</tr>
<tr>
<td>New Horizontal Editor Window</td>
<td></td>
</tr>
<tr>
<td>Move Tabs to Next Window</td>
<td></td>
</tr>
<tr>
<td>Move Tabs to Previous Window</td>
<td></td>
</tr>
<tr>
<td>Close All Tabs Except Active</td>
<td></td>
</tr>
<tr>
<td>Close All Tabs to the Right of Active</td>
<td></td>
</tr>
<tr>
<td>Close All Editor Tabs</td>
<td></td>
</tr>
</tbody>
</table>

The last section of the Window menu lists the currently open windows. Choose the window you want to switch to.

Menu commands
These commands are available:

Close Tab
Closes the active tab.

Close Window (Ctrl+F4)
Closes the active editor window.

Split
Splits an editor window horizontally or vertically into two or four panes, which means that you can see more parts of a file simultaneously.
New Vertical Editor Window
Opens a new empty window next to the current editor window.

New Horizontal Editor Window
Opens a new empty window under the current editor window.

Move Tabs to Next Window
Moves all tabs in the current window to the next window.

Move Tabs to Previous Window
Moves all tabs in the current window to the previous window.

Close All Tabs Except Active
Closes all the tabs except the current tab.

Close All Tabs to the Right of Active
Closes all tabs to the right of the current tab.

Close All Editor Tabs
Closes all tabs currently available in editor windows.

Help menu

The Help menu provides help about IAR Embedded Workbench and displays the version numbers of the user interface and of the IDE.

You can also access the Information Center from the Help menu. The Information Center is an integrated navigation system that gives easy access to the information resources you need to get started and during your project development: tutorials, example projects, user guides, support information, and release notes. It also provides shortcuts to useful sections on the IAR Systems web site.
General options

• Description of general options

Description of general options

Reference information about:
• Target options
• Stack/Heap
• Data Pointer
• Code Bank
• Output
• Library Configuration
• Library Options
• MISRA C

To set general options in the IDE:
1 Choose Project>Options to display the Options dialog box.
2 Select General Options in the Category list.
3 To restore all settings to the default factory settings, click the Factory Settings button.
Description of general options

**Target options**

The **Target** options specify target-specific features for the IAR C/C++ Compiler and Assembler.

![Target options screenshot]

**Device information**

Selects the processor variant:

**Device**

The device you are using. The choice of device controls the availability of a number of other options, and will automatically determine the default linker configuration file and C-SPY® device description file. For information about how to override the default files, see the *C-SPY® Debugging Guide for 8051*.

**CPU core**

The processor core you are using. For a description of the available variants, see the *IAR C/C++ Compiler Reference Guide for 8051*.

**Code model**

Selects the code model for your project.

The code model specifies the way in which code is generated and called. All object files in an application must use the same default code model. Your choice of code model determines the default function type attribute to be used by the compiler. The availability of a certain code model depends on the choice of CPU core.

For more information about the code models, see the *IAR C/C++ Compiler Reference Guide for 8051*. 
Data model

Selects the data model for your project.

The data model specifies the data memory which is used for storing static and globally defined variables and dynamically allocated data. All object files in an application must use the same default data model. The availability of a certain data model depends on the choice of CPU core.

For more information about the data models, see the IAR C/C++ Compiler Reference Guide for 8051.

Number of virtual registers

Selects the number of virtual registers to use.

A dedicated area of the 8051 internal RAM is used by the compiler as registers. In many cases the application code size will be smaller if you use many virtual registers, up to a certain limit.

For more information about virtual registers, see the IAR C/C++ Compiler Reference Guide for 8051.

Use MDU

Enables support for a Multiplication-Division Unit, if the device has one.

The Multiplication-Division Unit makes it possible to use hardware accelerator options for multiplication and division from within your code.

Use extended stack

Enables the extended stack. For more information about the extended stack, see the IAR C/C++ Compiler Reference Guide for 8051.

Calling convention

Selects the default calling convention for your project.

The calling convention controls whether the compiler by default should use a stack model or an overlay model for local data and in which memory the stack or overlay frame should be placed. The availability of a certain calling convention depends on the choice of code and data model.

All object files in an application must use the same default calling convention.

For more information about the calling conventions, see the IAR C/C++ Compiler Reference Guide for 8051.
Description of general options

Location for constants and strings

Selects the default location for constants and strings. Choose between:

**RAM memory**

Copies constants and strings from code memory to data memory. The specific data memory depends on the default data model.

**ROM mapped as data**

Places constants and strings in xdata, far, or huge memory, depending on the data model, in a range where ROM is located. In the:

- Xdata data model, the objects are placed in xdata memory.
- Far data model, the objects are placed in far memory.
- Huge data model, the objects are placed in huge memory.

In the other data models, the option has no effect and the RAM memory option will be used instead.

**CODE memory**

Places constants and strings in code memory.

Stack/Heap

The **Stack/Heap** options determine the heap and stack sizes.

For more information about using the stacks and heaps, see the IAR C/C++ Compiler Reference Guide for 8051.

**Note:** If you are using the extended stack, all object files in the application must use the same extended stack options.
Stack sizes
Specify the sizes of the idata, pdata, xdata, and extended stacks, respectively.

Heap sizes
Specify the sizes of the xdata, far, far22, and huge heaps, respectively.

Extended stack pointer address
Specify the address of the high byte of the extended stack pointer.

Extended stack pointer mask
Specify the bits used to mask the high byte of the extended stack pointer.

Extended stack pointer is an offset
Makes the extended stack start at another address than 0. This requires that your device supports extended stacks at other addresses.

Extended stack pointer start address
Specify the location of the extended stack in xdata memory.

Data Pointer
The Data Pointer options control the use of the data pointer registers (DPTRs) for your project. Up to 8 DPTRs are supported.

For more information about using the stacks and heaps, see the IAR C/C++ Compiler Reference Guide for 8051.
Number of DPTRs
Specify the number of data pointer registers you want to have available. For the extended1 core, the default value is 2, for the other cores it is 1.

DPTR select
Specify how to select the active DPTR.

Select register
Specify the address of the DPTR select register (usually called DPSEL or DPS).

Toggle using INC
Selects the method for selecting the active DPTR. This method can increment the bits in the DPTR selection register to select the active DPTR. This is the more efficient method, but it is not supported by all devices.

Set using XOR/AND
Selects the method for selecting the active DPTR. This default method uses the ORL or ANL instruction to set the active pointer in the DPTR selection register. This method is not always as efficient but it can always be used.

Mask
Specify which bits of the DPTR select register that are used to specify the current DPTR. 0x05, for instance, indicates that bits 0 and 2 specify the pointer (0x05=00000101).

Separate DPTR control register
If the IDE recognizes that your device supports the separate DPTR control register, the correct address is specified automatically. If you need to specify the address manually, use this option.

The separate DPTR control register is an SFR, supported by some devices, that controls various features used together with DPTRs.

Size
Set the DPTR size in bits, either 16 bits or 24 bits. The default size of DPTR depends on the device you are using.

DPTR addresses
Controls how the DPTR addresses will be handled. Choose between:

Shadowed
The SFR (special function register) parts of a DPTR register hides the SFR parts of another register.
Separate

The SFR parts of a DPTR register are all visible in separate SFRs. Click on Configure to display a dialog box where you can specify the addresses for the SFRs.

The value of this option depends on the device you are using.

Page register address

Specifies the address of the SFR register(s) that defines the page in external data that the MOVX @Ri, A and MOVX A, @Ri instructions operate on:

Bit 8-15

Specify the address for bits 8–15 of the register(s).

Bit 16-31

Specify the address for bits 16–32 of the register(s).

Code Bank

The Code Bank options control the use of the banking system.

<table>
<thead>
<tr>
<th>Code Bank</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of banks: 0x03</td>
</tr>
<tr>
<td>Register address: 0x07</td>
</tr>
<tr>
<td>Register mask: 0x00</td>
</tr>
<tr>
<td>Bank start: 0x0000</td>
</tr>
<tr>
<td>Bank end: 0xFFFF</td>
</tr>
</tbody>
</table>

For more information about the banking system, see the IAR C/C++ Compiler Reference Guide for 8051.

Number of banks

Specify the number of banks to be used.

Register address

Specify the SFR address to be used as bank register.
Description of general options

**Register mask**
Specify the bits that are active in the bank register.

**Bank start**
Specify the bank start address.

**Bank end**
Specify the bank end address.

**Output**
The Output options determine the type of output file. You can also specify the destination directories for executable files, object files, and list files.

**Output file**
Selects the type of the output file:

- **Executable (default)**
  As a result of the build process, the linker will create an application (an executable output file). When this setting is used, linker options will be available in the Options dialog box. Before you create the output you should set the appropriate linker options.

- **Library**
  As a result of the build process, the library builder will create a library file. When this setting is used, library builder options will be available in the Options dialog box, and Linker will disappear from the list of categories. Before you create the library you can set the options.
Output directories

Specify the paths to the destination directories. Note that incomplete paths are relative to your project directory. You can specify:

**Executables/libraries**

Override the default directory for executable or library files. Type the name of the directory where you want to save executable files for the project.

**Object files**

Override the default directory for object files. Type the name of the directory where you want to save object files for the project.

**List files**

Override the default directory for list files. Type the name of the directory where you want to save list files for the project.

Library Configuration

The Library Configuration options determine which library to use.

For information about the runtime library, library configurations, the runtime environment they provide, and the possible customizations, see *IAR C/C++ Compiler Reference Guide for 8051*.

**Library**

Selects which runtime library to use. For information about available libraries, see the *IAR C/C++ Compiler Reference Guide for 8051*.

**Note:** For C++ projects, you must use one of the DLIB library variants.

The names of the library object file and library configuration file that actually will be used are displayed in the **Library file** and **Configuration file** text boxes, respectively.
Description of general options

Library file
Displays the library object file that will be used. A library object file is automatically chosen depending on your settings of these options:

- CLIB/DLIB runtime environment
- Core variant
- Stack location
- Code model
- Data model
- Calling convention
- Constant location
- Number of data pointers
- Data pointer visibility
- Data pointer size
- Data pointer selection method
- Data pointer selection mask, if the data pointer selection method is XOR.

If you have chosen Custom DLIB or Custom CLIB in the Library drop-down list, you must specify your own library object file.

Configuration file
Displays the library configuration file that will be used. A library configuration file is chosen automatically depending on the project settings. If you have chosen Custom DLIB in the Library drop-down list, you must specify your own library configuration file.

Note: A library configuration file is only required for the DLIB library.
Library Options

The Library Options select the printf and scanf formatters.

For information about the capabilities of the formatters, see the IAR C/C++ Compiler Reference Guide for 8051.

Printf formatter

If Auto is selected, the linker automatically chooses the appropriate formatter for printf-related functions based on information from the compiler.

To override the default formatter for all printf-related functions, except for wprintf variants, choose between:

- Printf formatters in the IAR DLIB Library: Full, Full without multibytes, Large, Large without multibytes, Small, Small without multibytes, and Tiny
- Printf formatters in the IAR CLIB Library: Large, Medium, and Small

Choose a formatter that suits the requirements of your application.

Scanf formatter

If Auto is selected, the linker automatically chooses the appropriate formatter for scanf-related functions based on information from the compiler.

To override the default formatter for all scanf-related functions, except for wscanf variants, choose between:

- Scanf formatters in the IAR DLIB Library: Full, Full without multibytes, Large, Large without multibytes, Small, and Small without multibytes
- Scanf formatters in the IAR CLIB Library: Large, and Medium

Choose a formatter that suits the requirements of your application.
MISRA C

The MISRA-C:1998 and MISRA-C:2004 options control how the IDE checks the source code for deviations from the MISRA C rules. The settings are used for both the compiler and the linker.

For details about specific options, see the *IAR Embedded Workbench® MISRA C:2004 Reference Guide* or the *IAR Embedded Workbench® MISRA C:1998 Reference Guide* available from the Help menu.
Compiler options

- Description of compiler options

Description of compiler options

Reference information about:
- Multi-file Compilation
- Language 1
- Language 2
- Code
- Optimizations
- Output
- List
- Preprocessor
- Diagnostics
- MISRA C
- Extra Options
- Edit Include Directories dialog box

To set compiler options in the IDE:
1 Choose Project>Options to display the Options dialog box.
2 Select C/C++ Compiler in the Category list.
3 To restore all settings to the default factory settings, click the Factory Settings button.

Multi-file Compilation

Before you set specific compiler options, you can decide whether you want to use multi-file compilation, which is an optimization technique.

Multi-file Compilation

Enables multi-file compilation from the group of project files that you have selected in the workspace window.
Description of compiler options

You can use this option for the entire project or for individual groups of files. All C/C++ source files in such a group are compiled together using one invocation of the compiler.

This means that all files included in the selected group are compiled using the compiler options which have been set on the group or nearest higher enclosing node which has any options set. Any overriding compiler options on one or more files are ignored when building, because a group compilation must use exactly one set of options.

For information about how multi-file compilation is displayed in the Workspace window, see Workspace window, page 89.

**Discard Unused Publics**

Discards any unused public functions and variables from the compilation unit.

For more information about multi-file compilation and discarding unused public functions, see the *IAR C/C++ Compiler Reference Guide for 8051*.

**Language**

The **Language** options determine which programming language to use and which extensions to enable.

For more information about the supported languages, their dialects, and their extensions, see the *IAR C/C++ Compiler Reference Guide for 8051*.

**Language**

Determines the compiler support for either C or C++:

- **C (default)**
  - Makes the compiler treat the source code as C, which means that features specific to C++ cannot be used.
Compiler options

**C++**

Makes the compiler treat the source code as Embedded C++ or Extended Embedded C++. This means that some features specific to C++, such as classes and overloading, can be used.

**Auto**

Language support is decided automatically depending on the filename extension of the file being compiled:

- c, files with this filename extension are treated as C source files.
- cpp, files with this filename extension will be treated as C++ source files.

**Language conformance**

Controls how strictly the compiler adheres to the standard C or C++ language:

**Standard with IAR extensions**

Accepts 8051-specific keywords as extensions to the standard C or C++ language. In the IDE, this setting is enabled by default.

**Standard**

Disables IAR Systems extensions, but does not adhere strictly to the C or C++ dialect you have selected. Some very useful relaxations to C or C++ are still available.

**Strict**

Adheres strictly to the C or C++ dialect you have selected. This setting disables a great number of useful extensions and relaxations to C or C++.

**C dialect**

Selects the dialect if C is the supported language:

**C89**

Enables the C89 standard instead of Standard C. Note that this setting is mandatory when the MISRA C checking is enabled.

**C99**

Enables the C99 standard, also known as Standard C. This is the default standard used in the compiler, and it is stricter than C89. Features specific to C89 cannot be used. In addition, choose between:

- **Allow VLA**, allows the use of C99 variable length arrays.
- **C++ inline semantics**, enables C++ inline semantics when compiling a Standard C source code file.
Description of compiler options

**Require prototypes**

Forces the compiler to verify that all functions have proper prototypes, which means that source code containing any of the following will generate an error:

- A function call of a function with no declaration, or with a Kernighan & Ritchie C declaration.
- A function definition of a public function with no previous prototype declaration.
- An indirect function call through a function pointer with a type that does not include a prototype.

**C++ dialect**

Selects the dialect if C++ is the supported language:

**Embedded C++**

Makes the compiler treat the source code as Embedded C++. This means that features specific to C++, such as classes and overloading, can be used.

**Extended Embedded C++**

Enables features like namespaces or the standard template library in your source code.

**Destroy static objects**

Makes the compiler generate code to destroy C++ static variables that require destruction at program exit.

C++ requires that a DLIB library (C/C++ library) is used.
Language 2

The Language 2 options control the use of some language extensions.

Plain 'char' is

Normally, the compiler interprets the plain char type as unsigned char. Plain 'char' is Signed makes the compiler interpret the char type as signed char instead, for example for compatibility with another compiler.

Note: The runtime library is compiled with unsigned plain characters. If you select the Signed option, references to library functionality that uses unsigned plain characters will not work.

Floating-point semantics

Controls floating-point semantics. Choose between:

Strict conformance

Makes the compiler conform strictly to the C and floating-point standards for floating-point expressions.

Relaxed

Makes the compiler relax the language rules and perform more aggressive optimization of floating-point expressions. This option improves performance for floating-point expressions that fulfill these conditions:

- The expression consists of both single- and double-precision values
- The double-precision values can be converted to single precision without loss of accuracy
- The result of the expression is converted to single precision.
Note that performing the calculation in single precision instead of double precision might cause a loss of accuracy.

**Enable multibyte support**

By default, multibyte characters cannot be used in C or Embedded C++ source code. **Enable multibyte support** makes the compiler interpret multibyte characters in the source code according to the host computer’s default setting for multibyte support.

Multibyte characters are allowed in C and C++ style comments, in string literals, and in character constants. They are transferred untouched to the generated code.

**Code**

The **Code** options control the code generation of the compiler.

For more information about these compiler options, see the *IAR C/C++ Compiler Reference Guide for 8051*.

**Padding for ROM-monitor breakpoints**

Makes the compiler add NOP instructions in the code which makes it possible to use the IAR C-SPY ROM-monitor.

**No UBROF messages in output file**

By default, range error messages are embedded in the UBROF output object file. These messages can contain tiny fragments of your source code.

Use this option if you do not want the UBROF output file to contain this type of information. The drawback is that the range error messages will be less helpful.
Optimizations

The **Optimizations** options determine the type and level of optimization for the generation of object code.

### Level

Selects the optimization level:

- **None**
  - No optimization; provides best debug support.

- **Low**
  - The lowest level of optimization.

- **Medium**
  - The medium level of optimization.

- **High, balanced**
  - The highest level of optimization, balancing between speed and size.

- **High, size**
  - The highest level of optimization, favors size.

- **High, speed**
  - The highest level of optimization, favors speed.

- **No size constraints**
  - Optimizes for speed, but relaxes the normal restrictions for code size expansion.
  - This option is only available at the level **High, speed**.
By default, a debug project will have a size optimization that is fully debuggable, while a release project will have a high balanced optimization that generates small code without sacrificing speed.

For a list of optimizations performed at each optimization level, see the *IAR C/C++ Compiler Reference Guide for 8051*.

**Enabled transformations**

Selects which transformations that are available at different optimization levels. When a transformation is available, you can enable or disable it by selecting its check box. Choose between:

- Common subexpression elimination
- Loop unrolling
- Function inlining
- Code motion
- Type-based alias analysis

In a debug project the transformations are, by default, disabled. In a release project the transformations are, by default, enabled.

For a brief description of the transformations that can be individually disabled, see the *IAR C/C++ Compiler Reference Guide for 8051*.

**Output**

The **Output** options determine the generated compiler output.
Module type

Selects the module type. Select **Override default** and choose between:

**Program Module**

The object file will be treated as a program module rather than as a library module. By default, the compiler generates program modules.

**Library Module**

The object file will be treated as a library module rather than as a program module. A library module will only be included if it is referenced in your application.

For information about program and library modules, and working with libraries, see the XLIB and XAR chapters in the *IAR Linker and Library Tools Reference Guide*, available from the **Help** menu.

Object module name

Specify the object module name. Normally, the internal name of the object module is the name of the source file, without a directory name or extension.

This option is particularly useful when several modules have the same filename, because the resulting duplicate module name would normally cause a linker error; for example, when the source file is a temporary file generated by a preprocessor.

Generate debug information

Makes the compiler include additional information in the object modules that is required by C-SPY® and other symbolic debuggers.

**Generate debug information** is selected by default. Deselect it if you do not want the compiler to generate debug information.

**Note:** The included debug information increases the size of the object files.
Description of compiler options

List

The List options make the compiler generate a list file and determine its contents.

By default, the compiler does not generate a list file. Select any of the following options to generate a list file or an assembler file. The list file will be saved in the List directory, and its filename will consist of the source filename, plus the filename extension lst.

If you want to save the list file in another directory than the default directory for list files, use the Output Directories option in the General Options category; see Output, page 190, for additional information.

You can open the output files directly from the Output folder which is available in the Workspace window.

Output list file

Makes the compiler generate a list file. You can open the output files directly from the Output folder which is available in the Workspace window. By default, the compiler does not generate a list file. For the list file content, choose between:

Assembler mnemonics

Includes assembler mnemonics in the list file.

Diagnostics

Includes diagnostic information in the list file.

Output assembler file

Makes the compiler generate an assembler list file. For the list file content, choose between:

Include source

Includes source code in the assembler file.
Include call frame information
Includes compiler-generated information for runtime model attributes, call frame information, and frame size information.

Preprocessor

The Preprocessor options allow you to define symbols and include paths for use by the compiler and assembler.

Ignore standard include directories
Normally, the compiler and assembler automatically look for include files in the standard include directories. Use this option to turn off this behavior.

Additional include directories
Specify the full paths of directories to search for include files, one per line. Any directories specified here are searched before the standard include directories, in the order specified.

Use the browse button to display the Edit Include Directories dialog box, where you can specify directories using a file browser. For more information, see Edit Include Directories dialog box, page 209.

To avoid being dependent on absolute paths, and to make the project more easily portable between different machines and file system locations, you can use argument variables like $TOOLKIT_DIR$ and $PROJ_DIR$, see Argument variables, page 72.

Preinclude file
Specify a file to include before the first line of the source file.
Defined symbols

Define a macro symbol (one per line), including its value, for example like this:

\texttt{TESTVER=1}

This has the same effect as if a line like this appeared before the start of the source file:

\texttt{\#define TESTVER 1}

A line with no value has the same effect as if \texttt{=}1 was specified.

Preprocessor output to file

Makes the compiler and assembler output the result of the preprocessing to a file with the filename extension \texttt{i}, located in the \texttt{lst} directory. Choose between:

\begin{itemize}
  \item \textbf{Preserve comments} \hfill includes comments in the output. Normally, comments are treated as whitespace, and their contents are not included in the preprocessor output.
  \item \textbf{Generate \#line directives} \hfill generates \texttt{\#line} directives in the output to indicate where each line originated from.
\end{itemize}

Diagnostics

The \textbf{Diagnostics} options determine how diagnostic messages are classified and displayed. Use the diagnostics options to override the default classification of the specified diagnostics.

\begin{itemize}
  \item \textbf{Enable remarks}
  \item \textbf{Suppress these diagnostic:}
  \item \textbf{Treat these as remarks:}
  \item \textbf{Treat these as warnings:}
  \item \textbf{Treat these as errors:}
  \item \textbf{Treat all warnings as errors}
\end{itemize}

\textbf{Note:} The diagnostic messages cannot be suppressed for fatal errors, and fatal errors cannot be reclassified.
Enable remarks

Enables the generation of remarks. By default, remarks are not issued.

The least severe diagnostic messages are called remarks. A remark indicates a source code construct that might cause strange behavior in the generated code.

Suppress these diagnostics

Suppresses the output of diagnostic messages for the tags that you specify.

For example, to suppress the warnings Xx117 and Xx177, type:

Xx117, Xx177

Treat these as remarks

Classifies diagnostic messages as remarks. A remark is the least severe type of diagnostic message. It indicates a source code construct that might cause strange behavior in the generated code.

For example, to classify the warning Xx177 as a remark, type:

Xx177

Treat these as warnings

Classifies diagnostic messages as warnings. A warning indicates an error or omission that is of concern, but which will not cause the compiler to stop before compilation is completed.

For example, to classify the remark Xx826 as a warning, type:

Xx826

Treat these as errors

Classifies diagnostic messages as errors. An error indicates a violation of the language rules, of such severity that object code will not be generated, and the exit code will be non-zero.

For example, to classify the warning Xx117 as an error, type:

Xx117

Treat all warnings as errors

Classifies all warnings as errors. If the compiler encounters an error, object code is not generated.
Extra Options

The Extra Options page provides you with a command line interface to the tool.

**Use command line options**

Specify additional command line arguments to be passed to the tool (not supported by the GUI).

**MISRA C**

The MISRA-C:1998 and MISRA-C:2004 options override the corresponding options in the General Options category.

For details about specific option, see the IAR Embedded Workbench® MISRA C:2004 Reference Guide or the IAR Embedded Workbench® MISRA C:1998 Reference Guide available from the Help menu.
The Edit Include Directories dialog box is available from the Preprocessor page in the Options dialog box for the compiler and assembler categories.

Use this dialog box to specify or delete include paths, or to make a path relative or absolute.

**To add a path to an include directory:**
1. Click the text <Click to add>. A browse dialog box is displayed.
2. Browse to the appropriate include directory and click Select. The include path appears.
   To add yet another one, click <Click to Add>.

**To make the path relative or absolute:**
1. Click the drop-down arrow. A context menu is displayed, which shows the absolute path and paths relative to the argument variables $PROJ_DIRS$ and $TOOLKIT_DIRS$, when possible.
2. Choose one of the alternatives.

**To change the order of the paths:**
1. Use the shortcut key combinations Ctrl+Up/Down.
2. Notice that the list will be sorted accordingly.

**To delete an include path:**
1. Select the include path and click the red cross at the beginning of the line, alternatively press the Delete key.
2. Notice that the selected path will disappear.
Description of compiler options
Assembler options

- Description of assembler options

Description of assembler options
Reference information about:
- Language
- Output
- List
- Preprocessor
- Diagnostics
- Extra Options

To set assembler options in the IDE:
1. Choose Project>Options to display the Options dialog box.
2. Select Assembler in the Category list.
3. To restore all settings to the default factory settings, click the Factory Settings button.

Language

The Language options control certain behavior of the assembler language.

- User symbols are case sensitive
- Enable multibyte support
- Macro quote characters:
  - Single quote: `'
  - Double quote: `"`

**User symbols are case sensitive**

Toggles case sensitivity on and off. By default, case sensitivity is on. This means that, for example, LABEL and label refer to different symbols. When case sensitivity is off, LABEL and label will refer to the same symbol.

**Enable multibyte support**

Makes the assembler interpret multibyte characters in the source code according to the host computer’s default setting for multibyte support. By default, multibyte characters cannot be used in assembler source code.

Multibyte characters are allowed in comments, in string literals, and in character constants. They are transferred untouched to the generated code.

**Macro quote characters**

Selects the characters used for the left and right quotes of each macro argument. By default, the characters are `<` and `>`. 

**Macro quote characters** changes the quote characters to suit an alternative convention or simply to allow a macro argument to contain `<` or `>`. 

![Macro quote character selection](image)

**Output**

The **Output** options determine the generated assembler output.
Generate debug information

Makes the assembler generate debug information. Use this option if you want to use a debugger with your application. By default, this option is selected in a Debug project, but not in a Release project.

List

The List options make the assembler generate a list file and determine its contents.

Output list file

Makes the assembler generate a list file and send it to the file `sourcename.lst`. By default, the assembler does not generate a list file.

If you want to save the list file in another directory than the default directory for list files, use the Output Directories option in the General Options category; see Output, page 190, for additional information. You can open the output files directly from the Output folder which is available in the Workspace window.

Include header

Includes the header. The header of the assembler list file contains information about the product version, date and time of assembly, and the command line equivalents of the assembler options that were used.

Include listing

Selects which type of information to include in the list file:

#included text

Includes `#include` files in the list file.
Macro definitions
   Includes macro definitions in the list file.

Macro expansion
   Excludes macro expansions from the list file.

Macro execution info
   Prints macro execution information on every call of a macro.

Assembled lines only
   Excludes lines in false conditional assembler sections from the list file.

Multiline code
   Lists the code generated by directives on several lines if necessary.

Include cross-reference
   Includes a cross-reference table at the end of the list file:

   #define
   Includes preprocessor #defines.

   Internal symbols
   Includes all symbols, user-defined as well as assembler-internal.

   Dual line spacing
   Uses dual-line spacing.

Lines/page
   Specify the number of lines per page, within the range 10 to 150. The default number of lines per page is 80 for the assembler list file.

Tab spacing
   Specify the number of character positions per tab stop, within the range 2 to 9. By default, the assembler sets eight character positions per tab stop.
Preprocessor

The Preprocessor options allow you to define symbols and include paths for use by the assembler.

Ignore standard include directories

Normally, the compiler and assembler automatically look for include files in the standard include directories. Use this option to turn off this behavior.

Additional include directories

Specify the full paths of directories to search for include files, one per line. Any directories specified here are searched before the standard include directories, in the order specified.

Use the browse button to display the Edit Include Directories dialog box, where you can specify directories using a file browser. For more information, see Edit Include Directories dialog box, page 209.

To avoid being dependent on absolute paths, and to make the project more easily portable between different machines and file system locations, you can use argument variables like $TOOLKIT_DIR$ and $PROJ_DIR$, see Argument variables, page 72.

Defined symbols

Define a macro symbol (one per line), including its value, for example like this:

\texttt{TESTVER=1}

This has the same effect as if a line like this appeared before the start of the source file:

\texttt{\#define\ \ TESTVER\ 1}

A line with no value has the same effect as if \texttt{=1} was specified.
Diagnostics

The Diagnostics options control individual warnings or ranges of warnings.

Warnings

Controls the assembler warnings. The assembler displays a warning message when it finds an element of the source code that is legal, but probably the result of a programming error. By default, all warnings are enabled. To control the generation of warnings, choose between:

Enable
Enables warnings.

Disable
Disables warnings.

All warnings
Enables/disables all warnings.

Just warning
Enables/disables the warning you specify.

Warnings from to
Enables/disables all warnings in the range you specify.

For additional information about assembler warnings, see the IAR Assembler Reference Guide for 8051.

Disable all warnings
Disables all warnings.
**Assembler options**

**Disable warning or range of warnings**
Disables the warning or warnings in the range you specify.

**Enable warning or range of warnings**
Disables the warning or warnings in the range you specify.

**Max number of errors**
Specify the maximum number of errors. This means that you can increase or decrease the number of reported errors, for example, to see more errors in a single assembly. By default, the maximum number of errors reported by the assembler is 100.

**Extra Options**
The Extra Options page provides you with a command line interface to the tool.

**Use command line options**
Specify additional command line arguments to be passed to the tool (not supported by the GUI).
Description of assembler options
Custom build options

- Description of custom build options

Description of custom build options

Reference information about:
- Custom Tool Configuration

To set custom build options in the IDE:
1. Choose Project>Options to display the Options dialog box.
2. Select Custom Build in the Category list.

Custom Tool Configuration

The Custom Tool Configuration options control the invocation of the tools you want to add to the tool chain.

![Custom Tool Configuration Options](image)

For an example, see Extending the toolchain, page 103.

Filename extensions

Specify the filename extensions for the types of files that are to be processed by the custom tool. You can type several filename extensions. Use commas, semicolons, or blank spaces as separators. For example:

`.htm; .html`
Description of custom build options

**Command line**
Specify the command line for executing the external tool.

**Output file**
Specify the name for the output files from the external tool.

**Additional input files**
Specify any additional files to be used by the external tool during the build process. If these additional input files, *dependency* files, are modified, the need for a rebuild is detected.
Build actions options

- Description of build actions options

Description of build actions options

Reference information about:
- Build Actions Configuration

To set build action options in the IDE:

1. Choose Project>Options to display the Options dialog box.
2. Select Build Actions in the Category list.

Build Actions Configuration

The Build Actions Configuration options specify pre-build and post-build actions in the IDE. These options apply to the whole build configuration, and cannot be set on groups or files.

If a pre- or post-build action returns a non-zero error code, the entire Build or Make command is aborted.

Pre-build command line

Specify the command line to be executed directly before a build. Use the browse button to locate the tool you want to be executed. The commands will not be executed if the configuration is already up-to-date.
Description of build actions options

**Post-build command line**

Specify the command line to be executed directly after each successful build. Use the browse button to locate the tool you want to be executed. The commands will not be executed if the configuration was up-to-date. This is useful for copying or post-processing the output file.
Linker options

- Description of linker options

Description of linker options

Reference information about:
- Config
- Output
- Extra Output
- List
- Log
- #define
- Diagnostics
- Checksum
- Extra Options

To set linker options in the IDE:

1. Choose Project>Options to display the Options dialog box.
2. Select Linker in the Category list.
Description of linker options

**Config**

The **Config** options specify the path and name of the linker configuration file, override the default program entry, and specify the library search path.

**Linker configuration file**

A default linker configuration file is selected automatically based on your project settings. To override the default file, select **Override default** and specify an alternative file.

The argument variables `$TOOLKIT_DIR$` or `$PROJ_DIR$` can be used for specifying a project-specific or predefined linker configuration file.

**Override default program entry**

By default, the program entry is the symbol `__program_start`. The linker makes sure that a module containing the program entry symbol is included, and that the segment part containing the symbol is not discarded.

**Override default program entry** overrides the default program handling; choose between:

- **Entry symbol**
  Specify an entry symbol other than default.

- **Defined by application**
  Uses an entry symbol defined in the linked object code. The linker will, as always, include all program modules, and enough library modules to satisfy all symbol references, keeping all segment parts that are marked with the `root` attribute or that are referenced, directly or indirectly, from such a segment part.
Search paths

Specify the names of the directories that XLINK will search if it fails to find the object files to link in the current working directory. Add the full paths of any additional directories where you want XLINK to search for your object files.

The paths required by the product are specified automatically based on your choice of runtime library.

Use the browse button to open the Edit Include Directories dialog box, where you can specify directories using a file browser. For more information, see Edit Include Directories dialog box, page 209.

The argument variables $PROJ_DIR$ and $TOOLKIT_DIR$ can be used, see Argument variables, page 72.

Raw binary image

Links pure binary files in addition to the ordinary input files. Specify these parameters:

File

The pure binary file you want to link.

Symbol

The symbol defined by the segment part where the binary data is placed.

Segment

The segment where the binary data is placed.

Align

The alignment of the segment part where the binary data is placed.

The entire contents of the file are placed in the segment you specify, which means it can only contain pure binary data, for example, the raw binary output format. The segment part where the contents of the specified file are placed, is only included if the specified symbol is required by your application. Use the -g linker option if you want to force a reference to the symbol. Read more about single output files and the -g option in the IAR Linker and Library Tools Reference Guide.
The **Output** options determine the generated linker output.

### Output file

Sets the name of the XLINK output file. By default, the linker will use the project name with a filename extension. The filename extension depends on which output format you choose. If you choose **Debug information for C-SPY**, the output file will have the filename extension `.d51`.

**Note:** If you select a format that generates two output files, the file type that you specify will only affect the primary output file (first format).

To override the default name, select **Override default** and specify an alternative name of the output file.

### Format

Determines the format of the output file generated by the IAR XLINK Linker. The output file is either used as input to a debugger or for programming the target system.

Choose between:

- **Debug information for C-SPY**
  
  Creates a UBROF output file, with the `.d51` filename extension, to be used with C-SPY.

- **With runtime control modules**
  
  Produces the same output as the **Debug information for C-SPY** option, but also includes debugger support for handling program abort, exit, and assertions. Special C-SPY variants for the corresponding library functions are linked with your application.
With I/O emulation modules

Produces the same output as the Debug information for C-SPY and With runtime control modules options, but also includes debugger support for I/O handling, which means that stdin and stdout are redirected to the Terminal I/O window, and that you can access files on the host computer during a debug session.

Buffered terminal output

Buffers the terminal output during program execution, instead of instantly printing each new character to the C-SPY Terminal I/O window.

This option is useful when using debugger systems that have slow communication.

Allow C-SPY-specific extra output file

Enables the options available on the Extra Output page, see Extra Output, page 228.

Other

Generates output in a different format than those generated by the options Debug information for C-SPY, With runtime control modules, and With I/O emulation modules. Choose between:

Output format selects the output format. When you select debug (ubrof) or ubrof, a UBROF output file with the filename extension dbg is created. The generated output file will not contain debug information for simulating facilities such as stop at program exit, long jump instructions, and terminal I/O. If you need support for these facilities during a debug session, use the Debug information for C-SPY, With runtime control modules, and With I/O emulation modules options, respectively.

Format variant selects the format variant which is available for some of the output formats. The alternatives depend on the output format chosen.

Module-local symbols

Specifies whether local (non-public) symbols in the input modules should be included or not. If suppressed, the local symbols will not appear in the listing cross-reference and they will not be passed on to the output file. Choose between:

Include all includes all local symbols.

Suppress compiler generated ignores compiler-generated local symbols, such as jump or constant labels. Usually these are only of interest when debugging at assembler level.

Suppress all ignores all local symbols.
Description of linker options

Note that local symbols are only included in files if they were compiled or assembled with the appropriate option to specify this.

The default output settings are:

- In a debug project, Debug information for C-SPY, With runtime control modules, and With I/O emulation modules are selected by default.
- In a release project, Intel-extended is selected by default, which is an output format without debug information suitable for target download.

**Note:** For debuggers other than C-SPY®, check the user documentation supplied with that debugger for information about which format/variant that should be used.

For more information about the debugger runtime interface, see the *IAR C/C++ Compiler Reference Guide for 8051.*

**Extra Output**

The Extra Output options control the generation of an extra output file and specify its format.

For some debugger systems, two output files from the same build process are required—one with the necessary debug information, and one that you can burn to your hardware before debugging. This is useful when you want to debug code that is located in non-volatile memory.

If the options are disabled, make sure to select the option Allow C-SPY-specific extra output file on the Output page. The options are disabled if you have selected any of the options With runtime control modules or With I/O emulation modules on the Output page, because then the generated output file will contain dummy implementations for certain library functions, such as `putchar`, and extra debug information required by C-SPY to handle those functions. An extra output file would
still contain the dummy functions, but not the extra debug information, and would therefore normally be useless.

**Generate extra output file**

Makes the linker generate an additional output file from the build process.

**Output file**

Sets the name of the additional output file. By default, the linker will use the project name and a filename extension that depends on the output format you select. To override the default name, select **Override default** and specify an alternative file.

**Note:** If you select a format that generates two output files, the file type that you specify will only affect the primary output file (the first format).

**Format**

Determines the format of the extra output file:

**Output format**

Selects an output format. When you select **debug (ubrof)** or **ubrof**, a UBROF output file with the filename extension `dbg` is created.

**Format variant**

Selects a format variant. The alternatives depend on the output format chosen.

**List**

The **List** options control the generation of XLINK cross-reference listings.
Description of linker options

**Generate linker listing**
Makes the linker generate a listing and send it to the `projectname.map` file located in the list directory.

**Segment map**
Includes a segment map in the listing. The segment map will contain a list of all the segments in dump order.

**Symbols**
Selects which types of symbols to include in the listing:
- **None**
  Symbols are excluded.
- **Symbol listing**
  An abbreviated list of every entry (global symbol) in every module. This entry map is useful for quickly finding the address of a routine or data element.
- **Module map**
  A list of all segments, local symbols, and entries (public symbols) for every module in the application.

**Module summary**
Makes the linker generate a summary of the contributions to the total memory use from each module. Only modules with a contribution to memory use are listed.

**Include suppressed entries**
Includes all segment parts in a linked module in the list file, not just the segment parts that were included in the output. This makes it possible to determine exactly which entries that were not needed.

**Static overlay map**
Includes a listing of the static overlay system in the list file. This is only relevant if the compiler uses static overlay. Read more about static overlay maps in the IAR Linker and Library Tools Reference Guide.

**File format**
Selects the file format of the linker listing:
- **Text**
  Plain text file.
**HTML**

HTML format, with hyperlinks.

**Lines/page**

Sets the number of lines per page for the listing. This number must be in the range 10 to 150.

**Log**

The Log options control the stack usage analysis performed by XLINK.

For more information about logging using XLINK, see the *IAR Linker and Library Tools Reference Guide*.

**Generate log file**

Makes the linker log information to a log file, which you can find in $PROJ_DIR$/Debug/List. The log information can be useful for understanding why an executable image became the way it is.

**Input files**

Lists all object files that are used by the linking process and the order in which they will be processed.

**Module selections**

Lists each module that is selected for inclusion in the application, and which symbol that caused it to be included.
**Selection of printf/scanf**  
Lists redirected symbols, and why a certain automatic redirection was made.

**Segment selections**  
Lists each segment part that is selected for inclusion in your application, and the dependence that caused it to be included.

**#define**  
The `#define` options define absolute symbols at link time.

**Defined symbols**  
Define absolute symbols to be used at link time. This is especially useful for configuration purposes. Type the symbols that you want to define for the project, one per line, and specify their value. For example:

```
TESTVER=1
```

Note that there should be no space around the equal sign.

Any number of symbols can be defined in a linker configuration file. The symbol(s) defined in this manner will be located in a special module called `?ABS_ENTRY_MOD`, which is generated by the linker.

The linker will display an error message if you attempt to redefine an existing symbol.
Diagnostics

The **Diagnostics** options determine the error and warning messages generated by the IAR XLINK Linker.

### Always generate output

Makes the linker generate an output file even if a non-fatal error was encountered during the linking process, such as a missing global entry or a duplicate declaration. Normally, XLINK will not generate an output file if an error is encountered.

**Note:** XLINK always aborts on fatal errors, even when this option is used.

**Always generate output** allows missing entries to be patched in later in the absolute output image.

### Segment overlap warnings

Classifies segment overlap errors as warnings, making it possible to produce cross-reference maps, etc.

### No global type checking

Disables type checking at link time. While a well-written application should not need this option, there might be occasions where it is helpful.

By default, XLINK performs link-time type checking between modules by comparing the external references to an entry with the `PUBLIC` entry (if the information exists in the object modules involved). A warning is generated if there are mismatches.

### Range checks

Selects the behavior for address range check errors. If an address is relocated outside the address range of the target CPU—code, external data, or internal data address—an error
message is generated. This usually indicates an error in an assembler language module or in the segment placement. Choose between:

**Generate errors**
Generates an error message.

**Generate warnings**
Generates a warning.

**Disabled**
Disables the address range checking.

### Warnings/Errors

By default, the IAR XLINK Linker generates a warning when it detects a possible problem, although the generated code might still be correct. **Warnings/Errors** determines how diagnostic messages are classified.

Refer to the *IAR Linker and Library Tools Reference Guide* for information about the various warning and error messages.

Use these settings to control the generation of warning and error messages:

**Suppress all warnings**
Suppresses all warnings.

**Suppress these diagnostics**
Suppresses the output of diagnostic messages for the tags that you specify. For example, to suppress the warnings w117 and w177, type `w117,w177`.

**Treat these as warnings**
Classifies errors as warnings. For example, to make error 106 become treated as a warning, type `e106`.

**Treat these as errors**
Classifies warnings as errors. For example, to make warning 26 become treated as an error, type `w26`.
Checksum

The **Checksum** options control filling and checksumming.

![Checksum options](image)

**Fill unused code memory**

Fills all gaps between segment parts introduced by the linker with the fill pattern you specify:

**Fill pattern**

Specify a size, in hexadecimal notation, of the filler to be used in gaps between segment parts.

The linker can introduce gaps either because of alignment restrictions, or at the end of ranges given in segment placement options. The default behavior, when this option is not used, is that these gaps are not given a value in the output file.

**Generate checksum**

Checksums all generated raw data bytes. This option can only be used if the **Fill unused code memory** option has been specified.

Choose between:

**Checksum size**

Selects the size of the checksum, which can be 1, 2, or 4 bytes.

**Alignment**

Specify an optional alignment for the checksum. If you do not specify an alignment explicitly, an alignment of 2 is used.

**Algorithm**

Selects the algorithm to be used when calculating the checksum. Choose between:
Description of linker options

**Arithmetic sum**, the simple arithmetic sum algorithm. The result is truncated to one byte.

**CRC16** (default), the CRC16 algorithm (generating polynomial 0x11021).

**CRC32**, the CRC32 algorithm (generating polynomial 0x4C11DB7).

**CRC polynomial**, the CRC polynomial algorithm, a generating polynomial of the value you specify.

**Complement**

Selects the complement variant, either the one’s complement or two’s complement.

**Bit order**

Selects the bit order of the result to be output. Choose between:

- **MSB first**, which outputs the most significant bit first for each byte.
- **LSB first**, which reverses the bit order for each byte and outputs the least significant bit first.

**Initial value**

Specify an initial value for the checksum. This is useful if the microcontroller you are using has its own checksum calculation and you want that calculation to correspond to the calculation performed by the linker.

**Checksum unit size**

Selects the size of the unit for which a checksum should be calculated. Typically, this is useful to make the linker produce the same checksum as some hardware CRC implementations that calculate a checksum for more than 8 bits per iteration. Choose between:

- **8-bit**, calculates a checksum for 8 bits in every iteration.
- **16-bit**, calculates a checksum for 16 bits in every iteration.
- **32-bit**, calculates a checksum for 32 bits in every iteration.
Extra Options

The Extra Options page provides you with a command line interface to the tool.

Use command line options

Specify additional command line arguments to be passed to the tool (not supported by the GUI).
Description of linker options
Library builder options

- Output

Description of library builder options
Reference information about:
- Output

Options for the library builder are not available by default. Before you can set these options in the IDE, you must add the library builder tool to the list of categories.

To set Library Builder options in the IDE:
1. Choose Project > Options > General Options > Output.
2. Select the Library option, which means that Library Builder appears as a category in the Options dialog box.
3. Select Library Builder in the Category list.
Output

The **Output** options control the library builder and as a result of the build process, the library builder will create a library output file.

### Output file

Specifies the name of the output file from the library builder. By default, the linker will use the project name with a filename extension. To override the default name, select **Override default** and specify an alternative name of the output file.
Glossary

This is a general glossary for terms relevant to embedded systems programming. Some of the terms do not apply to the IAR Embedded Workbench® version that you are using.

A

Absolute location.
A specific memory address for an object specified in the source code, as opposed to the object being assigned a location by the linker.

Absolute segments
Segments that have fixed locations in memory before linking.

Address expression
An expression which has an address as its value.

Application
The program developed by the user of the IAR Systems toolkit and which will be run as an embedded application on a target processor.

Architecture
A term used by computer designers to designate the structure of complex information-processing systems. It includes the kinds of instructions and data used, the memory organization and addressing, and the methods by which the system is implemented. The two main architecture types used in processor design are Harvard architecture and von Neumann architecture.

Assembler directives
The set of commands that control how the assembler operates.

Assembler language
A machine-specific set of mnemonics used to specify operations to the target processor and input or output registers or data areas. Assembler language might sometimes be preferred over C/C++ to save memory or to enhance the execution speed of the application.

Assembler options
Parameters you can specify to change the default behavior of the assembler.

Auto variables
The term refers to the fact that each time the function in which the variable is declared is called, a new instance of the variable is created automatically. This can be compared with the behavior of local variables in systems using static overlay, where a local variable only exists in one instance, even if the function is called recursively. Also called local variables. Compare Register variables.

B

Backtrace
Information for keeping call frame information up to date so that the IAR C-SPY® Debugger can return from a function correctly. See also Call frame information.

Bank
See Memory bank.

Bank switching
Switching between different sets of memory banks. This software technique increases a computer’s usable memory by allowing different pieces of memory to occupy the same address space.

Banked code
Code that is distributed over several banks of memory. Each function must reside in only one bank.

Banked data
Data that is distributed over several banks of memory. Each data object must fit inside one memory bank.

Banked memory
Has multiple storage locations for the same address. See also Memory bank.
Bank-switching routines
Code that selects a memory bank.

Batch files
A text file containing operating system commands which are executed by the command line interpreter. In Unix, this is called a “shell script” because it is the Unix shell which includes the command line interpreter. Batch files can be used as a simple way to combine existing commands into new commands.

Bitfield
A group of bits considered as a unit.

Breakpoint
1 Code breakpoint. A point in a program that, when reached, triggers some special behavior useful to the process of debugging. Generally, breakpoints are used for stopping program execution or dumping the values of some or all of the program variables. Breakpoints can be part of the program itself, or they can be set by the programmer as part of an interactive session with a debugging tool for scrutinizing the program's execution.

2 Data breakpoint. A point in memory that, when accessed, triggers some special behavior useful to the process of debugging. Generally, data breakpoints are used to stop program execution when an address location is accessed either by a read operation or a write operation.

3 Immediate breakpoint. A point in memory that, when accessed, triggers some special behavior useful in the process of debugging. Immediate breakpoints are generally used for halting the program execution in the middle of a memory access instruction (before or after the actual memory access depending on the access type) while performing some user-specified action. The execution is then resumed. This feature is only available in the simulator version of C-SPY.

C

Call frame information
Information that allows the IAR C-SPY® Debugger to show, without any runtime penalty, the complete stack of function calls—call stack—wherever the program counter is, provided that the code comes from compiled C functions. See also Backtrace.

Calling convention
A calling convention describes the way one function in a program calls another function. This includes how register parameters are handled, how the return value is returned, and which registers that will be preserved by the called function. The compiler handles this automatically for all C and C++ functions. All code written in assembler language must conform to the rules in the calling convention to be callable from C or C++, or to be able to call C and C++ functions. The C calling convention and the C++ calling conventions are not necessarily the same.

Cheap
As in cheap memory access. A cheap memory access either requires few cycles to perform, or few bytes of code to implement. A cheap memory access is said to have a low cost. See Memory access cost.

Checksum
A computed value which depends on the ROM content of the whole or parts of the application, and which is stored along with the application to detect corruption of the data. The checksum is produced by the linker to be verified with the application. Several algorithms are supported. Compare CRC (cyclic redundancy checking).

Code banking
See Banked code.

Code model
The code model controls how code is generated for an application. Typically, the code model controls behavior such as how functions are called and in which code segment functions will be located. All object files of an application must be compiled using the same code model.
**Code pointers**
A code pointer is a function pointer. As many microcontrollers allow several different methods of calling a function, compilers for embedded systems usually provide the users with the ability to use all these methods.

Do not confuse code pointers with data pointers.

**Code segments**
Read-only segments that contain code. See also *Segment*.

**Compilation unit**
See *Translation unit*.

**Compiler function directives**
The compiler function directives are generated by the compiler to pass information about functions and function calls to the IAR XLINK Linker. To view these directives, you must create an assembler list file. These directives are primarily intended for compilers that support static overlay, a feature which is useful in smaller microcontrollers.

**Compiler options**
Parameters you can specify to change the default behavior of the compiler.

**Context menu**
A context menu appears when you right-click in the user interface, and provides context-specific menu commands.

**Cost**
See *Memory access cost*.

**CRC (cyclic redundancy checking)**
A number derived from, and stored with, a block of data to detect corruption. A CRC is based on polynomials and is a more advanced way of detecting errors than a simple arithmetic checksum. Compare *Checksum*.

**C-SPY options**
Parameters you can specify to change the default behavior of the IAR C-SPY Debugger.

**Cstartup**
Code that sets up the system before the application starts executing.

**C-style preprocessor**
A preprocessor is either a stand-alone application or an integrated part of a compiler, that performs preprocessing of the input stream before the actual compilation occurs. A C-style preprocessor follows the rules set up in Standard C and implements commands like `#define`, `#if`, and `#include`, which are used to handle textual macro substitution, conditional compilation, and inclusion of other files.

**D**

**Data banking**
See *Banked data*.

**Data model**
The data model specifies the default memory type. This means that the data model typically controls one or more of the following: The method used and the code generated to access static and global variables, dynamically allocated data, and the runtime stack. It also controls the default pointer type and in which data segments static and global variables will be located. A project can only use one data model at a time, and the same model must be used by all user modules and all library modules in the project.

**Data pointers**
Many microcontrollers have different addressing modes to access different memory types or address spaces. Compilers for embedded systems usually have a set of different data pointer types so they can access the available memory efficiently.

**Data representation**
How different data types are laid out in memory and what value ranges they represent.

**Declaration**
A specification to the compiler that an object, a variable or function, exists. The object itself must be defined in exactly one translation unit (source file). An object must either be declared or defined before it is used. Normally an object that is used in many files is defined in one source file. A declaration
is normally placed in a header file that is included by the files that use the object.

For example:

```c
/* Variable "a" exists somewhere. Function "b" takes two int parameters and returns an int. */
extern int a;
int b(int, int);
```

**Definition**
The variable or function itself. Only one definition can exist for each variable or function in an application. See also Tentative definition.

For example:

```c
int a;
int b(int x, int y)
{
    return x + y;
}
```

**Device description file**
A file used by C-SPY that contains various device-specific information such as I/O register (SFR) definitions, interrupt vectors, and control register definitions.

**Device driver**
Software that provides a high-level programming interface to a particular peripheral device.

**Digital signal processor (DSP)**
A device that is similar to a microprocessor, except that the internal CPU is optimized for use in applications involving discrete-time signal processing. In addition to standard microprocessor instructions, digital signal processors usually support a set of complex instructions to perform common signal-processing computations quickly.

**Disassembly window**
A C-SPY window that shows the memory contents disassembled as machine instructions, interspersed with the corresponding C source code (if available).

**DWARF**
An industry-standard debugging format which supports source level debugging. This is the format used by the IAR ILINK Linker for representing debug information in an object.

**Dynamic initialization**
Variables in a program written in C are initialized during the initial phase of execution, before the main function is called. These variables are always initialized with a static value, which is determined either at compile time or at link time. This is called static initialization. In C++, variables might require initialization to be performed by executing code, for example, running the constructor of global objects, or performing dynamic memory allocation.

**Dynamic memory allocation**
There are two main strategies for storing variables: statically at link time, or dynamically at runtime. Dynamic memory allocation is often performed from the heap and it is the size of the heap that determines how much memory that can be used for dynamic objects and variables. The advantage of dynamic memory allocation is that several variables or objects that are not active at the same time can be stored in the same memory, thus reducing the memory requirements of an application. See also Heap memory.

**Dynamic object**
An object that is allocated, created, destroyed, and released at runtime. Dynamic objects are almost always stored in memory that is dynamically allocated. Compare Static object.

**EEPROM**
Electrically Erasable, Programmable Read-Only Memory. A type of ROM that can be erased electronically, and then be re-programmed.

**ELF**
Executable and Linking Format, an industry-standard object file format. This is the format used by the IAR ILINK Linker. The debug information is formatted using DWARF.
**Embedded C++**
A subset of the C++ programming language, which is intended for embedded systems programming. The fact that performance and portability are particularly important in embedded systems development was considered when defining the language.

**Embedded system**
A combination of hardware and software, designed for a specific purpose. Embedded systems are often part of a larger system or product.

**Emulator**
An emulator is a hardware device that performs emulation of one or more derivatives of a processor family. An emulator can often be used instead of the actual microcontroller and connects directly to the printed circuit board—where the microcontroller would have been connected—via a connecting device. An emulator always behaves exactly as the processor it emulates, and is used when debugging requires all systems actuators, or when debugging device drivers.

**Enumeration**
A type which includes in its definition an exhaustive list of possible values for variables of that type. Common examples include Boolean, which takes values from the list [true, false], and day-of-week which takes values [Sunday, Monday, Tuesday, Wednesday, Thursday, Friday, Saturday]. Enumerated types are a feature of typed languages, including C and Ada.

Characters, (fixed-size) integers, and even floating-point types might be (but are not usually) considered to be (large) enumerated types.

**EPROM**
Erasable, Programmable Read-Only Memory. A type of ROM that can be erased by exposing it to ultraviolet light, and then re-programmed.

**Executable image**
Contains the executable image; the result of linking several relocatable object files and libraries. The file format used for an object file is UBROF.

**Exceptions**
An exception is an interrupt initiated by the processor hardware, or hardware that is tightly coupled with the processor, for instance, a memory management unit (MMU). The exception signals a violation of the rules of the architecture (access to protected memory), or an extreme error condition (division by zero).

Do not confuse this use of the word exception with the term exception used in the C++ language (but not in Embedded C++).

**Expensive**
As in expensive memory access. An expensive memory access either requires many cycles to perform, or many bytes of code to implement. An expensive memory access is said to have a high cost. See Memory access cost.

**Extended keywords**
Non-standard keywords in C and C++. These usually control the definition and declaration of objects (that is, data and functions). See also Keywords.

**F**

**Filling**
How to fill up bytes—with a specific fill pattern—that exists between the segments in an executable image. These bytes exist because of the alignment demands on the segments.

**Format specifiers**
Used to specify the format of strings sent by library functions such as printf. In the following example, the function call contains one format string with one format specifier, %c, that prints the value of a as a single ASCII character:

```c
printf("a = %c", a);
```

**G**

**General options**
Parameters you can specify to change the default behavior of all tools that are included in the IDE.
Generic pointers
Pointers that have the ability to point to all different memory types in, for example, a microcontroller based on the Harvard architecture.

Harvard architecture
A microcontroller based on the Harvard architecture has separate data and instruction buses. This allows execution to occur in parallel. As an instruction is being fetched, the current instruction is executing on the data bus. Once the current instruction is complete, the next instruction is ready to go. This theoretically allows for much faster execution than a von Neumann architecture, but adds some silicon complexity. Compare von Neumann architecture.

Heap memory
The heap is a pool of memory in a system that is reserved for dynamic memory allocation. An application can request parts of the heap for its own use; once memory is allocated from the heap it remains valid until it is explicitly released back to the heap by the application. This type of memory is useful when the number of objects is not known until the application executes. Note that this type of memory is risky to use in systems with a limited amount of memory or systems that are expected to run for a very long time.

Heap size
Total size of memory that can be dynamically allocated.

Host
The computer that communicates with the target processor. The term is used to distinguish the computer on which the debugger is running from the microcontroller the embedded application you develop runs on.

IDE (integrated development environment)
A programming environment with all necessary tools integrated into one single application.

ILINK
The IAR ILINK Linker which produces absolute output in the ELF/DWARF format.

Image
See Executable image.

Include file
A text file which is included into a source file. This is often done by the preprocessor.

Initialized segments
Read-write segments that should be initialized with specific values at startup. See also Segment.

Inline assembler
Assembler language code that is inserted directly between C statements.

Inlining
An optimization that replaces function calls with the body of the called function. This optimization increases the execution speed and can even reduce the size of the generated code.

Instruction mnemonics
A word or acronym used in assembler language to represent a machine instruction. Different processors have different instruction sets and therefore use a different set of mnemonics to represent them, such as, ADD, BR (branch), BLT (branch if less than), MOVE, LDR (load register).

Interrupt vector
A small piece of code that will be executed, or a pointer that points to code that will be executed when an interrupt occurs.

Interrupt vector table
A table containing interrupt vectors, indexed by interrupt type. This table contains the processor's mapping between interrupts and interrupt service routines and must be initialized by the programmer.

Interrupts
In embedded systems, the use of interrupts is a method of detecting external events immediately, for example a timer overflow or the pressing of a button.
Interrupts are asynchronous events that suspend normal processing and temporarily divert the flow of control through an “interrupt handler” routine. Interrupts can be caused by both hardware (I/O, timer, machine check) and software (supervisor, system call or trap instruction). Compare Trap.

Intrinsic
An adjective describing native compiler objects, properties, events, and methods.

Intrinsic functions
1. Function calls that are directly expanded into specific sequences of machine code. 2. Functions called by the compiler for internal purposes (that is, floating-point arithmetic etc.).

Key bindings
Key shortcuts for menu commands used in the IDE.

Keywords
A fixed set of symbols built into the syntax of a programming language. All keywords used in a language are reserved—they cannot be used as identifiers (in other words, user-defined objects such as variables or procedures). See also Extended keywords.

L

L-value
A value that can be found on the left side of an assignment and thus be changed. This includes plain variables and de-referenced pointers. Expressions like \((x + 10)\) cannot be assigned a new value and are therefore not L-values.

Language extensions
Target-specific extensions to the C language.

Library
See Runtime library.

Library configuration file
A file that contains a configuration of the runtime library. The file contains information about what functionality is part of the runtime environment. The file is used for tailoring a build of a runtime library. See also Runtime library.

Linker configuration file
A file used by the IAR XLINK Linker. It contains command line options which specify the locations where the memory segments can be placed, thereby assuring that your application fits on the target chip.

Because many of the chip-specific details are specified in the linker configuration file and not in the source code, the linker configuration file also helps to make the code portable.

In particular, the linker specifies the placement of segments, the stack size, and the heap size.

Local variable
See Auto variables.

Location counter
See Program location counter (PLC).

Logical address
See Virtual address (logical address).

MAC (Multiply and accumulate)
A special instruction, or on-chip device, that performs a multiplication together with an addition. This is very useful when performing signal processing where many filters and transforms have the form:

\[
y_j = \sum_{i=0}^{N} c_i \cdot x_i + j
\]

The accumulator of the MAC usually has a higher precision (more bits) than normal registers. See also Digital signal processor (DSP).
**Macro**
1. Assembler macros are user-defined sets of assembler lines that can be expanded later in the source file by referring to the given macro name. Parameters will be substituted if referred to.

2. C macro. A text substitution mechanism used during preprocessing of source files. Macros are defined using the `#define` preprocessing directive. The replacement text of each macro is then substituted for any occurrences of the macro name in the rest of the translation unit.

3. C-SPY macros are programs that you can write to enhance the functionality of C-SPY. A typical application of C-SPY macros is to associate them with breakpoints; when such a breakpoint is hit, the macro is run and can for example be used to simulate peripheral devices, to evaluate complex conditions, or to output a trace.

The C-SPY macro language is like a simple dialect of C, but is less strict with types.

**Mailbox**
A mailbox in an RTOS is a point of communication between two or more tasks. One task can send messages to another task by placing the message in the mailbox of the other task. Mailboxes are also known as message queues or message ports.

**Memory access cost**
The cost of a memory access can be in clock cycles, or in the number of bytes of code needed to perform the access. A memory which requires large instructions or many instructions is said to have a higher access cost than a memory which can be accessed with few, or small instructions.

**Memory area**
A region of the memory.

**Memory bank**
The smallest unit of continuous memory in banked memory. One memory bank at a time is visible in a microcontroller’s physical address space.

**Memory map**
A map of the different memory areas available to the microcontroller.

**Memory model**
Specifies the memory hierarchy and how much memory the system can handle. Your application must use only one memory model at a time, and the same model must be used by all user modules and all library modules.

**Microcontroller**
A microprocessor on a single integrated circuit intended to operate as an embedded system. In addition to a CPU, a microcontroller typically includes small amounts of RAM, PROM, timers, and I/O ports.

**Microprocessor**
A CPU contained on one (or a few) integrated circuits. A single-chip microprocessor can include other components such as memory, memory management, caches, floating-point unit, I/O ports and timers. Such devices are also known as microcontrollers.

**Module**
An object. An object file contains a module and library contains one or more objects. The basic unit of linking. A module contains definitions for symbols (exports) and references to external symbols (imports). When you compile C/C++, each translation unit produces one module.

**Multi-file compilation**
A technique which means that the compiler compiles several source files as one compilation unit, which enables for interprocedural optimizations such as inlining, cross call, and cross jump on multiple source files in a compilation unit.

**Nested interrupts**
A system where an interrupt can be interrupted by another interrupt is said to have nested interrupts.
Non-banked memory
Has a single storage location for each memory address in a microcontroller’s physical address space.

Non-initialized memory
Memory that can contain any value at reset, or in the case of a soft reset, can remember the value it had before the reset.

No-init segments
Read-write segments that should not be initialized at startup. See also Segment.

Non-volatile storage
Memory devices such as battery-backed RAM, ROM, magnetic tape and magnetic disks that can retain data when electric power is shut off. Compare Volatile storage.

NOP
No operation. This is an instruction that does not do anything, but is used to create a delay. In pipelined architectures, the NOP instruction can be used for synchronizing the pipeline. See also Pipeline.

Object
An object file or a library member.

Object file, absolute
See Executable image.

Object file, relocatable
The result of compiling or assembling a source file. The file format used for an object file is UBROF.

Operator
A symbol used as a function, with infix syntax if it has two arguments (+, for example) or prefix syntax if it has only one (for instance, bitwise negation, ~). Many languages use operators for built-in functions such as arithmetic and logic.

Operator precedence
Each operator has a precedence number assigned to it that determines the order in which the operator and its operands are evaluated. The highest precedence operators are evaluated first. Use parentheses to group operators and operands to control the order in which the expressions are evaluated.

Options
A set of commands that control the behavior of a tool, for example the compiler or linker. The options can be specified on the command line or via the IDE.

Output image
See Executable image.

P

Parameter passing
See Calling convention.

Peripheral unit
A hardware component other than the processor, for example memory or an I/O device.

Pipeline
A structure that consists of a sequence of stages through which a computation flows. New operations can be initiated at the start of the pipeline even though other operations are already in progress through the pipeline.

Pointer
An object that contains an address to another object of a specified type.

#pragma
During compilation of a C/C++ program, the #pragma preprocessing directive causes the compiler to behave in an implementation-defined manner. This can include, for example, producing output on the console, changing the declaration of a subsequent object, changing the optimization level, or enabling/disabling language extensions.

Pre-emptive multitasking
An RTOS task is allowed to run until a higher priority process is activated. The higher priority task might become active as the result of an interrupt. The term preemptive indicates that although a task is allotted to run a given length of time (a timeslice), it might lose the processor at any time. Each time
an interrupt occurs, the task scheduler looks for the highest priority task that is active and switches to that task. If the located task is different from the task that was executing before the interrupt, the previous task is suspended at the point of interruption.

Compare *Round Robin*.

**Preprocessing directives**
A set of directives that are executed before the parsing of the actual code is started.

**Preprocessor**
See *C-style preprocessor*.

**Processor variant**
The different chip setups that the compiler supports.

**Program counter (PC)**
A special processor register that is used to address instructions. Compare *Program location counter (PLC)*.

**Program location counter (PLC)**
Used in the IAR Assembler to denote the code address of the current instruction. The PLC is represented by a special symbol (typically $\%$) that can be used in arithmetic expressions. Also called simply location counter (LC).

**Project**
The user application development project.

**Project options**
General options that apply to an entire project, for example the target processor that the application will run on.

**PROM**
Programmable Read-Only Memory. A type of ROM that can be programmed only once.

**Qualifiers**
See *Type qualifiers*.

**Range, in linker configuration file**
A range of consecutive addresses in a memory. A region is built up of ranges.

**Read-only segments**
Segments that contain code or constants. See also *Segment*.

**Real-time operating system (RTOS)**
An operating system which guarantees the latency between an interrupt being triggered and the interrupt handler starting, and how tasks are scheduled. An RTOS is typically much smaller than a normal desktop operating system. Compare *Real-time system*.

**Real-time system**
A computer system whose processes are time-sensitive. Compare *Real-time operating system (RTOS)*.

**Region, in linker configuration file**
A set of non-overlapping ranges. The ranges can lie in one or more memories. For XLINK, the segments are placed in regions.

**Register**
A small on-chip memory unit, usually just one or a few bytes in size, which is particularly efficient to access and therefore often reserved as a temporary storage area during program execution.

**Register constant**
A register constant is a value that is loaded into a dedicated processor register when the system is initialized. The compiler can then generate code that assumes that the constants are present in the dedicated registers.

**Register locking**
Register locking means that the compiler can be instructed that some processor registers shall not be used during normal code generation. This is useful in many situations. For example, some parts of a system might be written in assembler language to gain speed. These parts might be given dedicated processor
registers. Or the register might be used by an operating system, or by other third-party software.

**Register variables**
Typically, register variables are local variables that are placed in registers instead of on the (stack) frame of the function. Register variables are much more efficient than other variables because they do not require memory accesses, so the compiler can use shorter/faster instructions when working with them. See also *Auto variables*.

**Relocatable segments**
Segments that have no fixed location in memory before linking.

**Reset**
A reset is a restart from the initial state of a system. A reset can originate from hardware (hard reset), or from software (soft reset). A hard reset can usually not be distinguished from the power-on condition, which a soft reset can be.

**ROM-monitor**
A piece of embedded software designed specifically for use as a debugging tool. It resides in the ROM of the evaluation board chip and communicates with a debugger via a serial port or network connection. The ROM-monitor provides a set of primitive commands to view and modify memory locations and registers, create and remove breakpoints, and execute your application. The debugger combines these primitives to fulfill higher-level requests like program download and single-step.

**Round Robin**
Task scheduling in an operating system, where all tasks have the same priority level and are executed in turn, one after the other. Compare *Pre-emptive multitasking*.

**RTOS**
See *Real-time operating system (RTOS)*.

**Runtime library**
A collection of relocatable object files that will be included in the executable image only if referred to from an object file, in other words conditionally linked.

**Runtime model attributes**
A mechanism that is designed to prevent modules that are not compatible to be linked into an application. A runtime attribute is a pair constituted of a named key and its corresponding value.

For XLINK, two modules can only be linked together if they have the same value for each key that they both define.

**R-value**
A value that can be found on the right side of an assignment. This is just a plain value. See also *L-value*.

**Saturation arithmetics**
Most, if not all, C and C++ implementations use mod–2^N 2-complement-based arithmetics where an overflow wraps the value in the value domain, that is, (127 + 1) = -128. Saturation arithmetics, on the other hand, does not allow wrapping in the value domain, for instance, (127 + 1) = 127, if 127 is the upper limit. Saturation arithmetics is often used in signal processing, where an overflow condition would have been fatal if value wrapping had been allowed.

**Scheduler**
The part of an RTOS that performs task-switching. It is also responsible for selecting which task that should be allowed to run. Many scheduling algorithms exist, but most of them are either based on static scheduling (performed at compile-time), or on dynamic scheduling (where the actual choice of which task to run next is taken at runtime, depending on the state of the system at the time of the task-switch). Most real-time systems use static scheduling, because it makes it possible to prove that the system will not violate the real-time requirements.

**Scope**
The section of an application where a function or a variable can be referenced by name. The scope of an item can be limited to file, function, or block.
Segment
A chunk of data or code that should be mapped to a physical location in memory. The segment can either be placed in RAM or in ROM.

Segment map
A set of segments and their locations. This map is part of the linker list file.

Segment part
A part of a segment, typically a variable or a function.

Semaphore
A semaphore is a type of flag that is used for guaranteeing exclusive access to resources. The resource can be a hardware port, a configuration memory, or a set of variables. If several tasks must access the same resource, the parts of the code (the critical sections) that access the resource must be made exclusive for every task. This is done by obtaining the semaphore that protects that resource, thus blocking all other tasks from it. If another task wishes to use the resource, it also must obtain the semaphore. If the semaphore is already in use, the second task must wait until the semaphore is released. After the semaphore is released, the second task is allowed to execute and can obtain the semaphore for its own exclusive access.

Severity level
The level of seriousness of the diagnostic response from the assembler, compiler, or debugger, when it notices that something is wrong. Typical severity levels are remarks, warnings, errors, and fatal errors. A remark just points to a possible problem, while a fatal error means that the programming tool exits without finishing.

Sharing
A physical memory that can be addressed in several ways. For XLINK, the command line option \(-U\) is used to define it.

Short addressing
Many microcontrollers have special addressing modes for efficient access to internal RAM and memory mapped I/O. Short addressing is therefore provided as an extended feature by many compilers for embedded systems. See also Data pointers.

Side effect
An expression in C or C++ is said to have a side-effect if it changes the state of the system. Examples are assignments to a variable, or using a variable with the post-increment operator. The C and C++ standards state that a variable that is subject to a side-effect should not be used more that once in an expression. As an example, this statement violates that rule:

\[ *d++ = *d; \]

Signal
Signals provide event-based communication between tasks. A task can wait for one or more signals from other tasks. Once a task receives a signal it waits for, execution continues. A task in an RTOS that waits for a signal does not use any processing time, which allows other tasks to execute.

Simple format
The Simple output format is a format that supplies the bytes of the application in a way that is easy to manipulate. If you want to modify the contents of some addresses in the application but the standard linker options are not sufficient, use the Simple output format. Generate the application in the Simple format and then write a small utility (example source code is delivered with XLINK) that modifies the output.

Simulator
A debugging tool that runs on the host and behaves as similar to the target processor as possible. A simulator is used for debugging the application when the hardware is unavailable, or not needed for proper debugging. A simulator is usually not connected to any physical peripheral devices. A simulated processor is often slower, or even much slower, than the real hardware.

Single stepping
Executing one instruction or one C statement at a time in the debugger.

Skeleton code
An incomplete code framework that allows the user to specialize the code.
Special function register (SFR)
A register that is used to read and write to the hardware components of the microcontroller.

Stack frames
Data structures containing data objects like preserved registers, local variables, and other data objects that must be stored temporary for a particular scope (usually a function).

Earlier compilers usually had a fixed size and layout on a stack frame throughout a complete function, while modern compilers might have a very dynamic layout and size that can change anywhere and anytime in a function.

Stack segments
The segment or segments that reserve space for the stack(s). Most processors use the same stack for calls and parameters, but some have separate stacks.

Standard libraries
The C and C++ library functions as specified by the C and C++ standard, and support routines for the compiler, like floating-point routines.

Static object
An object whose memory is allocated at link-time and is created during system startup (or at first use). Compare Dynamic object.

Static overlay
Instead of using a dynamic allocation scheme for parameters and auto variables, the linker allocates space for parameters and auto variables at link time. This generates a worst-case scenario of stack usage, but might be preferable for small chips with expensive stack access or no stack access at all.

Statically allocated memory
This kind of memory is allocated once and for all at link-time, and remains valid all through the execution of the application. Variables that are either global or declared static are allocated this way.

Structure value
A collecting names for structs and unions. A struct is a collection of data object placed sequentially in memory (possibly with pad bytes between them). A union is a collection of data sharing the same memory location.

Symbolic location
A location that uses a symbolic name because the exact address is unknown.

T
Target
1. An architecture. 2. A piece of hardware. The particular embedded system you are developing the application for. The term is usually used to distinguish the system from the host system.

Task (thread)
A task is an execution thread in a system. Systems that contain many tasks that execute in parallel are called multitasking systems. Because a processor only executes one instruction stream at the time, most systems implement some sort of task-switch mechanism (often called context switch) so that all tasks get their share of processing time. The process of determining which task that should be allowed to run next is called scheduling. Two common scheduling methods are Pre-emptive multitasking and Round Robin.

Tentative definition
A variable that can be defined in multiple files, provided that the definition is identical and that it is an absolute variable.

Terminal I/O
A simulated terminal window in C-SPY.

Timer
A peripheral that counts independent of the program execution.

Timeslice
The (longest) time an RTOS allows a task to run without running the task-scheduling algorithm. A task might be allowed to execute during several consecutive timeslices before being switched out. A task might also not be allowed to use its entire time slice, for example if, in a preemptive system, a higher priority task is activated by an interrupt.
Translation unit
A source file together with all the header files and source files included via the preprocessor directive \texttt{#include}, except for the lines skipped by conditional preprocessor directives such as \texttt{#if} and \texttt{#ifdef}.

Trap
A trap is an interrupt initiated by inserting a special instruction into the instruction stream. Many systems use traps to call operating system functions. Another name for trap is software interrupt.

Type qualifiers
In Standard C/C++, \texttt{const} or \texttt{volatile}. IAR Systems compilers usually add target-specific type qualifiers for memory and other type attributes.

Volatile storage
Data stored in a volatile storage device is not retained when the power to the device is turned off. To preserve data during a power-down cycle, you should store it in non-volatile storage. This should not be confused with the C keyword \texttt{volatile}. Compare \texttt{Non-volatile storage}.

von Neumann architecture
A computer architecture where both instructions and data are transferred over a common data channel. Compare \texttt{Harvard architecture}.

Watchpoints
Watchpoints keep track of the values of C variables or expressions in the C-SPY \texttt{Watch} window as the application is being executed.

X

XAR
An IAR tool that creates archives (libraries) in the UBROF format. XAR is delivered with IAR Embedded Workbench.

XLIB
An IAR tool that creates archives (libraries) in the UBROF format, listing object code, converting and absolute object file into an absolute object file in another format. XLIB is delivered with IAR Embedded Workbench.

XLINK
The IAR XLINK Linker which uses the UBROF output format.

Zero-initialized segments
Segments that should be initialized to zero at startup. See also \texttt{Segment}.
Zero-overhead loop
A loop in which the loop condition, including branching back to the beginning of the loop, does not take any time at all. This is usually implemented as a special hardware feature of the processor and is not available in all architectures.

Zone
Different processors have widely differing memory architectures. Zone is the term C-SPY uses for a named memory area. For example, on processors with separately addressable code and data memory there would be at least two zones. A processor with an intricate banked memory scheme might have several zones.
A

assembler options, definition of .................................. 241
absolute location, definition of .................................. 241
absolute segments, definition of .................................. 241
accelerator keys. See shortcut keys
Add Files (Workspace window context menu) .................. 92
Add Group (Workspace window context menu) .............. 92
Add Project Connection dialog box (Project menu) ....... 95
Add (Subversion control menu) .................................. 101
Additional include directories (preprocessor option) 205, 215
Additional input files (custom build option) ................. 220
address expression, definition of ................................ 241
address range check, specifying in linker ..................... 233
Algorithm (Generate checksum setting) .......................... 235
Alias (Key bindings option) ...................................... 41
Align (Raw binary image setting) ................................. 225
Alignment (Generate checksum setting) .......................... 235
All warnings (Warning setting) .................................... 216
Allow C-SPY-specific output file (Format setting) .......... 227
Allow VLA (C dialect setting) ..................................... 197
Always generate output (linker option) ......................... 233
Ambiguous Definitions (View menu) ............................ 146
ANSI C. See C89
application, definition of ........................................ 241
architecture, definition of ........................................ 241
argument variables .................................................. 68
custom .............................................................. 74
custom variables ..................................................... 73
environment variables ............................................. 73
in #include file paths ............................................. 205, 215
summary of predefined ............................................ 72
Arguments (External editor option) ............................... 47
Arithmetic sum (checksum algorithm) ............................ 236
asm (filename extension) ......................................... 163
Assembled lines only (Include listing setting) .................. 214
assembler comments, text style in editor ..................... 124
assembler directives
definition of .................................................. 241
text style in editor ................................................ 124
assembler language, definition of ............................... 241
assembler list files
compiler call frame information .................................. 205
conditional information, specifying ............................ 213
cross-references, generating ..................................... 214
generating .......................................................... 213
header, including .................................................. 213
lines per page, specifying ......................................... 214
tab spacing, specifying ............................................. 214
Assembler mnemonics (Output list file setting) .......... 204
assembler options .................................................. 211
Diagnostics .......................................................... 216
Language ............................................................ 211
List ................................................................. 213
Output ............................................................. 212
assembler options, definition of ............................... 241
assembler output, including debug information .............. 212
Assembler source file (Workspace window icon) .......... 90
assembler, command line version ................................ 23
assert, in built applications ...................................... 80
assumptions, programming experience ......................... 15
Auto code completion and parameter hints (editor option) .45
Auto indent (editor option) ....................................... 44
Auto (Language setting) ......................................... 197
a51 (filename extension) ......................................... 163

B

Background color (IDE Tools option) ......................... 50
backtrace information, definition of ........................... 241
Bank end (code bank option) .................................... 190
Bank start (code bank option) .................................. 190
bank switching, definition of .................................. 241
banked code, definition of ...................................... 241
banked data, definition of ...................................... 241
banked memory, definition of .................................. 241
bank-switching routines, definition of ......................... 242
Base (Register filter option) .................................... 65
code memory, filling unused ......................... 235
Code model (general option) .......................... 184
code model, definition of ................................ 242
Code page (compiler options) .......................... 200
code pointers, definition of ................................ 243
code sections, definition of ................................ 243
code templates, using in editor ......................... 122
colors in C-SPY windows, switching on or off ......... 60
command line options
   specifying from the Tools menu ....................... 31
   typographic convention ................................ 19
Command line (custom build option) .................. 220
command prompt icon, in this guide .................... 19
Command (External editor option) ...................... 48
Commit (Subversion control menu) ...................... 101
Common Fonts (IDE Options dialog box) ................. 39
common (directory) ...................................... 163
Compare (Source code control menu) ..................... 97
Compile (Workspace window context menu) ............... 92
compiler diagnostics ...................................... 92
compiler list files
   assembler mnemonics, including ....................... 204
   generating ............................................ 204
   source code, including ................................ 204
compiler options ........................................ 195
   definition of ........................................ 243
   Code ................................................... 200
   Diagnostics .......................................... 206
   Language 1 ........................................... 196
   Language 2 ........................................... 199
   List ................................................... 204
   MISRA C .............................................. 208
   Optimizations ......................................... 201
   Output ............................................... 202
   Preprocessor ......................................... 205, 215
compiler output
   including debug information ......................... 203
   module name .......................................... 203
   overriding default directory for ...................... 191
   program or library .................................... 203
   compiler preprocessor .................................. 205, 215
   compiler symbols, defining ............................ 205, 215
   compiler, command line version ....................... 23
   Complement (Generate checksum setting) ............... 236
   computer style, typographic convention ................ 19
   Config (linker options) ................................ 224
   Configuration file (general option) .................... 192
   Configurations for project dialog box (Project menu) . 94
   Configure Auto Indent (IDE Options dialog box) .... 46
   Configure Custom Argument Variables dialog box .... 74
   Configure Tools (Tools menu) ......................... 66
   Configure Viewers dialog box (Tools menu) .......... 68
   SCONFIG_NAMES (argument variable) .................... 72
   config, common (subdirectory) ......................... 163
   config, 8051 (subdirectory) ............................ 162
   Connect Project to SCC Project
      (Source code control menu) ......................... 97
   Connect Project to SVN Project
      (Subversion control menu) ......................... 102
   context menu, definition of ............................ 243
   Control file (Workspace window icon) .................. 90
   conventions, used in this guide ....................... 18
   copyright notice ...................................... 18
   correcting errors found during build .................. 2
   cost. See memory access cost .......................... 107
   cpp (filename extension) ................................ 163
   CPU core (Device information setting) ................. 184
   CRC polynomial (checksum algorithm) .................. 236
   CRC, definition of ................................... 243
   CRC16 (checksum algorithm) ............................ 236
   CRC32 (checksum algorithm) ............................ 236
   Create New Project dialog box (Project menu) ......... 93
   Cross-reference (assembler option) .................... 214
   cstartup (system startup code) ........................ 214
   definition of ........................................ 243
   stack pointers not valid until reaching ............... 62
   SCUR_DIRS (argument variable) ......................... 72
   SCUR_LINES (argument variable) ......................... 72
custom build .................................................. 103
using ...................................................... 110
custom tool configuration ................................. 103
Custom Tool Configuration (custom build options) .... 219
custom variables, as argument variables ................. 73
C-SPY options
  definition of ........................................... 243
C-style preprocessor, definition of .................... 243
C/C++ syntax
  enabling in compiler .................................. 197
  options for styles .................................... 49
C++ comments, text style in editor .................... 124
C++ dialect (compiler option) ........................ 198
C++ inline semantics (C dialect setting) ............ 197
C++ keywords, text style in editor .................... 124
C++ source file (Workspace window icon) ............ 90
C++ terminology ......................................... 18
C++ (Language setting) .................................. 197
C89 (C dialect setting) .................................. 197
C99 (C dialect setting) .................................. 197

D
dat (filename extension) .............................. 164–165
Data model (general option) .......................... 185
data model, definition of ............................... 243
Data Pointer (general options) ........................ 187
data pointers, definition of ............................. 243
data representation, definition of .................... 243
$DATE$ (argument variable) .......................... 72
dbg (filename extension) ................................ 164
dbgdt (filename extension) ............................. 164
ddf (filename extension) ................................ 164
debug information
  generating in assembler ............................... 213
  in compiler, generating .............................. 203
Debug information for C-SPY (Format setting) ........ 226
Debug (Configuration factory setting) ................. 95
Debugger (IDE Options factory setting) ............... 59
Declarations window (View menu) .................... 145
declaration, definition of .............................. 243
default installation path ............................... 161
Default integer format (IDE option) .................. 160
#define options (linker options) ..................... 232
define (linker options) ................................ 232
Defined by application (Override default program entry setting) ............................. 224
Defined symbols (compiler option) ................. 206, 215
Defined symbols (linker option) .................... 232
definition, definition of ............................... 244
dep (filename extension) .............................. 164
Destroy static objects (C++ dialect setting) ........ 198
development environment, introduction ............... 23
device description files ................................ 162
definition of ........................................... 244
device driver, definition of ............................ 244
Device information (general option) .................. 184
device selection files .................................. 162
Device (Device information setting) .................. 184
diagnostics compiler
  including in list file .................................. 204
  linker, suppressing ................................... 234
  suppressing .......................................... 207
Diagnostics (assembler options) ....................... 216
Diagnostics (compiler options) ........................ 206
Diagnostics (linker options) .......................... 233
Diff (Subversion control menu) ....................... 101
digital signal processor, definition of ............... 244
directories
  common .............................................. 163
  compiler, ignore standard include .......................... 205, 215
  root ............................................... 161
  8051 .............................................. 161
directory structure ..................................... 161
Disable all warnings (assembler option) ............ 197
Disable language extensions (Language conformance setting) ............................. 217
Disassembly window, definition of .............................. 244
Discard Unused Publics (multi-file compilation setting) ........ 196
disclaimer .................................................................... 2
Disconnect Project from SCC Project
(Source code control menu) ........................................ 97
Disconnect Project from SVN Project
(Subversion control menu) .......................................... 102
DLIB
documentation ............................................................. 17
naming convention ........................................................ 20
specifying ..................................................................... 191
dni (filename extension) .................................................. 164
dockable windows .......................................................... 25
document conventions .................................................... 18
documentation .............................................................. 161
online ........................................................................... 162
overview of guides ........................................................ 17
overview of this guide .................................................... 16
this guide ..................................................................... 15
doc, common (subdirectory) ............................................. 163
doc, 8051 (subdirectory) ................................................ 162
DPTR addresses (general option) ..................................... 188
DPTR select (general option) ........................................... 188
drag-and-drop
of files in workspace window ......................................... 82
text in editor window ...................................................... 120
drivers, 8051 (subdirectory) ............................................ 162
DSP. See digital signal processor
Dual line spacing (Include cross-reference setting) .............. 214
DWARF, definition of .................................................... 244
Dynamic Data Exchange (DDE) ..................................... 31
calling external editor ..................................................... 47
dynamic initialization, definition of ................................. 244
dynamic memory allocation, definition of ......................... 244
dynamic object, definition of .......................................... 244
d51 (filename extension) ................................................. 164

disable (Warning setting) ............................................... 216
Disabled (Range checks setting) ...................................... 234

disclaimer .................................................................... 2

disco (filename extension) .............................................. 164
dockable windows .......................................................... 25
document conventions .................................................... 18
documentation .............................................................. 161
document conventions .................................................... 18

dockable windows .......................................................... 25
document conventions .................................................... 18
documentation .............................................................. 161
online ........................................................................... 162
overview of guides ........................................................ 17
overview of this guide .................................................... 16
this guide ..................................................................... 15
doc, common (subdirectory) ............................................. 163
doc, 8051 (subdirectory) ................................................ 162
DPTR addresses (general option) ..................................... 188
DPTR select (general option) ........................................... 188
drag-and-drop
of files in workspace window ......................................... 82
text in editor window ...................................................... 120
drivers, 8051 (subdirectory) ............................................ 162
DSP. See digital signal processor
Dual line spacing (Include cross-reference setting) .............. 214
DWARF, definition of .................................................... 244
Dynamic Data Exchange (DDE) ..................................... 31
calling external editor ..................................................... 47
dynamic initialization, definition of ................................. 244
dynamic memory allocation, definition of ......................... 244
dynamic object, definition of .......................................... 244
d51 (filename extension) ................................................. 164
Embedded C++ (C++ dialect setting) ............................. 198
embedded system, definition of ................................. 245
Embedded Workbench
  editor ...................................................... 117
  layout .................................................... 25
  main window ............................................. 35
  reference information .................................... 167
  running ................................................... 26
  version number, displaying ............................... 182
  emulator (C-SPY driver), definition of .................. 245
Enable graphical stack display and stack usage
  tracking (Stack option) .................................. 61
Enable multibyte support (assembler option) ............ 212
Enable multibyte support (compiler option) ............... 200
Enable project connections (IDE Project options) ........ 54
Enable remarks (compiler option) ........................... 207
Enable virtual space (editor option) ........................ 45
Enable warnings or range of warnings (assembler option) 217
Enable (Warning setting) .................................... 216
Enabled transformations (compiler option) ................. 202
encoding, editor options .................................... 43
Entry symbol (Override default program entry setting) ... 224
enumeration, definition of .................................. 245
environment variables, as argument variables .............. 73
EOL character (editor option) ................................ 44
EPROM, definition of ....................................... 245
error messages
  compiler ................................................... 207
effects, correcting ......................................... 107
ewd (filename extension) ................................... 164
ewp (filename extension) ................................... 164
ewplugin (filename extension) ............................... 164
eww (filename extension) .................................. 164
  the workspace file ...................................... 26
$EW_DIRS (argument variable) ............................... 73
examples, 8051 (subdirectory) ............................. 162
exceptions, definition of .................................. 245
executable image, definition of ............................. 245
Executable (Output file setting) .............................. 190
Executables/libraries (output directory setting) ........ 191
$EXE_DIRS (argument variable) .............................. 73
expensive memory access, definition of ................... 245
extended command line file ................................. 165
Extended Embedded C++ syntax, enabling in compiler ... 198
extended keywords, definition of ........................... 245
Extended stack pointer address (general option) ........ 187
Extended stack pointer is a offset (general option) .... 187
Extended stack pointer mask (general option) .......... 187
extensions. See filename extensions or language extensions
  External Analyzer (IDE Options dialog box) ............ 54, 56
  External Editor (IDE Options dialog box) ............... 47
  external editor, using .................................. 31
Extra Options, specifying command
  line options .............................................. 208, 217, 237
Extra Output (linker options) ............................... 228
Factory settings, restoring default settings .............. 107
File Encoding (editor option) .............................. 43
file extensions. See filename extensions
  File format (linker option) ............................... 230
File menu .................................................. 167
File Properties (Workspace window context menu) ........ 92
file types
  device description ...................................... 162
device selection .......................................... 162
documentation ............................................. 162
drivers ..................................................... 162
extended command line ..................................... 165
header ....................................................... 162
include .................................................... 162
library ..................................................... 162
linker configuration files ................................ 162
map ......................................................... 162
project templates .......................................... 162
readme ...................................................... 162
syntax coloring configuration .............................. 162
File (Raw binary image setting) .............................. 225

IDE Project Management and Building Guide

for 8051
filename extensions ............................................. 163
  cfg, syntax highlighting .................................. 49
eww, the workspace file ..................................... 26
  other than default ....................................... 27
Filename Extensions dialog box (Tools menu) ............ 70
Filename Extensions Overrides dialog box (Tools menu) .... 71
Filename extensions (custom build option) .............. 219
files 
editing ...................................................... 118
  navigating among .................................... 79
$FILE_DIRS (argument variable) .......................... 73
$FILE_Fnames (argument variable) ......................... 73
$FILE_PATHS (argument variable) ........................ 73
Fill pattern (Fill setting) .................................. 235
Fill unused code memory (linker option) ................. 235
filling, definition of ................................... 245
Filter Files (Register filter option) ......................... 64
Find All References window (View menu) .................. 152
Find dialog box (Edit menu) ................................ 137
Find in Files dialog box (Edit menu) ...................... 140
Find in Files window (View menu) ......................... 138
Fixed width font (IDE option) .............................. 39
floating windows ......................................... 25
floating-point expressions, improving performance ...... 199
Floating-point semantics (compiler option) ............. 199
fmt (filename extension) .................................. 164
font 
  Editor ..................................................... 49
  Fixed width .......................................... 39
  Proportional width .................................. 39
format specifiers, definition of .......................... 245
Format variant (Format setting) ............................ 227, 229
Format (linker option) .................................... 226, 229
formats 
  linker output 
    default, overriding .................................. 227
    specifying .......................................... 226
functions 
intrinsic, definition of .................................. 247
shortcut to in editor windows ............................. 125, 131

G

general options 
  Code Bank ............................................... 189
  Data Pointer .......................................... 187
  definition of ........................................ 245
  Library Configuration .................................. 191
  Library Options ....................................... 193
  MISRA C ................................................ 194
  Output .................................................. 190
  Stack/Heap options ................................... 186
  Target ................................................... 184
  Generate browse information (IDE Project options) .... 53
  Generate checksum (linker option) ...................... 235
  Generate debug information (assembler option) ....... 213
  Generate debug information (compiler option) ......... 203
  Generate errors (Range checks setting) ................ 234
  Generate extra output file (linker option) ............ 229
  Generate linker listing (linker option) ................. 230
  Generate warnings (Range checks setting) .............. 234
  Generate #line directives (Preprocessor output 
to file setting) ........................................... 206
generating extra output file ................................ 227
generic pointers, definition of ........................... 246
Get Latest Version (Source code control menu) .......... 97
glossary ...................................................... 241
Go to function (editor button) ............................ 125, 131
Go to Line dialog box ..................................... 171
gray padlock (source code control icon) .................. 100
Group excluded from the build (Workspace window icon) . 90
Group members (Register filter option) .................... 64
group members (Register filter option) .................... 64
Groups (Workspace window icon) .......................... 90
groups, definition of .................................... 81
H

h (filename extension) ......................... 164
Harvard architecture, definition of ............ 246
Header file (Workspace window icon) ........... 90
header files ..................................... 162
quick access to ................................ 126
heap memory, definition of .................... 246
Heap sizes (general option) .................... 187
heap size, definition of ....................... 246
Help menu ..................................... 97
helpfiles (filename extension) .................. 164
High, balanced (Level setting) .................. 201
High, size (Level setting) ...................... 201
High, speed (Level setting) ..................... 201
History (Source code control menu) ............ 97
host, definition of ................................ 246
htm (filename extension) ...................... 164
HTML text file (Workspace window icon) ........ 90
HTML (File format setting) .................... 231
html (filename extension) ...................... 164

I

i (filename extension) ......................... 164
iarbuild, building from the command line ........ 109
 iarIdePm.exe ................................. 26
icons ........................................... 126
in Workspace window ............................ 89
SVN states ..................................... 102
icons, in this guide ............................. 19
IDE ............................................. 246
definition of ................................... 246
overview ...................................... 23
IDE internal file (Workspace window icon) ....... 90
Ignore standard include directories (compiler option) 205, 215
ILINK .......................................... 246
definition of ................................... 246
inc (filename extension) ...................... 164

Include compiler call frame information (Output assembler file setting) .......... 205
include files .................................. 162
compiler, specifying path ....................... 205, 215
definition of .................................. 246
linker, specifying path ......................... 225
specifying path ................................ 205, 215
Include header (assembler option) ............ 213
Include listing (assembler option) ............. 213
Include source (Output assembler file setting) ........ 204
Include suppressed entries (linker option) ........ 230
Incremental Search dialog box (Edit menu) ....... 144
inc, 8051 (subdirectory) ....................... 162
Indent size (editor option) ..................... 42
Indent with spaces (Tab Key Function setting) .... 43
indentation, in editor .......................... 119
inherited settings, overriding .................. 107
ini (filename extension) ...................... 164
Initial value (Generate checksum setting) ...... 236
initialized sections, definition of .............. 246
inline assembler, definition of ................. 246
inlining, definition of ......................... 246
Insert tab (Tab Key Function setting) .......... 43–44
insertion point, shortcut key for moving ........ 125
installation directory ......................... 18
installation path, default ....................... 161
installed files .................................. 161
documentation .................................. 162
executable ..................................... 163
include ........................................ 162
library ......................................... 162
instruction mnemonics, definition of .......... 246
Integrated Development Environment (IDE) definition of ........................................ 246
Internal symbol (Include cross-reference setting) .......... 214
interrupt vector table, definition of .......... 246
interrupt vector, definition of ................. 246
interrupts ..................................... 246
definition of ................................... 246
nested, definition of ........................... 248
define ............................. 232
Diagnostics .......................... 233
Extra Output ............................. 228
List ..................................... 229
Log ..................................... 231
Output .................................. 226
linker symbols, defining .................. 232
list files
assembler
  compiler runtime information .......... 205
  conditional information, specifying .... 213
  cross-references, generating .......... 214
  header, including ..................... 213
  lines per page, specifying .......... 214
  tab spacing, specifying ............. 214
compiler
  assembler mnemonics, including ...... 204
  generating ........................... 204
  source code, including ............. 204
linker
  generating ........................... 230
  including segment map ............. 230
  specifying lines per page .......... 231
List files (Output directories setting) .... 191
List (assembler options) ................ 213
List (compiler options) ................ 204
List (linker options) ................... 229
$LIST_DIR$ (argument variable) .......... 73
location counter, definition of ......... 250
Location for constants and strings (general option) .... 186
-log ( iarbuild command line option) .... 110
log (filename extension) .............. 164
Log (linker options) ................... 231
Log (Subversion control menu) .......... 101
logical address, definition of .......... 254
Low (Level setting) ..................... 201
lst (filename extension) .............. 164
L-value, definition of ................. 247
M
mac (filename extension) ............... 164
Macro definitions (Include listing setting) .... 214
Macro execution info (Include listing setting) .... 214
Macro expansions (Include listing setting) .... 214
Macro quote characters (assembler option) .... 212
macros, definition of .................. 248
MAC, definition of ..................... 247
mailbox (RTOS), definition of .......... 248
-make ( iarbuild command line option) .... 109
Make before debugging (IDE Project options) .... 53
Make (Workspace window context menu) .... 91
map files, generating .................. 230
map (filename extension) .............. 164
Max number of errors (assembler option) .... 217
MDU. See Multiplication-Division Unit
Medium (Level setting) ................. 201
memory
  filling unused ...................... 235
  memory access cost, definition of .... 248
  memory area, definition of .......... 248
  memory bank, definition of .......... 248
  memory map, definition of .......... 248
  memory model, definition of .......... 248
  memory usage, summary of .......... 230
  menu bar ................................ 35
  menu (filename extension) .......... 165
Menu (Key bindings option) ............. 40
menus .................................. 167
Messages window, amount of output ...... 50
Messages (IDE Options dialog box) ...... 50
metadata (subdirectory) ............... 163
microcontroller, definition of .......... 248
microprocessor, definition of .......... 248
migration
  from earlier IAR compilers .......... 18
MISRA C
  compiler options ..................... 208
general options ......................................... 194
MISRA C, documentation ............................... 17
Module map (Symbols setting) ..................... 230
module name, specifying in compiler ............ 203
Module summary (linker option) .................. 230
Module type (compiler option) ..................... 203
modules, definition of ................................ 248
Module-local symbol (Format setting) .............. 227
Multiline code (Include listing setting) ............ 214
Multiplication-Division Unit, enable support for 185
Multiply and accumulate, definition of .......... 247
multitasking, definition of ........................... 249
multi-file compilation .................................. 195
definition of ........................................... 248

N
naming conventions ........................................ 19
NDEBUG, preprocessor symbol ...................... 80
nested interrupts, definition of .................... 248
New Configuration dialog box (Project menu) .... 94
New Group (Register filter option) ................. 64
No global type checking (linker option) .......... 233
No size constraints (Level setting) ................. 201
No source browser and build status updates when the IDE is not the foreground process (IDE Project options) 54
No UBROF messages in output file (code option) 200
None (Level setting) .................................... 201
None (Symbols setting) ................................ 230
non-banked memory, definition of ................. 249
non-initialized memory, definition of ............. 249
non-volatile memory, definition of ................. 249
NOP (assembler instruction), definition of ........ 249
no-init sections, definition of ..................... 249
Number of banks (code bank option) .............. 189
Number of DPTRs (general option) ................ 188
Number of virtual registers (general option) ...... 185

O
Object file or library (Workspace window icon) .... 90
object file (absolute), definition of ............... 249
object file (relocatable), definition of ............ 249
Object files (Output directories setting) ............ 200
Object module name (compiler option) ........... 203
object, definition of ................................ 249
SOBJ_DIR$ (argument variable) ..................... 73
online documentation available from Help menu . 182
target-specific, in directory ......................... 162
Open Containing Folder (editor window context menu) 130
Open Containing Folder (Workspace window context menu) 130
Open Workspace (File menu) ........................ 168
Opening Brace (a) (Configure auto indent option) 46
operator precedence, definition of ................. 249
operators, definition of ................................ 249
optimization levels, setting ......................... 201
Optimizations page (compiler options) .......... 201
Option name (category option) ...................... 95
options
assembler .............................................. 211
build actions .......................................... 221
compiler ................................................ 195
custom build .......................................... 219
editor ................................................... 42
library builder ........................................ 239
linker ................................................... 223
setup files for editor ................................ 48
Options dialog box (Project menu) ................. 112
using .................................................... 105
Options (Workspace window context menu) ........ 91
options, definition of ................................ 249
Other file (Workspace window icon) ............... 90
Other (Format setting) ................................ 227
output
assembler ........................................ 212
including debug information .................. 212
compiler ........................................... 202
including debug information .................. 203
formats ........................................... 226
debug (ubrof) .................................... 226
generating extra file ............................. 227
linker
  generating ...................................... 233
  specifying filename ........................... 226
  specifying filename on extra output ....... 229
preprocessor .................................... 206
Output assembler file (compiler option) .... 204
Output directories (general option) ......... 191
Output file (custom build option) ......... 220
Output file (general option) ................. 190
Output file (library builder options) ..... 240
Output file (linker option) .................... 226, 229
Output format (Format setting) .............. 227, 229
output image. See executable image
Output list file (assembler option) .......... 213
Output list file (compiler option) .......... 204
Output (assembler option) .................... 212
Output (compiler options) .................... 202
Output (general options) ..................... 190
Output (library builder options) .......... 240
Output (linker options) ...................... 226
Override default program entry (linker option) ......................... 224

P
Padding for ROM-monitor breakpoints (code option) .......... 200
padlock (source code control icon) ........... 100
Page register address (general option) ........... 189
parameter hint, in editor ........................ 121
parameters
typographic convention ....................... 19
when building from command line ............ 109
parentheses and brackets, matching (in editor) .................. 119
part number, of this guide ........................ 2
paths
compiler include files .......................... 205, 215
include files ..................................... 205, 215
linker include files ............................. 225
relative, in Embedded Workbench ............... 81, 130
source files ..................................... 130
pbd (filename extension) ....................... 165
pbi (filename extension) ....................... 165
peripheral units, definition of ................. 249
peripherals register. See SFR
pew (filename extension) ....................... 165
pipeline, definition of ........................ 249
Plain ‘char’ is (compiler option) ............. 199
Play a sound after build operations (IDE Project options) ...... 53
plugins
  common (subdirectory) ....................... 163
  definition of .................................. 249
pointers
  definition of .................................. 249
  warn when stack pointer is out of range .... 61
pop-up menu. See context menu
Post-build command line (build actions option) ............ 222
#pragma directive, definition of ............... 249
precedence, definition of ..................... 249
preemptive multitasking, definition of .......... 249
Preinclude file (compiler option) ............. 205
preprocessor
definition of. See C-style preprocessor
  macros for initializing string variables. .... 108
NDEBUG symbol ................................ 80
preprocessor directives
definition of ................................... 250
text style in editor ............................. 124
Preprocessor output to file (compiler option) ............. 206
Preprocessor (compiler options) ............... 205, 215
prerequisites, programming experience .......... 15
Preserve comments (Preprocessor output to file setting) ........ 206
Press shortcut key (Key bindings option) ............. 40
| Pre-build command line (build actions option) | 221 |
| Primary (Key bindings option) | 40 |
| Printf formatter (general option) | 193 |
| prj (filename extension) | 165 |
| processor variant, definition of | 250 |
| product overview | 115 |
| directory structure | 161 |
| file types | 163 |
| program counter, definition of | 250 |
| program location counter, definition of | 250 |
| Program Module (Module type setting) | 203 |
| programming experience | 15 |
| program, see also application | |
| Project Make, options | 52 |
| Project menu | 176 |
| project model | 77 |
| project options, definition of | 250 |
| Project page (IDE Options dialog box) | 52 |
| Project with multi-file compilation | 90 |
| (Workspace window icon) | |
| Project (Workspace window icon) | 89 |
| projects | 84 |
| adding files to | 84 |
| build configuration, creating | 84 |
| building | 107 |
| in batches | 109 |
| creating | 84 |
| definition of | 79, 250 |
| excluding groups and files | 84 |
| groups, creating | 84 |
| managing | 77 |
| organization | 79 |
| source code control | 82 |
| version control systems | 82 |
| workspace, creating | 84 |
| $PROJ_DIRS (argument variable) | 73 |
| $PROJ_FNAMES (argument variable) | 73 |
| $PROJ_PATHS (argument variable) | 73 |
| PROM, definition of | 250 |
| Properties (Source code control menu) | 97 |
| Properties (Subversion control menu) | 101 |
| Proportional width font (IDE option) | 39 |
| prototypes, verifying the existence of | 198 |
| publication date, of this guide | 2 |

**Q**

qualified, definition of. See type qualifiers

**R**

Range checks (linker option) | 233 |
range, definition of | 250 |
Raw binary image (linker option) | 225 |
reading guidelines | 15 |
readme files, See release notes |
read-only sections, definition of | 250 |
real-time operating system, definition of | 250 |
real-time system, definition of | 250 |
Rebuild All (Workspace window context menu) | 92 |
red padlock (source code control icon) | 100 |
reference information, typographic convention | 19 |
References window (View menu) | 147 |
Refresh (Source code control menu) | 97 |
Refresh (Subversion control menu) | 101 |
Register address (code bank option) | 189 |
register constant, definition of | 250 |
Register Filter (IDE Options dialog box) | 63 |
register locking, definition of | 250 |
Register mask (code bank option) | 190 |
register variables, definition of | 251 |
registered trademarks | 2 |
registers | |

definition of | 250 |
header files for in inc directory | 162 |
relative paths | 81, 130 |
release notes | 162 |
Release (Configuration factory setting) | 95 |
Reload last workspace at startup (IDE Project options) | 53 |
relocatable segments, definition of ........................................... 251
remarks, classifying diagnostics as ........................................... 207
Remove trailing blanks (editor option) ................................. 45
Remove (Workspace window context menu) ......................... 92
Rename Group dialog box ....................................................... 92
Rename (Workspace window context menu) ............................... 92
Replace dialog box (Edit menu) .............................................. 139
Replace in Files dialog box (Edit menu) ................................. 142
Require prototypes (C dialect setting) ........................................ 198
Replace in Files dialog box (Edit menu) ...................................... 142
Replace dialog box (Edit menu) .............................................. 139
Replace dialog box (Edit menu) .............................................. 139
Rename (Workspace window context menu) ............................... 92
reset, definition of ................................................................. 251
restoring default factory settings ............................................. 107
ROM-monitor, definition of ..................................................... 251
Root directory ............................................................................ 161
Round Robin, definition of ....................................................... 251
RTOS, definition of ................................................................. 250
runtime libraries
    definition of ........................................................................... 251
    specifying ........................................................................... 191
runtime model attributes, definition of ...................................... 251
r51 (filename extension) ............................................................. 165

S
saturation arithmetics, definition of ........................................... 251
Save All (File menu) ................................................................. 168
Save As (File menu) ................................................................. 168
Save editor windows before building (IDE Project options) ....... 52
Save workspace and projects before building (IDE Project options) ................................................................. 53
Save Workspace (File menu) ...................................................... 168
Save (File menu) ................................................................. 168
Scan for changed files (editor option) ........................................ 44
Scarf formatter (general option) ................................................ 193
SCC, See source code control systems ......................................... 251
scheduler (RTOS), definition of ................................................ 251
scope, definition of ................................................................. 251
scrolling, shortcut key for ......................................................... 125
Search paths (linker option) ...................................................... 225
searching in editor windows ..................................................... 127
Segment map (linker option) ...................................................... 230
Segment map, definition of ....................................................... 252
Segment overlap warnings (linker option) .................................. 233
segment parts, including all in list file ........................................ 230
segment part, definition of ....................................................... 252
Segment (Raw binary image setting) ........................................... 225
segments
    definition of ........................................................................... 252
    overlap errors, reducing ......................................................... 233
    range checks, controlling ......................................................... 233
    selecting text, shortcut key for ................................................ 125
    semaphores, definition of ......................................................... 252
    Separate DPTR control register (general option) ..................... 188
    Service (External editor option) ................................................ 48
    Set as Active (Workspace window context menu) ................... 92
    settings (directory) ................................................................. 165
    severity level
      changing default for compiler diagnostics .......................... 206
      changing default for linker diagnostics .............................. 233
      definition of ........................................................................... 252
SFR
    definition of ........................................................................... 253
    in header files ........................................................................... 162
    sharing, definition of ............................................................. 252
    short addressing, definition of ................................................ 252
    shortcut keys ........................................................................... 124
    customizing ........................................................................... 40
    Show bookmarks (editor option) .............................................. 45
    Show fold margin (editor option) .............................................. 45
    Show line break characters (editor option) ............................ 45
    Show line numbers (editor option) .......................................... 44
    Show right margin (editor option) ............................................ 43
    side-effect, definition of ........................................................ 252
    signals, definition of ............................................................. 252

IDE Project Management and Building Guide
for 8051
Simple format, definition of .......................... 252
simulator, definition of ............................... 252
size optimization ...................................... 201
Size (Generate checksum setting) .................... 235
Size (of DPTRs) (general option) .................... 188
skeleton code, definition of ......................... 252
Source Browser window ............................... 148
Source code using ...................................... 126
source code
including in compiler list file ....................... 204
templates ............................................ 122
Source code color in Disassembly window (IDE option) ........................ 59
source code control systems ........................ 82
Source Code Control (IDE Options dialog box) ..................... 58
Source file excluded from the build (Workspace window icon) ....................... 90
source files
editing .................................................. 118
managing in projects ................................ 81
paths to ............................................. 81, 130
special function registers (SFR)
definition of .......................................... 253
in header files ....................................... 162
specifying options for ................................ 195
src, 8051 (subdirectory) ................................ 162
stack frames, definition of ......................... 253
stack segment, definition of ....................... 253
Stack sizes (general option) ......................... 187
Stack (IDE Options dialog box) ........................ 61
Stack/Heap (general options) ....................... 186
Standard C
making compiler adhere to .......................... 197
syntax enabling in compiler ......................... 197
standard libraries, definition of .................... 253
Standard (Language conformance setting) ........ 197
static objects, definition of ......................... 253
Static overlay map (linker option) .................. 230
static overlay, definition of ......................... 253
statically allocated memory, definition of ........ 253
status bar .............................................. 37
Step into functions (IDE option) .................... 59
stepping, definition of ................................ 252
STL container expansion (IDE option) .............. 60
Stop build operation on (IDE Project options) .... 52
Stop Build (Workspace window context menu) .... 92
Strict (Language conformance setting) .............. 197
strings, text style in editor .......................... 124
structure value, definition of ....................... 253
Subversion states and corresponding icons .......... 102
Supress all warnings (linker option) ............... 234
Suppress these diagnostics (compiler option) .... 207
Suppress these diagnostics (linker option) ....... 234
Symbol listing (Symbols setting) .................... 230
Symbol (Raw binary image setting) .................. 225
symbolic location, definition of .................... 253
symbols
See also user symbols
defining in compiler .................................. 206, 215
defining in linker ...................................... 232
definition of .......................................... 253
Symbols (linker option) ............................... 230
syntax coloring
configuration files .................................... 162
in editor .............................................. 124
Syntax Coloring (Editor colors and fonts option) .................................. 50
Syntax highlighting (editor option) .................. 44
syntax highlighting, in editor window .............. 124
s51 (filename extension) ............................. 165

T

Tab Key Function (editor option) .................... 43
Tab size (editor option) .............................. 42
Tab spacing (assembler option) ..................... 214
Target (general options) ............................. 184
TARGET_BNAMES (argument variable) ............. 73
TARGET_BPATHS (argument variable) ............... 73
TARGET_DIRS (argument variable) ................. 73
$TARGET_FNAME$ (argument variable) 73
$TARGET_PATH$ (argument variable) 73
target, definition of 253
task, definition of 253
Template dialog box (Edit menu) 153
templates for code, using 122
tentative definition, definition of 253
Terminal I/O window, definition of 253
Terminal I/O (IDE Options dialog box) 65
terminal I/O, simulating 227
terminology 18, 241
testing, of code 107
Text file (Workspace window icon) 90
Text (File format setting) 230
thread, definition of 253
timer, definition of 253
timeslice, definition of 253
Tool Output window 38
toolbar, IDE 36
toolchain extending 103
overview 23
$TOOLKIT_DIRS$ (argument variable) 73
tools icon, in this guide 19
Tools menu 179
tools, user-configured 66
trademarks 2
transformations, enabled in compiler 202
translation unit, definition of 254
trap, definition of 254
Treat all warnings as errors (compiler option) 207
Treat these as errors (compiler option) 207
Treat these as errors (linker option) 234
Treat these as remarks (compiler option) 207
Treat these as warnings (compiler option) 207
Treat these as warnings (linker option) 234
tutor, 8051 (subdirectory) 162
type qualifiers, definition of 254
Type (External editor option) 47
type-checking, disabling at link time 233
typographic conventions 19

U

UBROF
creating output in 226
definition of 254
tool for generating 254
Undo Checkout (Source code control menu) 97
Update intervals (IDE option) 60
Update (Subversion control menu) 101
Use Code Templates (editor option) 49
Use colors (IDE option) 60
Use command line options (compiler option) 208, 217, 237
Use Custom Keyword File (editor option) 48
Use extended stack (general option) 185
Use External Editor (External editor option) 47
Use MDU (general option) 185
Use register filter (Register filter option) 64
User symbols are case sensitive (assembler option) 212
USERS=$USER_NAME$ (argument variable) 73

V

value expressions, definition of 254
variable length arrays 197
variables, using in arguments 68
version of this guide 2
Version Control System menu 96, 100
Version Control System (Workspace window context menu) 92
version control systems 82
version number of Embedded Workbench 182
View menu 173
virtual address, definition of 254
virtual space
  definition of ............................................. 254
  enabling in the editor .................................. 45
visualSTATE
  part of the tool chain ..................................... 24
  project file .................................................. 165
volatile storage, definition of ............................. 254
von Neumann architecture, definition of ................... 254
vsp (filename extension) ..................................... 165

W
Warn when exceeding stack threshold (Stack option) ... 61
Warn when stack pointer is out of bounds (Stack option) 61
warnings
  compiler .................................................... 207
  linker ......................................................... 234
Warnings from to (Warning setting) ......................... 216
warnings icon, in this guide ................................ 19
Warnings (assembler option) ................................ 216
warnings, disable ............................................. 216
Warnings/Errors (linker option) .............................. 234
Watchpoints, definition of .................................. 254
web sites, recommended ...................................... 18
When source resolves to multiple function instances ...... 59
Window menu .................................................... 181
windows
  about organizing on the screen ............................. 25
  how to organize on the screen ............................. 26
With I/O emulation modules (Format setting) ............... 227
With runtime control modules (Format setting) ............. 226
word completion, in editor .................................... 121
Workspace window .............................................. 89
drag-and-drop of files ......................................... 82
Workspace window icons ........................................ 89
Workspace (Workspace window icon) .......................... 89
workspaces
  creating ....................................................... 84
  using .......................................................... 83
wsdt (filename extension) ..................................... 165

X
XAR, definition of ............................................ 254
xcl (filename extension) ....................................... 165
XLIB, definition of ............................................ 254
XLINK, definition of ........................................... 254

Z
zero-initialized sections, definition of ..................... 254
zero-overhead loop, definition of ........................... 255
zone, definition of ............................................ 255

Symbols
#define options (linker options) ............................. 232
#define (Include cross-reference setting) .................. 214
#include text (Include listing setting) .................... 213
#pragma directive, definition of ........................... 249
% stack usage threshold (Stack option) .................... 61
SCONFIG_NAMES (argument variable) ......................... 72
SCUR_DIRS (argument variable) ............................... 72
SCUR_LINES (argument variable) ............................. 72
SDATES (argument variable) .................................. 72
SEW_DIRS (argument variable) ................................. 73
SEXE_DIRS (argument variable) ............................... 73
SFFILE_DIRS (argument variable) ............................. 73
SFFILE_FNAMES (argument variable) ......................... 73
SFFILE_PATHS (argument variable) .......................... 73
SLIST_DIRS (argument variable) .............................. 73
SOBJ_DIRS (argument variable) ............................... 73
SPROJ_DIRS (argument variable) .............................. 73
SPROJ_FNAMES (argument variable) .......................... 73
SPROJ_PATHS (argument variable) ............................ 73
TARGET_BNAMES (argument variable) ......................... 73
TARGET_BPATHS (argument variable) ......................... 73
$TARGET_DIRS$ (argument variable) ................. 73
$TARGET_FNAME$ (argument variable) ................. 73
$TARGET_PATHS$ (argument variable) ................. 73
$TOOLKIT_DIRS$ (argument variable) .................. 73
$USER_NAMES$ (argument variable) ................. 73

**Numerics**

8051 (directory) ................................. 161